Bug 199591 - [exp-run] openjdk8 as default jdk
Summary: [exp-run] openjdk8 as default jdk
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on: 203061 203123 203124 203125 203142 203143 203495 203506 203511 203513
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-21 19:46 UTC by Steve Wills
Modified: 2015-10-19 16:15 UTC (History)
4 users (show)

See Also:


Attachments
default jdk change patch (556 bytes, patch)
2015-04-21 19:46 UTC, Steve Wills
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2015-04-21 19:46:04 UTC
Created attachment 155820 [details]
default jdk change patch

please run exp-run with openjdk8 as default
Comment 1 Antoine Brodin freebsd_committer 2015-04-21 20:00:14 UTC
Take for exp-run
Comment 2 Antoine Brodin freebsd_committer 2015-04-22 20:34:27 UTC
Exp-run results:

http://package18.nyi.freebsd.org/jail.html?mastername=101amd64-default-PR199591

New failures:

+ {"origin"=>"databases/libgda5-jdbc", "pkgname"=>"libgda5-jdbc-5.2.2", "phase"=>"build", "errortype"=>"missing_header"}
+ {"origin"=>"databases/mysql-connector-java", "pkgname"=>"mysql-connector-java-5.1.35", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/hadoop2", "pkgname"=>"hadoop2-2.6.0", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/java-util-concurrent", "pkgname"=>"java-util-concurrent-1.3.4_2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/luajava", "pkgname"=>"luajava-1.1_2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/umlgraph", "pkgname"=>"umlgraph-5.6_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"java/eclipse-ecj", "pkgname"=>"eclipse-ecj-3.8.2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"java/jakarta-commons-collections", "pkgname"=>"jakarta-commons-collections-3.2.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"java/junit", "pkgname"=>"junit-4.11_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/racket", "pkgname"=>"racket-6.1_2", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"lang/racket-minimal", "pkgname"=>"racket-minimal-6.1_1", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"lang/x10", "pkgname"=>"x10-2.2.1_3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"mail/davmail", "pkgname"=>"davmail-4.5.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"math/jakarta-commons-math", "pkgname"=>"jakarta-commons-math-2.2_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net-im/jitsi", "pkgname"=>"jitsi-2.3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/openmq", "pkgname"=>"openmq-4.5.2.p.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/openmq-client", "pkgname"=>"openmq-client-4.5.2.p.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"print/pdf-renderer", "pkgname"=>"pdf-renderer-0.9.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"security/keynote", "pkgname"=>"keynote-2.3_1", "phase"=>"patch", "errortype"=>"???"}
+ {"origin"=>"security/quantis", "pkgname"=>"quantis-v13.11.08", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"www/helma", "pkgname"=>"helma-1.7.0_1", "phase"=>"build", "errortype"=>"???"}

Failure logs:

http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/libgda5-jdbc-5.2.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/mysql-connector-java-5.1.35.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/hadoop2-2.6.0.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/java-util-concurrent-1.3.4_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/luajava-1.1_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/umlgraph-5.6_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/eclipse-ecj-3.8.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/jakarta-commons-collections-3.2.1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/junit-4.11_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/racket-6.1_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/racket-minimal-6.1_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/x10-2.2.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/davmail-4.5.1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/jakarta-commons-math-2.2_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/jitsi-2.3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/openmq-4.5.2.p.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/openmq-client-4.5.2.p.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/pdf-renderer-0.9.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/keynote-2.3_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/quantis-v13.11.08.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-04-22_19h31m00s/logs/errors/helma-1.7.0_1.log

Note that the following ports make some other ports skipped:

java/junit: 13 skipped
java/jakarta-commons-collections: 5 skipped
devel/hadoop2: 5 skipped
print/pdf-renderer: 3 skipped
databases/mysql-connector-java: 1 skipped
Comment 3 Antoine Brodin freebsd_committer 2015-04-22 20:35:38 UTC
The racket failures may be random failures that are unrelated to openjdk
Comment 4 John Marino freebsd_committer 2015-04-29 11:51:29 UTC
so is the next step to limit most of those ports to openjdk 7?

By the way, junit is failing on openjdk7 currently for a different reason, and DF also is having trouble with libgda5-jdbc on openjdk7
Comment 5 John Marino freebsd_committer 2015-07-03 08:44:49 UTC
is the effort to switch to openjdk8 by default dead?  if not, what is the status?  Who is leading the charge?
Comment 6 Greg Lewis freebsd_committer 2015-07-03 20:11:23 UTC
This needs to get done.  I'll start looking at it later this week, but obviously the more the merrier.
Comment 7 Greg Lewis freebsd_committer 2015-07-03 20:22:55 UTC
Created a patch for mysql-connector-java (see related bug)
Comment 8 commit-hook freebsd_committer 2015-07-03 23:34:51 UTC
A commit references this bug:

Author: glewis
Date: Fri Jul  3 23:34:08 UTC 2015
New revision: 391286
URL: https://svnweb.freebsd.org/changeset/ports/391286

Log:
  . Mark this for deprecation.  These are early versions of what current JDKs
    have included in the java.util.concurrent package by default since Java 5.

  PR:		199591

Changes:
  head/devel/java-util-concurrent/Makefile
Comment 9 Greg Lewis freebsd_committer 2015-07-03 23:36:27 UTC
The error for databases/libgda5-jdbc makes it look like it would be broken for any version of openjdk.  I don't think this is worth worrying about.
Comment 10 Greg Lewis freebsd_committer 2015-07-03 23:36:56 UTC
Marked devel/java-util-concurrent for deprecation since it should just die.
Comment 11 Greg Lewis freebsd_committer 2015-07-03 23:38:27 UTC
java/junit has been updated to 4.12 and it's method of building has been changed.  It now works.
Comment 12 Greg Lewis freebsd_committer 2015-07-04 06:50:19 UTC
devel/hadoop2 fails even if I restrict it to Java 7.  However, I think that is because Maven will run using Java 8 with the switch to that as the default version and its execution of javadoc (where the build failure occurs) will use Java 8 too, regardless of what version of Java the Hadoop build wants to use.  I haven't absolutely confirmed that, but the error is identical and that is how Maven looks to work to me.

There is a newer version of Hadoop (2.7.0) which may support Java 8 and be a viable path forward there.  However, the hadoop2 port looks non-trivial to update (at least to me), so this will likely take some effort.
Comment 13 Greg Lewis freebsd_committer 2015-07-04 17:55:39 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201335 submitted for jakarta-commons-collections
Comment 14 Greg Lewis freebsd_committer 2015-07-04 22:36:18 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201347 submitted for mail/davmail
Comment 15 Greg Lewis freebsd_committer 2015-07-04 22:39:38 UTC
Several of these failures are due to doclint being on by default for Java 8 when running javadoc.  I think we'd get quite a few ports fixed if we were able to turn that off during port builds.  The way to do so is to add -Xdoclint:none to the command line when invoking javadoc.

What I'm considering is a flag that ports could set that would turn off doclint that we'd pass through to javadoc.  This likely means changes to javavmwrapper since I don't believe a lot of these ports use $JAVADOC that bsd.java.mk sets but instead directly invoke javadoc themselves.
Comment 16 Greg Lewis freebsd_committer 2015-07-05 06:24:56 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=201352 submitted for math/jakarta-commons-math
Comment 17 Greg Lewis freebsd_committer 2015-07-05 17:05:13 UTC
The failure for security/keynote looks to be either transient or have nothing to do with the Java 8 change.
Comment 18 Antoine Brodin freebsd_committer 2015-09-08 20:36:20 UTC
Take again
Comment 19 Antoine Brodin freebsd_committer 2015-09-10 13:07:46 UTC
Exp-run results on 10.1 amd64:

http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-PR199591&build=2015-09-10_05h33m30s

There are 15 new failures:

+ {"origin"=>"databases/hbase", "pkgname"=>"hbase-0.98.9", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"databases/libgda5-jdbc", "pkgname"=>"libgda5-jdbc-5.2.4", "phase"=>"build", "errortype"=>"missing_header"}
+ {"origin"=>"devel/luajava", "pkgname"=>"luajava-1.1_2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"devel/umlgraph", "pkgname"=>"umlgraph-5.6_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"editors/openoffice-4", "pkgname"=>"apache-openoffice-4.1.1_13", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/jogl", "pkgname"=>"jogl-1.1.1_5", "phase"=>"package", "errortype"=>"???"}
+ {"origin"=>"java/eclipse-ecj", "pkgname"=>"eclipse-ecj-3.8.2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/x10", "pkgname"=>"x10-2.2.1_3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"math/scilab", "pkgname"=>"scilab-5.5.2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net-im/jitsi", "pkgname"=>"jitsi-2.3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/openmq", "pkgname"=>"openmq-4.5.2.p.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/openmq-client", "pkgname"=>"openmq-client-4.5.2.p.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"print/pdf-renderer", "pkgname"=>"pdf-renderer-0.9.1,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"security/quantis", "pkgname"=>"quantis-v13.11.08", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"www/helma", "pkgname"=>"helma-1.7.0_1", "phase"=>"build", "errortype"=>"???"}

Failure logs:

http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/hbase-0.98.9.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/libgda5-jdbc-5.2.4.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/luajava-1.1_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/umlgraph-5.6_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/apache-openoffice-4.1.1_13.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/jogl-1.1.1_5.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/eclipse-ecj-3.8.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/x10-2.2.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/scilab-5.5.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/jitsi-2.3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/openmq-4.5.2.p.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/openmq-client-4.5.2.p.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/pdf-renderer-0.9.1,1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/quantis-v13.11.08.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR199591/2015-09-10_05h33m30s/logs/errors/helma-1.7.0_1.log
Comment 20 Greg Lewis freebsd_committer 2015-09-12 19:21:45 UTC
Fix for luajava is in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=203061
Comment 21 Steve Wills freebsd_committer 2015-09-15 13:34:29 UTC
Fix for print/pdf-renderer is in PR 203123
Comment 22 Steve Wills freebsd_committer 2015-09-15 13:36:14 UTC
fix for devel/umlgraph is in bug 203124
Comment 23 Steve Wills freebsd_committer 2015-09-15 13:37:46 UTC
fix for jitsi is in bug 203125
Comment 24 commit-hook freebsd_committer 2015-09-16 11:10:36 UTC
A commit references this bug:

Author: kwm
Date: Wed Sep 16 11:10:24 UTC 2015
New revision: 397054
URL: https://svnweb.freebsd.org/changeset/ports/397054

Log:
  Allow libgda5-jdbc to build with openjdk8.

  PR:		199591 (openjdk8 by default exp-run)
  Submitted by:	swills@

Changes:
  head/databases/libgda5/Makefile
Comment 25 Steve Wills freebsd_committer 2015-10-16 18:28:33 UTC
I believe all the issues are solved now. Shall we have one more exp-run or should we just do it?
Comment 27 Antoine Brodin freebsd_committer 2015-10-17 06:11:12 UTC
When I wrote "came back from openoffice-4" I meant this commit:

r398790 | truckman | 2015-10-08 01:09:38 +0000 (Thu, 08 Oct 2015) | 10 lines

Temporarily downgrade the openoffice-devel port from the upstream trunk
branch to 4.1.2-RC1 in order to give the latter wider exposure before
4.1.2 is released.
Comment 29 Steve Wills freebsd_committer 2015-10-18 00:05:57 UTC
The remaining broken ones have been marked broken, I don't know how to fix them. If anyone else does, that would be great. So should we let any of those hold up the switch of the default? Or should we go ahead?
Comment 30 Don Lewis freebsd_committer 2015-10-18 00:13:49 UTC
I'm currently testing a fix for OpenOffice.  I hope to have something to commit by tomorrow.
Comment 31 Steve Wills freebsd_committer 2015-10-18 03:13:26 UTC
(In reply to Don Lewis from comment #30)
Awesome, thanks for the update!
Comment 32 commit-hook freebsd_committer 2015-10-18 08:18:43 UTC
A commit references this bug:

Author: truckman
Date: Sun Oct 18 08:18:26 UTC 2015
New revision: 399605
URL: https://svnweb.freebsd.org/changeset/ports/399605

Log:
  Patch the source with r1697228, r1697237, r1697247, r1697306, and
  r1697312 from upstream trunk (with a few tweaks to compensate for
  some other upstream changes not included here) to unbreak the build
  with OpenJDK8.

  Revert r399536 to unmark broken.

  PR:		199591 (openjdk8 by default exp-run)

Changes:
  head/editors/openoffice-4/Makefile
  head/editors/openoffice-4/files/patch-openjdk8
Comment 33 commit-hook freebsd_committer 2015-10-18 08:20:46 UTC
A commit references this bug:

Author: truckman
Date: Sun Oct 18 08:20:07 UTC 2015
New revision: 399606
URL: https://svnweb.freebsd.org/changeset/ports/399606

Log:
  Patch the source with r1697228, r1697237, r1697247, r1697306, and
  r1697312 from upstream trunk (with a few tweaks to compensate for
  some other upstream changes not included here) to unbreak the build
  with OpenJDK8.

  Revert r399537 to unmark broken.

  PR:		199591 (openjdk8 by default exp-run)

Changes:
  head/editors/openoffice-devel/Makefile
  head/editors/openoffice-devel/files/patch-openjdk8
Comment 34 Don Lewis freebsd_committer 2015-10-18 08:21:28 UTC
(In reply to Steve Wills from comment #31)
editors/openoffice-4 and editors/openoffice-devel should be fixed now.
Comment 35 Antoine Brodin freebsd_committer 2015-10-18 14:38:09 UTC
I confirm openoffice is fixed  (no more failures at http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-PR199591&build=2015-10-18_08h57m25s )
Comment 36 Steve Wills freebsd_committer 2015-10-19 16:15:13 UTC
Committed in r399693.