Bug 199627 - [MAINTAINER] multimedia/plexhometheater Fix build on FreeBSD 8+9
Summary: [MAINTAINER] multimedia/plexhometheater Fix build on FreeBSD 8+9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: http://beefy1.isc.freebsd.org/data/93...
Keywords:
: 199628 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-22 22:42 UTC by Ben Woods
Modified: 2015-04-24 19:05 UTC (History)
1 user (show)

See Also:


Attachments
Patch to fix build of multimedia/plexhometheater on FreeBSD 8+9 (892 bytes, patch)
2015-04-22 22:42 UTC, Ben Woods
no flags Details | Diff
Patch to fix build of multimedia/plexhometheater on FreeBSD 8+9 (894 bytes, patch)
2015-04-23 13:46 UTC, Ben Woods
no flags Details | Diff
Successful poudriere testport on FreeBSD 9.3 amd64 (gzipped) (114.70 KB, application/x-gzip)
2015-04-23 13:47 UTC, Ben Woods
no flags Details
Successful poudriere testport on FreeBSD 8.4 i386 (gzipped) (124.75 KB, application/x-gzip)
2015-04-24 09:01 UTC, Ben Woods
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Woods freebsd_committer 2015-04-22 22:42:38 UTC
Created attachment 155879 [details]
Patch to fix build of multimedia/plexhometheater on FreeBSD 8+9

Fix build on FreeBSD 8+9 for multimedia/plexhometheater.
The issue is __builtin_bswap32 and __builtin_bswap64 were not introduced in GCC until v4.3.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2015-04-23 03:17:52 UTC
*** Bug 199628 has been marked as a duplicate of this bug. ***
Comment 2 Ben Woods freebsd_committer 2015-04-23 13:46:24 UTC
Created attachment 155914 [details]
Patch to fix build of multimedia/plexhometheater on FreeBSD 8+9

Replace __builtin_bswap32 with __bswap32 instead of bswap32.
This uses the definition of __bswap32 in machine/endian.h
Comment 3 Ben Woods freebsd_committer 2015-04-23 13:47:10 UTC
Created attachment 155915 [details]
Successful poudriere testport on FreeBSD 9.3 amd64 (gzipped)
Comment 4 Ben Woods freebsd_committer 2015-04-24 09:01:12 UTC
Created attachment 155941 [details]
Successful poudriere testport on FreeBSD 8.4 i386 (gzipped)
Comment 5 commit-hook freebsd_committer 2015-04-24 19:03:49 UTC
A commit references this bug:

Author: adamw
Date: Fri Apr 24 19:03:44 UTC 2015
New revision: 384674
URL: https://svnweb.freebsd.org/changeset/ports/384674

Log:
  Fix build on FreeBSD 8 and 9.

  __builtin_bswap32 and __builtin_bswap64 were not introduced in GCC until v4.3.

  PR:		199627
  Submitted by:	maintainer (Ben Woods)

Changes:
  head/multimedia/plexhometheater/Makefile
Comment 6 Adam Weinberger freebsd_committer 2015-04-24 19:05:22 UTC
Committed. Next time, when adding a list of things (options, files, etc.) please keep them sorted. Helps with future maintainability.