Bug 199639 - print/libpaper: Distribution file libpaper_1.1.24+nmu3.tar.gz is missing from MASTER_SITES
Summary: print/libpaper: Distribution file libpaper_1.1.24+nmu3.tar.gz is missing from...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Johannes Jost Meixner
URL: http://mirror.crucial.com.au/debian/p...
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-04-23 09:26 UTC by David Harrigan
Modified: 2015-05-29 14:26 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)


Attachments
patch to bring the library up to nmu4 (747 bytes, patch)
2015-04-23 10:58 UTC, David Harrigan
koobs: maintainer-approval+
Details | Diff
Poudriere Test Results (23.68 KB, text/plain)
2015-04-24 07:58 UTC, David Harrigan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Harrigan 2015-04-23 09:26:08 UTC
Hi,

Recently trying to do an upgrade, and encountering this:

===>>> All >> git-2.3.5 >> textproc/xmlto >> print/libpaper (3/12)
 
===>>> Port directory: /usr/ports/print/libpaper
 
===>>> Starting check for build dependencies
===>>> Gathering dependency list for print/libpaper from ports
===>>> Dependency check complete for print/libpaper
 
===>>> All >> git-2.3.5 >> textproc/xmlto >> print/libpaper (3/12)
 
===>  Cleaning for libpaper-1.1.24.3
===>>> Waiting on fetch & checksum for print/libpaper <<<===
===>  License GPLv2 accepted by the user
===>   libpaper-1.1.24.3 depends on file: /usr/local/sbin/pkg - found
=> libpaper_1.1.24+nmu3.tar.gz doesn't seem to exist in /usr/ports/distfiles//.
=> Attempting to fetch ftp://ftp.uk.freebsd.org/pub/FreeBSD/ports/distfiles/libpaper_1.1.24+nmu3.tar.gz
fetch: ftp://ftp.uk.freebsd.org/pub/FreeBSD/ports/distfiles/libpaper_1.1.24+nmu3.tar.gz: Not Found
=> Attempting to fetch http://cdn.debian.net/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz
fetch: http://cdn.debian.net/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz: Not Found
=> Attempting to fetch http://www.gtlib.gatech.edu/pub/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz
fetch: http://www.gtlib.gatech.edu/pub/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz: Not Found
=> Attempting to fetch ftp://ftp.us.debian.org/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz

Eventually, it gives up, since the library is not found.

If I can be of any further assistance, please do let me know.

-=david=-
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-04-23 09:28:28 UTC
Confirmed. It appears that +nmu2 and +nmu4 exist, but the distfiles for +nmu3 are missing.

This likely requires a port update to 1.1.24.4 (1.1.24+nmu4)
Comment 2 David Harrigan 2015-04-23 10:58:27 UTC
Created attachment 155903 [details]
patch to bring the library up to nmu4

Hi,

Hope this helps. Tested using poudriere testport.

-=david=-
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-04-23 23:45:29 UTC
Great stuff David :)

If you could include the poudriere results as an attachment that would be great
Comment 4 David Harrigan 2015-04-24 07:58:47 UTC
Created attachment 155938 [details]
Poudriere Test Results

Test results from a Poudriere run:

pd testport -j freebsd10_1 -o print/libpaper > poudriere-testport.txt 2>&1
Comment 5 Franco Fichtner 2015-05-15 07:35:57 UTC
Was just about to push another PR with the same patch. Fixes the endless fetch fails. +1 for merge, thanks!
Comment 6 Hiroki Sato freebsd_committer 2015-05-15 07:44:18 UTC
Sorry for the delay.  I am working on it now and will fix this problem today.
Comment 7 David Harrigan 2015-05-16 08:37:29 UTC
Hi,

Any update on this? Still can't do a clean upgrade since I'm still getting these errors:

===>>> Waiting on fetch & checksum for print/libpaper <<<===
fetch: ftp://ftp.ie.debian.org/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz: Not Found
=> Attempting to fetch ftp://ftp.is.debian.org/debian/pool/main/libp/libpaper/libpaper_1.1.24+nmu3.tar.gz
fetch: ftp://ftp.is.debian.org/debian/pool/main/libp/libpape
...
...
...

and so on...

Thank you.

-=david=-
Comment 8 Franco Fichtner 2015-05-22 07:21:56 UTC
Gentle prodding... :)
Comment 9 Johannes Jost Meixner freebsd_committer 2015-05-29 14:13:07 UTC
I'll take this (maintainer timeout after 14 days).
Comment 10 commit-hook freebsd_committer 2015-05-29 14:18:56 UTC
A commit references this bug:

Author: xmj
Date: Fri May 29 14:18:21 UTC 2015
New revision: 387857
URL: https://svnweb.freebsd.org/changeset/ports/387857

Log:
  print/libpaper: update to 1.1.24.4

  - update to 1.1.24.4

  PR:		199639
  Submitted by:	David Harrigan <dharrigan@gmail.com>
  Approved by:	maintainer timeout (2 weeks)

Changes:
  head/print/libpaper/Makefile
  head/print/libpaper/distinfo
Comment 11 Johannes Jost Meixner freebsd_committer 2015-05-29 14:19:10 UTC
Committed, thanks!
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2015-05-29 14:26:13 UTC
Comment on attachment 155903 [details]
patch to bring the library up to nmu4

Maintainer timeout, implicit approval