Bug 199751 - databases/mysql56-server: Can't specify my.cnf path in /usr/local/etc/my.cnf or /etc/my.cnf
Summary: databases/mysql56-server: Can't specify my.cnf path in /usr/local/etc/my.cnf ...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Mark Felder
URL:
Keywords: needs-qa
Depends on: 216244
Blocks:
  Show dependency treegraph
 
Reported: 2015-04-28 07:40 UTC by Bleakwind
Modified: 2017-01-26 19:58 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (ale)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bleakwind 2015-04-28 07:40:32 UTC
databases/mysql56-server:
When I make install clean the ports, and put 
-------------------------------------------
mysql_enable="YES"
mysql_dbdir="/db/mysql"
mysql_optfile="/usr/local/etc/my.cnf"
-------------------------------------------
into /etc/rc.conf.

my.cnf path still in the directory /usr/local/my.cnf
Can't specify my.cnf path in /usr/local/etc/my.cnf or /etc/my.cnf.
Comment 1 Martin Waschbüsch 2015-10-25 21:42:08 UTC
Hi there,

I tried (without success) to reproduce this.
I tested this on FreeBSD 10.2-RELEASE-p5 amd64 on a clean ports tree.
The only option in /etc/make.conf that I set is:
DEVELOPER=yes

The steps were:

cd /usr/ports/databases/mysql56-server
make install clean

I then added the three lines you mentioned to /etc/rc.conf,
created /db/mysql - it will !not! be autocreated:
mkdir -p /db/mysql

then I ran:

service mysql-server start

when I now examine the command line mysql-server is running (ps ax | grep mysql | less), I can see that all parameters are set correctly:

/usr/local/libexec/mysqld --defaults-extra-file=/usr/local/etc/my.cnf --basedir=/usr/local --datadir=/db/mysql --plugin-dir=/usr/local/lib/mysql/plugin --log-error=/db/mysql/dev.waschbuesch.it.err --pid

dbdir is set to /db/mysql
defaults-extra-file is set to /usr/local/etc/my.cnf

So, all seems to be like it should be.

Does your build environment differ somehow?

Martin
Comment 2 commit-hook freebsd_committer 2017-01-19 22:29:54 UTC
A commit references this bug:

Author: feld
Date: Thu Jan 19 22:29:06 UTC 2017
New revision: 431919
URL: https://svnweb.freebsd.org/changeset/ports/431919

Log:
  databases/mysql56: Update to 5.6.35

  - Port improvements from MySQL 5.7 port
  - Use system libs instead of bundled
  - Fix many open PRs
  - Change MAINTAINER

  PR:		216244 192657 198812 199751 205093
  PR:		209618 211248 205983 209338

Changes:
  head/databases/mysql56-client/Makefile
  head/databases/mysql56-client/files/patch-CMakeLists.txt
  head/databases/mysql56-client/files/patch-extra_CMakeLists.txt
  head/databases/mysql56-client/files/patch-man_CMakeLists.txt
  head/databases/mysql56-client/files/patch-mysys_ssl_my_default.cc
  head/databases/mysql56-client/files/patch-scripts_CMakeLists.txt
  head/databases/mysql56-client/files/patch-support-files_CMakeLists.txt
  head/databases/mysql56-client/pkg-message
  head/databases/mysql56-server/Makefile
  head/databases/mysql56-server/distinfo
  head/databases/mysql56-server/files/my.cnf.sample.in
  head/databases/mysql56-server/files/mysql-server.in
  head/databases/mysql56-server/files/patch-mysys_ssl_my_default.cc
  head/databases/mysql56-server/pkg-message
  head/databases/mysql56-server/pkg-plist
Comment 3 commit-hook freebsd_committer 2017-01-26 19:58:28 UTC
A commit references this bug:

Author: brnrd
Date: Thu Jan 26 19:58:06 UTC 2017
New revision: 432535
URL: https://svnweb.freebsd.org/changeset/ports/432535

Log:
  MFH: r431919 r431968 r431975 r432035 r432066 r432458

  databases/mysql56: Update to 5.6.35

  - Port improvements from MySQL 5.7 port
  - Use system libs instead of bundled
  - Fix many open PRs
  - Change MAINTAINER

  PR:		216244 192657 198812 199751 205093
  PR:		209618 211248 205983 209338

  databases/mysql56-server: Rollback rc script changes

  databases/mysql56-server: Do not install my.cnf sample

  An issue was discovered where users of mysql did not have a my.cnf and
  the recent update was causing mysqld to find a sample my.cnf and load
  its parameters. This was causing errors on startup for users of innodb
  as the parameters used to init the database did not match the ones in
  the sample config file it was now reading.

  databases/mysql56-server: Fix build with LibreSSL

    - Fix CMake SSL detection
    - Always set WITH_SSL=${OPENSSLBASE}

  PR:		216311
  Approved by:	Mahdi Moktari <mokhi64@gmail.com> (maintainer)
  Differential Revision:	D9272

  Revert r432035 part 2, it breaks build with openssl from base

  With hat:	portmgr

  databases/mysql56-server: Fix OpenSSL linking

    - Force dynamic linking with OpenSSL

  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2017Q1/
  branches/2017Q1/databases/mysql56-client/Makefile
  branches/2017Q1/databases/mysql56-client/files/patch-CMakeLists.txt
  branches/2017Q1/databases/mysql56-client/files/patch-cmake_ssl.cmake
  branches/2017Q1/databases/mysql56-client/files/patch-extra_CMakeLists.txt
  branches/2017Q1/databases/mysql56-client/files/patch-man_CMakeLists.txt
  branches/2017Q1/databases/mysql56-client/files/patch-mysys_ssl_my_default.cc
  branches/2017Q1/databases/mysql56-client/files/patch-scripts_CMakeLists.txt
  branches/2017Q1/databases/mysql56-client/files/patch-support-files_CMakeLists.txt
  branches/2017Q1/databases/mysql56-client/pkg-message
  branches/2017Q1/databases/mysql56-server/Makefile
  branches/2017Q1/databases/mysql56-server/distinfo
  branches/2017Q1/databases/mysql56-server/files/my.cnf.sample.in
  branches/2017Q1/databases/mysql56-server/files/patch-cmake_ssl.cmake
  branches/2017Q1/databases/mysql56-server/files/patch-mysys_ssl_my_default.cc
  branches/2017Q1/databases/mysql56-server/pkg-message
  branches/2017Q1/databases/mysql56-server/pkg-plist