Bug 199845 - camlp4 is gone from lang/ocaml breaking some consumers (17 ports)
Summary: camlp4 is gone from lang/ocaml breaking some consumers (17 ports)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords: needs-patch, regression
Depends on: 195737 199847 199895
Blocks: 195736
  Show dependency treegraph
 
Reported: 2015-05-01 17:16 UTC by Jan Beich
Modified: 2015-05-16 07:37 UTC (History)
8 users (show)

See Also:
bugzilla: maintainer-feedback? (michipili)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Jan Beich freebsd_committer 2015-05-01 17:33:52 UTC
devel/ocaml-findlib was fixed by ports r385056.

CC'ing maintainers of yet to be fixed except unmaintained:

  astro/planets
  math/orpie
  net-p2p/liberator
  net-p2p/mldonkey-core
Comment 2 Jan Beich freebsd_committer 2015-05-01 19:09:56 UTC
deskutils/wyrd was fixed by ports r385141.
Comment 4 jaapb 2015-05-02 08:29:20 UTC
I don't use FreeBSD very much anymore, so I'm not really the best person to fix this. (As a corollary, if anyone wants to take over maintainership of any or all of the ports I'm still listed as maintainer of, they are most welcome to.)
Comment 5 Guido Falsi freebsd_committer 2015-05-03 09:49:21 UTC
Looks like camlp4 has been forked as a separate project:

https://github.com/ocaml/camlp4

I'm creating a port for that, will post patches as soon as I have something workable. Should fix ports needing it.
Comment 6 Guido Falsi freebsd_committer 2015-05-03 12:31:08 UTC
Turns out there already is a ocaml-camlp4 port. It helps> I have made a quick test and adding it as a dependency to ocaml-lablgl makes the build proceed.

It anyway fails since the TK bits too are now missing.

The labltk part was also moved to a standalone project:

https://forge.ocamlcore.org/projects/labltk/

I'm porting that, which is proving a little difficult since it's build system has no notion of staging/DESTDIR.
Comment 7 Michael Grünewald 2015-05-03 12:59:56 UTC
There is already a port for labltk in the works, see #195737.

  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195736#c2

The labltk port is not perfect yet, but it works quite a bit as I have
this working on my system since months.
Comment 8 Guido Falsi freebsd_committer 2015-05-03 17:37:09 UTC
I submitted a patch as a differential review which fixes this problem, after the other blocking PRs get committed, please check it here:

https://reviews.freebsd.org/D2434
Comment 9 commit-hook freebsd_committer 2015-05-04 15:47:57 UTC
A commit references this bug:

Author: madpilot
Date: Mon May  4 15:47:02 UTC 2015
New revision: 385413
URL: https://svnweb.freebsd.org/changeset/ports/385413

Log:
  - Add USE_OCAML_CAMLP4 and USE_OCAML_TK to bsd.ocaml.mk which add
    depends on the camlp4 language and labltk ocaml modules, which are
    now in separate ports.
  - Update x11-toolkits/ocaml-lablgtk2 to 2.18.3
  - Update graphics/ocaml-lablgl to 1.05
  - Make unison ports use USE_OCAML
  - Convert ports to the new flags where needed
  - Bump PORTREVISION on ports depending on ocaml-lablgtk2, those need to be rebuilt

  PR:			199845
  Submitted by:		jbeich@
  Differential Revision:	https://reviews.freebsd.org/D2434
  Approved by:		portmgr (mat)

Changes:
  head/Mk/bsd.ocaml.mk
  head/astro/planets/Makefile
  head/databases/ocaml-mysql/Makefile
  head/deskutils/wyrd/Makefile
  head/devel/coccinelle/Makefile
  head/devel/frama-c/Makefile
  head/devel/monotone-viz/Makefile
  head/devel/ocaml-camomile/Makefile
  head/devel/ocaml-deriving-ocsigen/Makefile
  head/devel/ocaml-extlib/Makefile
  head/devel/ocaml-typeconv/Makefile
  head/devel/ocaml-ulex/Makefile
  head/devel/ocaml-xstrp4/Makefile
  head/games/freetennis/Makefile
  head/graphics/ocaml-lablgl/Makefile
  head/graphics/ocaml-lablgl/distinfo
  head/graphics/ocaml-lablgl/pkg-descr
  head/graphics/ocaml-lablgl/pkg-plist
  head/math/alt-ergo/Makefile
  head/math/coq/Makefile
  head/math/ocaml-ocamlgraph/Makefile
  head/math/ocamlgsl/Makefile
  head/math/orpie/Makefile
  head/net/unison/Makefile
  head/net/unison-devel/Makefile
  head/net/unison232/Makefile
  head/net/unison240/Makefile
  head/net-p2p/liberator/Makefile
  head/net-p2p/mldonkey/Makefile
  head/security/sks/Makefile
  head/textproc/ocaml-text/Makefile
  head/www/ocaml-net/Makefile
  head/x11-toolkits/ocaml-lablgtk2/Makefile
  head/x11-toolkits/ocaml-lablgtk2/distinfo
  head/x11-toolkits/ocaml-lablgtk2/files/
Comment 10 Guido Falsi freebsd_committer 2015-05-04 15:51:20 UTC
r385413 fixes the problems listed here.

Please note that the net-p2p/mldonkey ports and www/ocaml-net ports still fail, but with unrelated errors, maybe due to changes in ocaml, the error is:

Error: This comment contains an unterminated string literal
Comment 11 commit-hook freebsd_committer 2015-05-12 11:59:17 UTC
A commit references this bug:

Author: jbeich
Date: Tue May 12 11:58:23 UTC 2015
New revision: 386137
URL: https://svnweb.freebsd.org/changeset/ports/386137

Log:
  Add camlp4 dependency after r385012 uncovered by r385413

  devel/ocaml-lwt (4 skipped) is still broken by another issue:

    File "src/top/toplevel.ml", line 60, characters 17-62:
    Error: This expression has type load:bool -> Path.t
           but an expression was expected of type 'a * 'b

  PR:		199845
  Reported by:	pkg-fallout
  Approved by:	portmgr blanket

Changes:
  head/devel/monotone-viz/Makefile
  head/devel/ocaml-lwt/Makefile
  head/devel/ocaml-sexplib/Makefile
  head/lang/mtasc/Makefile
Comment 12 Marcin Cieślak 2015-05-12 17:14:34 UTC
Thanks for fixing lang/mtasc so quickly!
Comment 13 Johan van Selst freebsd_committer 2015-05-14 12:19:40 UTC
(In reply to commit-hook from comment #11)

The issue with devel/ocaml-lwt appears unrelated to the camlp4 mishap. It seems that this version of ocaml-lwt does not work with the new ocaml version in our ports tree. Please open a new PR to track this. Thanks.
Comment 14 commit-hook freebsd_committer 2015-05-16 07:37:44 UTC
A commit references this bug:

Author: marino
Date: Sat May 16 07:37:26 UTC 2015
New revision: 386500
URL: https://svnweb.freebsd.org/changeset/ports/386500

Log:
  Reset 14 ocaml ports maintained by Jaap Boender per his request

  "I don't use FreeBSD very much anymore, so I'm not really the best person
   to fix this. (As a corollary, if anyone wants to take over maintainership
   of any or all of the ports, I'm still listed as maintainer of, they are
   most welcome to.)"

  Given that Jaap hasn't submitted or handled any PRs since before staging,
  I think it will be more effective to just reset all the ports and let
  people pick up the ones they like.  Thanks for your past support, Jaap!

  PR:	199845

Changes:
  head/archivers/ocaml-bz2/Makefile
  head/databases/ocaml-dbm/Makefile
  head/databases/ocaml-sqlite3/Makefile
  head/devel/ocaml-calendar/Makefile
  head/devel/ocaml-lwt/Makefile
  head/devel/ocaml-react/Makefile
  head/lang/js_of_ocaml/Makefile
  head/security/ocaml-cryptokit/Makefile
  head/security/ocaml-ssl/Makefile
  head/textproc/ocaml-text/Makefile
  head/textproc/ocaml-tyxml/Makefile
  head/www/eliom/Makefile
  head/www/ocaml-net/Makefile
  head/www/ocsigen/Makefile