Bug 199856 - net-p2p/bitcoin: Update to v0.10.1, resolve issue 198826
Summary: net-p2p/bitcoin: Update to v0.10.1, resolve issue 198826
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jan Beich
URL:
Keywords:
: 199857 199858 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-02 07:42 UTC by robbak
Modified: 2015-05-03 17:02 UTC (History)
0 users

See Also:


Attachments
Patch to update to 0.10.1 (1.87 KB, patch)
2015-05-02 07:42 UTC, robbak
robbak: maintainer-approval+
Details | Diff
Poudriere buildlog. 9.3amd (309.33 KB, text/x-log)
2015-05-02 07:51 UTC, robbak
no flags Details
buildlog, bitcoin-daemon (116.26 KB, text/x-log)
2015-05-02 07:52 UTC, robbak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description robbak 2015-05-02 07:42:47 UTC
Created attachment 156228 [details]
Patch to update to 0.10.1

This patch updates bitcoin to new bugfix version 0.10.1. It also includes the patches to fix bug 198826.
Comment 1 robbak 2015-05-02 07:47:43 UTC
*** Bug 199857 has been marked as a duplicate of this bug. ***
Comment 2 robbak 2015-05-02 07:48:29 UTC
*** Bug 199858 has been marked as a duplicate of this bug. ***
Comment 3 robbak 2015-05-02 07:51:00 UTC
Created attachment 156229 [details]
Poudriere buildlog. 9.3amd
Comment 4 robbak 2015-05-02 07:52:15 UTC
Created attachment 156230 [details]
buildlog, bitcoin-daemon
Comment 5 commit-hook freebsd_committer 2015-05-03 16:58:31 UTC
A commit references this bug:

Author: jbeich
Date: Sun May  3 16:58:05 UTC 2015
New revision: 385291
URL: https://svnweb.freebsd.org/changeset/ports/385291

Log:
  net-p2p/bitcoin*: update to 0.10.1 and fix conflicts

  Work around bin/test_bitcoin installed more than once by leaving
  TESTS=on by default only in net-p2p/bitcoin-utils.

  Changes:	https://bitcoin.org/en/release/v0.10.1
  PR:		198826 [1]
  PR:		199856
  Reported by:	peter [1]
  Submitted by:	robbak@gmail.com (maintainer, other mail)

Changes:
  head/net-p2p/bitcoin/Makefile
  head/net-p2p/bitcoin/distinfo
  head/net-p2p/bitcoin-daemon/Makefile
Comment 6 Jan Beich freebsd_committer 2015-05-03 17:02:07 UTC
Thanks. Committed with minor changes:
- Convert GH_TAGNAME to DISTVERSIONPREFIX
- Sort USES