Bug 199879 - [PATCH] lang/ocaml: configure broken with certain compiler options
Summary: [PATCH] lang/ocaml: configure broken with certain compiler options
Status: Closed DUPLICATE of bug 199878
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Guido Falsi
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-05-03 09:27 UTC by Guido Falsi
Modified: 2015-05-03 09:31 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (michipili)


Attachments
patch (857 bytes, patch)
2015-05-03 09:27 UTC, Guido Falsi
madpilot: maintainer-approval? (michipili)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Guido Falsi freebsd_committer 2015-05-03 09:27:06 UTC
Hi,

After the last update lang/ocaml fails to configure with the following error when any compiler option includes a "=":

===>  Configuring for ocaml-4.02.1
[ERROR!]Arguments to this script look like '-prefix /foo/bar', not '-prefix=/foo/bar' (note the '=').


The regexp performing this check in the configure script is really too generic and triggers also for perfectly legitimate compiler options like "-march=xxx".

Attached patch comments out this check. I don't think it's really needed in the port. Creating a correct check allowing the = symbol between quotes looks too difficult for too little advantage.

Can you approve this change?

BTW the update also has another problem. The caml4p parts were removed in this new release, but some other ports did depend on them. I'm creating a port for caml4p from here:

https://github.com/ocaml/camlp4

Was this checked before performing the update?
Comment 1 Guido Falsi freebsd_committer 2015-05-03 09:27:36 UTC
Created attachment 156268 [details]
patch
Comment 2 Guido Falsi freebsd_committer 2015-05-03 09:31:56 UTC

*** This bug has been marked as a duplicate of bug 199878 ***