Bug 199912 - [MAINTAINER] games/assaultcube: Fix build on pkg-fallout host(s) and other fixes for v1.2.0.2
Summary: [MAINTAINER] games/assaultcube: Fix build on pkg-fallout host(s) and other fi...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jan Beich
URL:
Keywords:
Depends on:
Blocks: 199905
  Show dependency treegraph
 
Reported: 2015-05-04 05:01 UTC by lightside
Modified: 2015-06-04 18:49 UTC (History)
0 users

See Also:


Attachments
Proposed patch (since 381324 revision) (5.66 KB, patch)
2015-05-04 05:01 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 8.4 amd64) (8.86 KB, application/x-bzip2)
2015-05-04 05:02 UTC, lightside
no flags Details
The poudriere testport log (FreeBSD 9.3 amd64) (8.47 KB, application/x-bzip2)
2015-05-04 05:03 UTC, lightside
no flags Details
The poudriere testport log (FreeBSD 10 amd64) (8.38 KB, application/x-bzip2)
2015-05-04 05:03 UTC, lightside
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lightside 2015-05-04 05:01:21 UTC
Created attachment 156316 [details]
Proposed patch (since 381324 revision)

Patch to fix the build of games/assaultcube port on pkg-fallout host(s), which used recent FreeBSD kernel update:
http://thread.gmane.org/gmane.os.freebsd.devel.cvs/523979

Failed:
http://beefy6.nyi.freebsd.org/data/84amd64-default/385145/logs/assaultcube-1.2.0.2_3.log
Sat May  2 08:29:53 UTC 2015
Host OSVERSION: 1100070
Jail OSVERSION: 804000

Was success before:
http://beefy6.nyi.freebsd.org/data/84amd64-default/384800/logs/assaultcube-1.2.0.2_3.log
Mon Apr 27 17:50:34 UTC 2015
Host OSVERSION: 1100064
Jail OSVERSION: 804000

Changes:
- Convert patch for ${BUILD_WRKSRC}/Makefile to sed patch with possible fix to build on current pkg-fallout host(s)
- Adapt patches in files directory, after ports r383894 changes for ports-mgmt/portlint v2.16.3
- Add patch to build enet library on DragonFly operating system by Jan Beich (jbeich@)
Comment 1 lightside 2015-05-04 05:02:49 UTC
Created attachment 156317 [details]
The poudriere testport log (FreeBSD 8.4 amd64)

I can't reproduce the error on my current FreeBSD 10 build host, but the poudriere testport log don't show cube.h.gch file, which might fix this issue, related to GCC precompiled header(s).
Comment 2 lightside 2015-05-04 05:03:14 UTC
Created attachment 156318 [details]
The poudriere testport log (FreeBSD 9.3 amd64)
Comment 3 lightside 2015-05-04 05:03:31 UTC
Created attachment 156319 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 4 commit-hook freebsd_committer 2015-05-04 11:17:18 UTC
A commit references this bug:

Author: jbeich
Date: Mon May  4 11:16:49 UTC 2015
New revision: 385392
URL: https://svnweb.freebsd.org/changeset/ports/385392

Log:
  games/assaultcube: unbreak on DragonFly and the package cluster

  - Disable PCH (precompiled header) to unbreak build with GCC in
    jails for older branches and recent 11.0C kernel
  - Add upstream patch for bundled libenet to unbreak build on DragonFly [1]
  - Convert patch for ${BUILD_WRKSRC}/Makefile into sed(1) variant
  - Pet portlint since r383894 by formatting patches with makepatch target

  PR:		199912
  Submitted by:	lightside <lightside@gmx.com> (maintainer)
  Obtained from:	https://github.com/lsalzman/enet/commit/8df6e58 [1]

Changes:
  head/games/assaultcube/Makefile
  head/games/assaultcube/files/patch-source_enet_unix.c
  head/games/assaultcube/files/patch-source_src_Makefile
  head/games/assaultcube/files/patch-source_src_bot_bot_waypoint.cpp
  head/games/assaultcube/files/patch-source_src_console.h
  head/games/assaultcube/files/patch-source_src_master.cpp
Comment 5 Jan Beich freebsd_committer 2015-05-04 11:22:48 UTC
Thanks. Committed and confirmed the fix on 11.0C amd64 kernel with 9.3R i386 jail.
Comment 6 commit-hook freebsd_committer 2015-06-04 18:49:24 UTC
A commit references this bug:

Author: amdmi3
Date: Thu Jun  4 18:48:36 UTC 2015
New revision: 388542
URL: https://svnweb.freebsd.org/changeset/ports/388542

Log:
  MFH: r385392

  games/assaultcube: unbreak on DragonFly and the package cluster

  - Disable PCH (precompiled header) to unbreak build with GCC in
    jails for older branches and recent 11.0C kernel
  - Add upstream patch for bundled libenet to unbreak build on DragonFly [1]
  - Convert patch for ${BUILD_WRKSRC}/Makefile into sed(1) variant
  - Pet portlint since r383894 by formatting patches with makepatch target

  PR:		199912
  Submitted by:	lightside <lightside@gmx.com> (maintainer)
  Obtained from:	https://github.com/lsalzman/enet/commit/8df6e58 [1]
  Approved by:	ports-secteam (delhij)

Changes:
_U  branches/2015Q2/
  branches/2015Q2/games/assaultcube/Makefile
  branches/2015Q2/games/assaultcube/files/patch-source_enet_unix.c
  branches/2015Q2/games/assaultcube/files/patch-source_src_Makefile
  branches/2015Q2/games/assaultcube/files/patch-source_src_bot_bot_waypoint.cpp
  branches/2015Q2/games/assaultcube/files/patch-source_src_console.h
  branches/2015Q2/games/assaultcube/files/patch-source_src_master.cpp