Bug 199989 - [MAINTAINER] Update x11/tint-devel to 20150506
Summary: [MAINTAINER] Update x11/tint-devel to 20150506
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-05-06 11:29 UTC by yamagi
Modified: 2015-05-15 13:15 UTC (History)
1 user (show)

See Also:


Attachments
svn patch to tint-devel 20150506 (1.61 KB, patch)
2015-05-06 11:29 UTC, yamagi
no flags Details | Diff
Second version of the patch (1.99 KB, patch)
2015-05-15 11:19 UTC, yamagi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2015-05-06 11:29:54 UTC
Created attachment 156421 [details]
svn patch to tint-devel 20150506

The attached svn patch updates x11/tint-devel to a new snapshot as of today, 6. May 2015. Changes to the port are:

- Since upstream migrated from svn to git, switch to the snapshot date for version numbers.
- README was renamed to README.md

The port was tested with Poudriere in a FreeBSD 10.1 jail.
Comment 1 Thomas Zander freebsd_committer 2015-05-14 10:47:12 UTC
Does not build when all OPTIONs are deselected:

[...]
CMake Error at CMakeLists.txt:93 (message):
  Startup notification support enabled yet dependency not fulfilled:
  libstartup-notification-1.0


-- Configuring incomplete, errors occurred!
Comment 2 yamagi 2015-05-15 11:18:25 UTC
My fault, sorry. :( In fact, the port was broken before. The problem is, that the startup-notification dependency is bound to the PYCONF option but it's needed by tint2 itself. I've changed startup-notification to be a general dependency. An updated patch is attached.
Comment 3 yamagi 2015-05-15 11:19:03 UTC
Created attachment 156798 [details]
Second version of the patch
Comment 4 commit-hook freebsd_committer 2015-05-15 12:49:44 UTC
A commit references this bug:

Author: riggs
Date: Fri May 15 12:49:09 UTC 2015
New revision: 386404
URL: https://svnweb.freebsd.org/changeset/ports/386404

Log:
  Update to upstream snapshot 20150506

  PR:		199989
  Submitted by:	yamagi@yamagi.org (maintainer)

Changes:
  head/x11/tint-devel/Makefile
  head/x11/tint-devel/distinfo