Bug 200099 - net/pvm fails to build on armv6
Summary: net/pvm fails to build on armv6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL: http://chips.ysv.freebsd.org/data/11a...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-10 14:11 UTC by Mikael Urankar
Modified: 2015-05-19 10:16 UTC (History)
2 users (show)

See Also:


Attachments
fix arm build (509 bytes, patch)
2015-05-10 14:11 UTC, Mikael Urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2015-05-10 14:11:00 UTC
Created attachment 156611 [details]
fix arm build

Hi,

The attached patch fixes that.
Comment 1 Mikael Urankar freebsd_committer 2015-05-10 14:13:03 UTC
build log:
http://mikael.urankar.free.fr/FreeBSD/arm/build_logs/pvm-3.4.6_4.log
Comment 2 commit-hook freebsd_committer 2015-05-19 10:15:14 UTC
A commit references this bug:

Author: marino
Date: Tue May 19 10:14:57 UTC 2015
New revision: 386762
URL: https://svnweb.freebsd.org/changeset/ports/386762

Log:
  net/pvm3: Fix build on armv6

  PR:		200099
  Submitted by:	Mikael Urankar

Changes:
  head/net/pvm/files/patch-pvmgetarch
Comment 3 John Marino freebsd_committer 2015-05-19 10:16:34 UTC
This was just a patch to a patch.  When I regenerated the patch, it didn't match.  The offsets were different.

So next time it's better to regenerate the patch.