Bug 200152 - [maintainer update] x11-fm/doublecmd: update to version 0.6.2
Summary: [maintainer update] x11-fm/doublecmd: update to version 0.6.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 16:13 UTC by Beñat Gonzalez Etxepare
Modified: 2015-05-26 18:32 UTC (History)
1 user (show)

See Also:


Attachments
Patch to version 0.6.2 (2.73 KB, patch)
2015-05-12 16:13 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff
Patch to version 0.6.2 (fixed) (2.91 KB, patch)
2015-05-12 21:24 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff
Build failure with QT4 option (39.67 KB, text/plain)
2015-05-21 11:17 UTC, Dmitry Marakasov
no flags Details
Patch to version 0.6.2 (second fix) (2.86 KB, patch)
2015-05-21 15:44 UTC, Beñat Gonzalez Etxepare
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beñat Gonzalez Etxepare 2015-05-12 16:13:59 UTC
Created attachment 156711 [details]
Patch to version 0.6.2

Changes:
- Update to version 0.6.2. Changelog:
http://doublecmd.sourceforge.net/mantisbt/changelog_page.php?version_id=34
- Conversion to options framework for dependency registration

Patch tested using Poudriere.
Comment 1 Jan Beich freebsd_committer 2015-05-12 18:50:29 UTC
Comment on attachment 156711 [details]
Patch to version 0.6.2

> .if ${PORT_OPTIONS:MGTK2}
>-USE_FPC+=	gtk2
>-USE_GNOME=	gtk20
[...]
>+GTK2_USE_FPC=		gtk2
>+GTK2_USE_GNOME=		gtk20

USE_FOO is converted differently from USES=foo. To avoid regressing the option check with

  $ make WITH=GTK2 -V USE_FPC
  $ make WITH=GTK2 -V USE_GNOME

  $ make WITHOUT=GTK2 -V USE_FPC
  $ make WITHOUT=GTK2 -V USE_GNOME

https://www.freebsd.org/doc/en/books/porters-handbook/makefile-options.html#options-use
Comment 2 Beñat Gonzalez Etxepare 2015-05-12 21:24:42 UTC
Created attachment 156732 [details]
Patch to version 0.6.2 (fixed)

Thanks for your help!
So if I understand correctly, this new patch should do it.

Checks:

$ make WITH=GTK2 -V USE_FPC ; make WITHOUT=GTK2 -V USE_FPC
gtk2
     <-- (blank line)
$ make WITH=GTK2 -V USE_GNOME ; make WITHOUT=GTK2 -V USE_GNOME
gtk20
     <-- (blank line)
Comment 3 Dmitry Marakasov freebsd_committer 2015-05-21 11:17:06 UTC
Created attachment 157005 [details]
Build failure with QT4 option

It fails with QT4 option enabled, see attached log.
Comment 4 Beñat Gonzalez Etxepare 2015-05-21 15:44:56 UTC
Created attachment 157013 [details]
Patch to version 0.6.2 (second fix)

Sorry, I didn't test QT4 option with the second patch. This new patch corrects the building error with QT4.

Tested both options (GTK2 and QT4) this time, using Poudriere.
Comment 5 Dmitry Marakasov freebsd_committer 2015-05-26 18:32:35 UTC
I also suggest to add descriptions for plugin options.
Comment 6 commit-hook freebsd_committer 2015-05-26 18:32:40 UTC
A commit references this bug:

Author: amdmi3
Date: Tue May 26 18:32:00 UTC 2015
New revision: 387507
URL: https://svnweb.freebsd.org/changeset/ports/387507

Log:
  - Update to 0.6.2

  PR:		200152
  Submitted by:	bbtruk@users.sourceforge.net (maintainer)

Changes:
  head/x11-fm/doublecmd/Makefile
  head/x11-fm/doublecmd/distinfo