Bug 200156 - sort: Broken pipe Error when running portsnap update
Summary: sort: Broken pipe Error when running portsnap update
Status: New
Alias: None
Product: Services
Classification: Unclassified
Component: Portsnap (show other bugs)
Version: unspecified
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Colin Percival
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 17:42 UTC by rsimmons0
Modified: 2015-09-29 15:35 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rsimmons0 2015-05-12 17:42:48 UTC
After running portsnap update I get the following Broken pipe error message:

# portsnap update
sort: Broken pipe
Removing old files and directories... done.
Extracting new files:
/usr/ports/GIDs
/usr/ports/MOVED
/usr/ports/Mk/Uses/
/usr/ports/Mk/bsd.sites.mk
Comment 1 rsimmons0 2015-05-13 16:05:42 UTC
This happens every time I run portsnap update
Comment 2 Ed Maste freebsd_committer 2015-08-04 20:31:57 UTC
Can you confirm you're actually running on arm64, or was amd64 intended?
Comment 3 rsimmons0 2015-08-14 21:15:41 UTC
It is amd64, sorry.

Also, I just upgraded to 10.2-RELEASE and the problem still exists.
Comment 4 Peter Wemm freebsd_committer freebsd_triage 2015-08-15 18:05:21 UTC
(changed cc from clusteradm to secteam, clusteradm has no involvement in freebsd-update)
Comment 5 rsimmons0 2015-09-29 15:35:51 UTC
Updated to 10.2-p3 and the problem is still here:

# portsnap update
sort: Broken pipe
Removing old files and directories...