Bug 200290 - [PATCH] audio/csound6: Update to version 6.05
Summary: [PATCH] audio/csound6: Update to version 6.05
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-05-18 18:30 UTC by tkato432
Modified: 2015-06-09 10:38 UTC (History)
1 user (show)

See Also:


Attachments
audio_csound6.diff (10.27 KB, patch)
2015-05-18 18:30 UTC, tkato432
no flags Details | Diff
failed build log (652.93 KB, text/plain)
2015-06-07 21:04 UTC, Guido Falsi
no flags Details
audio_csound6.diff (9.88 KB, patch)
2015-06-08 10:00 UTC, tkato432
no flags Details | Diff
audio_csound6.diff (14.56 KB, patch)
2015-06-09 10:00 UTC, tkato432
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tkato432 2015-05-18 18:30:09 UTC
Created attachment 156890 [details]
audio_csound6.diff
Comment 1 Guido Falsi freebsd_committer 2015-06-07 21:04:38 UTC
Created attachment 157520 [details]
failed build log

Hi,

While testing this patch I have been unable to make it work in all FreeBSD versions.

With the patch as is, with default options, it fails on 10.1 and head, I'm attaching a log of a failed build.

If I use USES=openmp it succeeds on 10.1 and head but fails on older releases.

Have noticed this behavior too? are you able to submit a patch without this problem?

Thanks in advance.
Comment 2 tkato432 2015-06-08 10:00:07 UTC
Created attachment 157533 [details]
audio_csound6.diff

Initial patch has been outdated because of r387982.
Comment 3 Guido Falsi freebsd_committer 2015-06-08 19:08:51 UTC
Hi again,

The new patch applies successfully, but I get the same failure seen in the attached file "failed build log" on head and 10.1.

Can you investigate this issue please?
Comment 4 tkato432 2015-06-09 10:00:11 UTC
Created attachment 157562 [details]
audio_csound6.diff

Oh, it seems gcc port has implicitly changed its behavior. Although
slightly older gcc built this port smoothly, the same build error as
you pointed out was reproduced with recompiled one.
Comment 5 Guido Falsi freebsd_committer 2015-06-09 10:37:41 UTC
Committed, Thanks!
Comment 6 commit-hook freebsd_committer 2015-06-09 10:38:00 UTC
A commit references this bug:

Author: madpilot
Date: Tue Jun  9 10:37:25 UTC 2015
New revision: 388907
URL: https://svnweb.freebsd.org/changeset/ports/388907

Log:
  - Update to 6.05
  - Regenerate patches to silence portlint warnings

  PR:		200290
  Submitted by:	tkato432 at yahoo.com

Changes:
  head/audio/csound6/Makefile
  head/audio/csound6/distinfo
  head/audio/csound6/files/patch-H__remote.h
  head/audio/csound6/files/patch-InOut-rtalsa.c
  head/audio/csound6/files/patch-Opcodes-urandom.c
  head/audio/csound6/files/patch-Top-csound.c
  head/audio/csound6/files/patch-frontends__CsoundAC__ChordSpace.hpp
  head/audio/csound6/files/patch-frontends__CsoundAC__Composition.cpp
  head/audio/csound6/files/patch-frontends__CsoundAC__Counterpoint.cpp
  head/audio/csound6/files/patch-frontends__CsoundAC__Counterpoint.hpp
  head/audio/csound6/pkg-plist