Bug 200293 - [PATCH] benchmarks/fhourstones: Update MASTER_SITES
Summary: [PATCH] benchmarks/fhourstones: Update MASTER_SITES
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-05-18 18:31 UTC by tkato432
Modified: 2015-05-19 08:42 UTC (History)
0 users

See Also:


Attachments
benchmarks_fhourstones.diff (3.61 KB, patch)
2015-05-18 18:31 UTC, tkato432
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tkato432 2015-05-18 18:31:34 UTC
Created attachment 156893 [details]
benchmarks_fhourstones.diff
Comment 1 John Marino freebsd_committer 2015-05-19 08:19:19 UTC
I will take this but I already see some changes in the patch that need to be reverted.
Comment 2 commit-hook freebsd_committer 2015-05-19 08:37:55 UTC
A commit references this bug:

Author: marino
Date: Tue May 19 08:37:44 UTC 2015
New revision: 386748
URL: https://svnweb.freebsd.org/changeset/ports/386748

Log:
  benchmarks/fhourstones: New MASTER_SITES to unbreak, move executable

  This port was broken due to being unfetchable.  While finding a new
  source location, switch the executable from lib/fhourstones to
  libexec/fhourstones.  Also, use "sed" and "echo" to eliminate the
  need for patches.

  Some changes were made to the submitted patch by me, but they were minor.

  PR:		200293
  Submitted by:	Ports Fury

Changes:
  head/benchmarks/fhourstones/Makefile
  head/benchmarks/fhourstones/files/
  head/benchmarks/fhourstones/pkg-descr
Comment 3 John Marino freebsd_committer 2015-05-19 08:42:30 UTC
The main things I changed:

1) I simplified the creation of bin/fhourstones.  We didn't need the blank line inserted, nor do we need to use "echo -n" to create the file (">" works fine)

2) I removed the compound cd / install commands.  Several committers have asked that all changes like this be blocked so you should stop doing this because it just adds effort for us.

3) I removed the %% format in PLIST_FILES.  Please either use make variables or just spell it out.  This is not an issue because PLIST_FILES by design must only be 6 lines long at the minimum (otherwise pkg-plist should be used)