Bug 200366 - [patch] astro/foxtrotgps: fix yournavigation.org API
Summary: [patch] astro/foxtrotgps: fix yournavigation.org API
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: patch
: 200365 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-21 11:41 UTC by Gleb Smirnoff
Modified: 2015-05-22 08:41 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (crwhipp)


Attachments
damn bugzill, here it is! (4.70 KB, patch)
2015-05-21 13:59 UTC, Gleb Smirnoff
no flags Details | Diff
poudriere testport log (100.31 KB, text/x-log)
2015-05-22 04:06 UTC, crwhipp
crwhipp: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Smirnoff freebsd_committer 2015-05-21 11:41:59 UTC
The yournavigation.org API has changed and foxtrotgps can no longer fetch routes from the service.

The patch takes two revisions (287, 288) from the future unreleased version of foxtrotgps and brings them into the port.
Comment 1 crwhipp 2015-05-21 13:58:59 UTC
I don't see the patch, is it attached?
Comment 2 Gleb Smirnoff freebsd_committer 2015-05-21 13:59:42 UTC
Created attachment 157009 [details]
damn bugzill, here it is!
Comment 3 crwhipp 2015-05-22 04:06:34 UTC
Created attachment 157028 [details]
poudriere testport log
Comment 4 crwhipp 2015-05-22 04:09:12 UTC
Patch applies and corrects the issue.  Approved.

Thanks for your help!
Comment 5 Gleb Smirnoff freebsd_committer 2015-05-22 08:30:00 UTC
*** Bug 200365 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2015-05-22 08:41:49 UTC
A commit references this bug:

Author: glebius
Date: Fri May 22 08:41:10 UTC 2015
New revision: 386994
URL: https://svnweb.freebsd.org/changeset/ports/386994

Log:
  Provide patch from future version to fix yournavigation.org API.

  PR:		200366
  Approved by:	Craig Whipp <crwhipp gmail.com> (maintainer)

Changes:
  head/astro/foxtrotgps/Makefile
  head/astro/foxtrotgps/files/
  head/astro/foxtrotgps/files/patch-src_tracks.c