Bug 200544 - devel/dcmtk: Fix for oflist destructor crash on CURRENT
Summary: devel/dcmtk: Fix for oflist destructor crash on CURRENT
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-05-30 21:23 UTC by mp39590
Modified: 2015-09-28 14:34 UTC (History)
2 users (show)

See Also:


Attachments
patch (337 bytes, patch)
2015-05-30 21:23 UTC, mp39590
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mp39590 2015-05-30 21:23:46 UTC
Created attachment 157293 [details]
patch

The patch is a sync from upstream git[1], this fixes the crash of orthanc server, when it exits. I can reproduce it only on -current, so it looks like it depends on -current's debugging features turned on.

[1] - http://git.dcmtk.org/web?p=dcmtk.git;a=commitdiff;h=dd7e3b3d8074795a86e6c8bbb67b2c13c7034d12

NB: please bump PORTVERSION
Comment 1 commit-hook freebsd_committer 2015-09-28 14:32:04 UTC
A commit references this bug:

Author: riggs
Date: Mon Sep 28 14:31:11 UTC 2015
New revision: 398117
URL: https://svnweb.freebsd.org/changeset/ports/398117

Log:
  Fix crash in OFListBase destructor on CURRENT

  - Import an upstream fix for OFListBase destructor crash, see
    git commitdiff link in PR.
  - Bump PORTREVISION

  PR:		200544
  Submitted by:	mp39590@gmail.com

Changes:
  head/devel/dcmtk/Makefile
  head/devel/dcmtk/files/patch-ofstd_libsrc_oflist.cc