Bug 200618 - www/chromium VideoCaptureDevice segfault when opening gmail
Summary: www/chromium VideoCaptureDevice segfault when opening gmail
Status: Closed DUPLICATE of bug 200601
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-chromium mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-03 16:51 UTC by Ed Maste
Modified: 2015-06-03 17:57 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2015-06-03 16:51:51 UTC
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 81f580800 (LWP 102299)]
0x0000000006a2e319 in base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>::Run(media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&) (this=0x7fffdebf3390, object=0x0, args=...)
    at ../../base/bind_internal.h:176
176         return (object->*method_)(CallbackForward(args)...);
(gdb) bt
#0  0x0000000006a2e319 in base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>::Run(media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&) (this=0x7fffdebf3390, object=0x0, 
    args=...) at ../../base/bind_internal.h:176
#1  0x0000000006a2e214 in base::internal::InvokeHelper<false, void, base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>, base::internal::TypeList<media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&> >::MakeItSo(base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>, media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&) (runnable=..., args=..., args=...)
    at ../../base/bind_internal.h:293
#2  0x0000000006a2e1c1 in base::internal::Invoker<IndexSequence<0ul, 1ul>, base::internal::BindState<base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>, void (media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&), base::internal::TypeList<base::internal::UnretainedWrapper<media::VideoCaptureDeviceFactory>, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> > >, base::internal::TypeList<base::internal::UnwrapTraits<base::internal::UnretainedWrapper<media::VideoCaptureDeviceFactory> >, base::internal::UnwrapTraits<base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> > >, base::internal::InvokeHelper<false, void, base::internal::RunnableAdapter<void (media::VideoCaptureDeviceFactory::*)(base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&)>, base::internal::TypeList<media::VideoCaptureDeviceFactory*, base::Callback<void (scoped_ptr<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> >, base::DefaultDeleter<std::__1::list<media::VideoCaptureDevice::Name, std::__1::allocator<media::VideoCaptureDevice::Name> > > >)> const&> >, void ()>::Run(base::internal::BindStateBase*) (base=0x829f2d700)
    at ../../base/bind_internal.h:343
#3  0x0000000000581c2e in base::Callback<void ()>::Run() const (this=0x7fffdebf37d8) at ../../base/callback.h:396
#4  0x0000000001a18d5a in base::debug::TaskAnnotator::RunTask (this=0x82400f260, queue_function=0xc755c0a "MessageLoop::PostTask", run_function=0xc755c20 "MessageLoop::RunTask", 
    pending_task=...) at ../../base/debug/task_annotator.cc:63
#5  0x00000000018d8d1e in base::MessageLoop::RunTask (this=0x82400f140, pending_task=...) at ../../base/message_loop/message_loop.cc:444
#6  0x00000000018d8e5b in base::MessageLoop::DeferOrRunPendingTask (this=0x82400f140, pending_task=...) at ../../base/message_loop/message_loop.cc:454
#7  0x00000000018d9483 in base::MessageLoop::DoWork (this=0x82400f140) at ../../base/message_loop/message_loop.cc:566
#8  0x00000000018e7c71 in base::MessagePumpDefault::Run (this=0x82401b040, delegate=0x82400f140) at ../../base/message_loop/message_pump_default.cc:32
#9  0x00000000018d87c0 in base::MessageLoop::RunHandler (this=0x82400f140) at ../../base/message_loop/message_loop.cc:410
#10 0x000000000191d674 in base::RunLoop::Run (this=0x7fffdebf3c10) at ../../base/run_loop.cc:55
#11 0x00000000018d8061 in base::MessageLoop::Run (this=0x82400f140) at ../../base/message_loop/message_loop.cc:303
#12 0x00000000019aabc9 in base::Thread::Run (this=0x81f456ec0, message_loop=0x82400f140) at ../../base/threading/thread.cc:185
#13 0x00000000019aaff2 in base::Thread::ThreadMain (this=0x81f456ec0) at ../../base/threading/thread.cc:239
#14 0x0000000001996cff in base::(anonymous namespace)::ThreadFunc (params=0x7fffffffca50) at ../../base/threading/platform_thread_posix.cc:77
#15 0x0000000819c777c5 in thread_start (curthread=0x81f580800) at /tank/emaste/src/git-stable-10/lib/libthr/thread/thr_create.c:288
#16 0x0000000000000000 in ?? ()
Comment 1 miguelmclara 2015-06-03 17:52:21 UTC
Getting this error  too as well as:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200601

FreeBSD 11-Current
chromium-43.0.2357.81
Comment 2 Ed Maste freebsd_committer 2015-06-03 17:57:40 UTC

*** This bug has been marked as a duplicate of bug 200601 ***