Bug 200621 - net/turses current port 0.2.22 requires net/py-tweepy 2.2, but port installs net/py-tweepy 2.3
Summary: net/turses current port 0.2.22 requires net/py-tweepy 2.2, but port installs ...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kubilay Kocak
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-06-03 20:37 UTC by patpro
Modified: 2015-07-08 20:05 UTC (History)
1 user (show)

See Also:
koobs: merge-quarterly+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patpro 2015-06-03 20:37:28 UTC
Twitter command line turses no longer work after net/py-tweepy upgrade, because current net/turses need previous net/py-tweepy version.

It appears that a newer turses version is available that uses net/py-tweepy 2.3.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-05 13:50:05 UTC
tweepy is now 3.3.0 (with Python 3) support among other things, though it doesn't appear yet that a turses version that declares tweepy>3 in its install_requires. 

Github master does, but it hasn't been released. I've created an issue for it here: https://github.com/dialelo/turses/issues/203

I'll be taking maintainership of tweepy and updating it to the latest version, and then giving the turses port update a crack.

You can assist in the meantime by testing the latest turses with tweepy 3.3.0 via pip in a virtualenv and letting me know if it works for you at runtime
Comment 2 patpro 2015-07-06 18:30:58 UTC
(In reply to Kubilay Kocak from comment #1)

The fact is I don't plan to migrate from python 2.7 to python 3.x anytime soon, and I don't want to install 3.x just to run turses. Kind of overkill.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-07 04:16:34 UTC
(In reply to Kubilay Kocak from comment #1)

I should have clearer, apologies. turses is 2/3 compatible. I didn't mean it removed 2.x support or that I wanted a test with Python 3.x.

Can you test the latest turses (the author has updated the PyPi sdist since my last comment) with the latest tweepy, on Python 2.7, using a virtualenv & pip to make sure it just works.

Unfortuntely the test suite of tweepy is frustratingly complex to get working, which is why I'm asking for an end-user test. I can take care of the port updates once confirmed.
Comment 4 commit-hook freebsd_committer 2015-07-07 10:21:12 UTC
A commit references this bug:

Author: koobs
Date: Tue Jul  7 10:20:35 UTC 2015
New revision: 391498
URL: https://svnweb.freebsd.org/changeset/ports/391498

Log:
  net/py-tweepy: Update to 3.3.0, Enable Python 3

  - Update to 3.3.0
  - Take MAINTAINER'ship
  - Switch to GITHUB to get access to the tests & test suite
  - Allow building with Python 3 (now supported)
  - Update BUILD_DEPENDS and RUN_DEPENDS
  - Sort USE_PYTHON values
  - Patch setup.py to correctly set test dependencies and hook in the setuptools
    test command
  - Patch out unnecessary (tox) test dependency.

  Changes:

    https://github.com/tweepy/tweepy/blob/v3.3.0/CHANGELOG.md

  First part of:

  PR:		200621
  Reported by:	Patrick P. <freebsdbug patpro net>

Changes:
  head/net/py-tweepy/Makefile
  head/net/py-tweepy/distinfo
  head/net/py-tweepy/files/
  head/net/py-tweepy/files/patch-setup.py
  head/net/py-tweepy/files/patch-test__requirements.txt
Comment 5 commit-hook freebsd_committer 2015-07-07 11:48:20 UTC
A commit references this bug:

Author: koobs
Date: Tue Jul  7 11:48:04 UTC 2015
New revision: 391502
URL: https://svnweb.freebsd.org/changeset/ports/391502

Log:
  net/turses: Update to 0.3.0, Unbreak.

  - Update to 0.3.0, unbreaking due to 2.3+ versions of net/py-tweepy
    in the ports tree
  - Patch setup.py to relax py-tweepy version requirement
  - oauth2 is no longer required
  - Set USES=python to 2.7, since this doesnt need the meta-port

  - Patch in setuptools test command support (setup.py)
  - Update TEST_DEPENDS and TESTS option description
  - Sort USE_PYTHON values
  - Add NO_ARCH

  Second half of:

  PR:		200621
  Reported by:	Patrick P. <freebsdbug patpro net>
  MFH:		2015Q3

Changes:
  head/net/turses/Makefile
  head/net/turses/distinfo
  head/net/turses/files/patch-setup.py
Comment 6 commit-hook freebsd_committer 2015-07-07 15:10:34 UTC
A commit references this bug:

Author: koobs
Date: Tue Jul  7 15:09:36 UTC 2015
New revision: 391509
URL: https://svnweb.freebsd.org/changeset/ports/391509

Log:
  MFH: r391502

  net/turses: Update to 0.3.0, Unbreak.

  - Update to 0.3.0, unbreaking due to 2.3+ versions of net/py-tweepy
    in the ports tree
  - Patch setup.py to relax py-tweepy version requirement
  - oauth2 is no longer required
  - Set USES=python to 2.7, since this doesnt need the meta-port

  - Patch in setuptools test command support (setup.py)
  - Update TEST_DEPENDS and TESTS option description
  - Sort USE_PYTHON values
  - Add NO_ARCH

  Second half of:

  PR:		200621
  Reported by:	Patrick P. <freebsdbug patpro net>

  Approved by:	portmgr (feld)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/net/turses/Makefile
  branches/2015Q3/net/turses/distinfo
  branches/2015Q3/net/turses/files/patch-setup.py
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-07 15:21:07 UTC
Committed, thank you for the report Patrick
Comment 8 patpro 2015-07-08 20:05:53 UTC
(In reply to Kubilay Kocak from comment #7)

Well, thank you for the fix! Sorry for my late reply, I was quite unavailable those last days.
I've just updated tweepy and turses, it looks like everything is working OK.

Thanks again.