Bug 200648 - [patch] Update devel/jsoncpp to 0.10.2
Summary: [patch] Update devel/jsoncpp to 0.10.2
Status: Closed DUPLICATE of bug 209407
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL: https://bugs.freebsd.org/bugzilla/sho...
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-06-04 21:57 UTC by Brad Davis
Modified: 2016-05-15 16:23 UTC (History)
3 users (show)

See Also:
johan: maintainer-feedback+


Attachments
patch (2.22 KB, patch)
2015-06-04 21:57 UTC, Brad Davis
no flags Details | Diff
poudriere build log (16.60 KB, text/plain)
2015-06-04 21:59 UTC, Brad Davis
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Davis freebsd_committer 2015-06-04 21:57:05 UTC
Created attachment 157419 [details]
patch
Comment 1 Brad Davis freebsd_committer 2015-06-04 21:59:04 UTC
Created attachment 157420 [details]
poudriere build log

An example from one of the build runs.
Comment 2 Johan Ström 2015-06-05 06:12:38 UTC
Thanks for your submission!

I'm looking at https://github.com/open-source-parsers/jsoncpp/releases, which mentions 0.10.1 is binary compatible with 0.6.0-rc2. But no mention if 0.10.2 also is? I assume so. If so, I have no complaints and the porters may update the port if they find it correct!
Comment 3 Brad Davis freebsd_committer 2015-06-05 13:50:10 UTC
Well we can just bump the things that depend on it so they get rebuilt. Which looks like net-im/kopete-kde4 and www/chromium according to freshports.
Comment 4 Johan Ström 2015-06-05 13:58:43 UTC
Personally I'm only using it for some stuff which is not in ports yet, didn't even know others was using it!

Anyway, I'm not a jsoncpp developer, just port submitter, so I cannot vouch for any compat issues. I have nothing to object on though!
Comment 5 Brad Davis freebsd_committer 2015-06-05 15:07:56 UTC
I came across it because CMake is going to require it.. So I figured I would update it as well.
Comment 6 Johan Ström 2015-06-18 06:33:06 UTC
Possibly replaced by #200939
Comment 7 Raphael Kubo da Costa freebsd_committer 2015-06-22 21:47:48 UTC
Please note that it'd be good to have bug 201057 fixed before updating.
Comment 8 Brad Davis freebsd_committer 2016-05-15 16:23:05 UTC

*** This bug has been marked as a duplicate of bug 209407 ***