Bug 200661 - devel/pcre: 8.37 has unresolved vulnerabilities
Summary: devel/pcre: 8.37 has unresolved vulnerabilities
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Brendan Fabeny
URL:
Keywords: needs-qa, security
Depends on:
Blocks:
 
Reported: 2015-06-05 20:17 UTC by freebsdpr-20121114
Modified: 2015-06-10 04:14 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback? (bf)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description freebsdpr-20121114 2015-06-05 20:17:24 UTC

    
Comment 1 freebsdpr-20121114 2015-06-05 20:19:58 UTC
See http://vuxml.freebsd.org/freebsd/e69af246-0ae2-11e5-90e4-d050996490d0.html

Fixes appear to exist in the upstream code (http://vcs.pcre.org/pcre?view=revision&revision=1562) but 8.38 is not yet released.
Comment 2 Jason Unovitch freebsd_committer 2015-06-10 03:25:47 UTC
See https://svnweb.freebsd.org/changeset/ports/388777

These upstream changes were all applied as patches to the 8.37 pcre in ports.
Comment 3 Xin LI freebsd_committer 2015-06-10 04:14:01 UTC
This is already fixed.