Bug 200786 - [PATCH] net-mgmt/pmacct: Add missing PostgreSQL LIB_DEPENDS and support for multiple daemons in rc.d
Summary: [PATCH] net-mgmt/pmacct: Add missing PostgreSQL LIB_DEPENDS and support for m...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-11 10:14 UTC by Niels Kristensen
Modified: 2018-02-09 19:16 UTC (History)
2 users (show)

See Also:


Attachments
[patch] pmacct.patch (3.47 KB, patch)
2015-06-11 10:14 UTC, Niels Kristensen
no flags Details | Diff
revised rc.d script based on the snort example (2.39 KB, patch)
2015-06-11 18:30 UTC, Niels Kristensen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Niels Kristensen 2015-06-11 10:14:50 UTC
Created attachment 157631 [details]
[patch] pmacct.patch

When building with PGSQL=on on poudriere it missed lpq.

    checking for PQconnectdb in -lpq... no
    configure: error: 
            ERROR: missing PQ library. Refer to: http://www.postgresql.org

-

The rc.d script has been modified so it can run multiple daemons, as explained in the comment of the script. It's needed for listening on multiple interfaces.
The script is mostly a copy of rc.d/openvpn.
Comment 1 Ryan Steinmetz freebsd_committer freebsd_triage 2015-06-11 15:25:34 UTC
We don't want to use the symlink style method for running multiple instances.

Better implementation examples can be found in:
www/apache22/files/apache22.in (profiles)
security/snort/files/snort.in (interfaces)

The patch for multi-instance support, as it currently stands, is rejected.

I've committed your fix for postgres/LIB_DEPENDS, thank you!
Comment 2 commit-hook freebsd_committer 2015-06-11 15:26:43 UTC
A commit references this bug:

Author: zi
Date: Thu Jun 11 15:25:42 UTC 2015
New revision: 389227
URL: https://svnweb.freebsd.org/changeset/ports/389227

Log:
  - Add LIB_DEPENDS for postgres support
  - Do not bump PORTREVISION as this is a NOOP by default

  PR:		200786
  Submitted by:	Niels Kristensen <niels@kristensen.io>

Changes:
  head/net-mgmt/pmacct/Makefile
Comment 3 Niels Kristensen 2015-06-11 18:30:35 UTC
Created attachment 157647 [details]
revised rc.d script based on the snort example

I've revised the rc.d patch to use the style of the snort implementation.
Comment 4 Niels Kristensen 2015-11-04 12:46:39 UTC
Any news on this one?
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-02-05 13:45:29 UTC
Feedback please!
Comment 6 Ryan Steinmetz freebsd_committer freebsd_triage 2018-02-05 14:02:38 UTC
(In reply to w.schwarzenfeld from comment #5)
Can you verify that the patch for multiple instances is functional?
Comment 7 Kurt Jaeger freebsd_committer 2018-02-05 16:59:33 UTC
I have the need for multiple instances and will test it.
Comment 8 commit-hook freebsd_committer 2018-02-09 19:16:07 UTC
A commit references this bug:

Author: pi
Date: Fri Feb  9 19:15:43 UTC 2018
New revision: 461328
URL: https://svnweb.freebsd.org/changeset/ports/461328

Log:
  net-mgmt/pmacct: update 1.6.1 -> 1.6.2, allow per-interface instances

  PR:		200786
  Submitted by:	Niels Kristensen <niels@kristensen.io>
  Relnotes:	http://www.pmacct.net/ChangeLog-1.6.2

Changes:
  head/UPDATING
  head/net-mgmt/pmacct/Makefile
  head/net-mgmt/pmacct/distinfo
  head/net-mgmt/pmacct/files/pkg-message.in
  head/net-mgmt/pmacct/files/pmacctd.in
  head/net-mgmt/pmacct/pkg-plist
Comment 9 Kurt Jaeger freebsd_committer 2018-02-09 19:16:29 UTC
Committed, thanks!