Bug 200845 - www/firefox build fails with dtrace enabled
Summary: www/firefox build fails with dtrace enabled
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
: 209952 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-13 22:03 UTC by Tony Narlock
Modified: 2016-06-05 20:26 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Narlock 2015-06-13 22:03:14 UTC
Environment:
FreeBSD 10.1-RELEASE-p10


Error:

MAKE_JOBS_UNSAFE=yes make package
===>  Building for firefox-38.0.6,1

..

/../js/src/Unified_cpp_js_src11.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/Unified_cpp_js_src4.o: multiple definition of '__dtraceenabled_javascript___function-return'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/Unified_cpp_js_src11.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/Unified_cpp_js_src8.o: multiple definition of '__dtrace_javascript___object-create'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/jsarray.o: previous definition here
../../build/unix/gold/ld: error: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/Unified_cpp_js_src8.o: multiple definition of '__dtraceenabled_javascript___object-create'
../../build/unix/gold/ld: /usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library/../../js/src/jsarray.o: previous definition here
/usr/ports/www/firefox/work/mozilla-release/ipc/chromium/src/base/process_util_bsd.cc:117: warning: undefined reference to 'environ'
/usr/ports/www/firefox/work/mozilla-release/ipc/chromium/src/base/process_util_bsd.cc:117: warning: undefined reference to 'environ'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
/usr/ports/www/firefox/work/mozilla-release/config/rules.mk:812: recipe for target 'libxul.so' failed
gmake[7]: *** [libxul.so] Error 1
gmake[7]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1/toolkit/library'
/usr/ports/www/firefox/work/mozilla-release/config/recurse.mk:74: recipe for target 'toolkit/library/target' failed
gmake[6]: *** [toolkit/library/target] Error 2
gmake[6]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1'
/usr/ports/www/firefox/work/mozilla-release/config/recurse.mk:36: recipe for target 'compile' failed
gmake[5]: *** [compile] Error 2
gmake[5]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1'
/usr/ports/www/firefox/work/mozilla-release/config/rules.mk:541: recipe for target 'default' failed
gmake[4]: *** [default] Error 2
gmake[4]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release/obj-x86_64-portbld-freebsd10.1'
/usr/ports/www/firefox/work/mozilla-release/client.mk:398: recipe for target 'realbuild' failed
gmake[3]: *** [realbuild] Error 2
gmake[3]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release'
/usr/ports/www/firefox/work/mozilla-release/client.mk:171: recipe for target 'build' failed
gmake[2]: *** [build] Error 2
gmake[2]: Leaving directory '/usr/ports/www/firefox/work/mozilla-release'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/firefox
*** Error code 1

Stop.
make: stopped in /usr/ports/www/firefox
Comment 1 Jan Beich freebsd_committer 2015-07-19 11:56:30 UTC
Try disabling either DEBUG or DTRACE option, or add --disable-gold to MOZ_OPTIONS.
Comment 2 commit-hook freebsd_committer 2016-06-03 10:53:27 UTC
A commit references this bug:

Author: jbeich
Date: Fri Jun  3 10:52:46 UTC 2016
New revision: 416309
URL: https://svnweb.freebsd.org/changeset/ports/416309

Log:
  www/firefox: update to 47.0 (rc2) / 45.2esr

  - Adjust firefox-esr-i18n for linux-firefox after r414580
  - Unbreak DTRACE=on + DEBUG=on [1]
  - Unbreak FFMPEG=off [2]

  Changes:	https://www.mozilla.org/firefox/47.0/releasenotes/
  Changes:	https://www.mozilla.org/firefox/45.2.0/releasenotes/
  Security:	8065d37b-8e7c-4707-a608-1b0a2b8509c3
  PR:		200845, 209952 [1], 209308 [2]
  MFH:		2016Q2

Changes:
  head/Mk/Uses/gecko.mk
  head/Mk/bsd.gecko.mk
  head/www/firefox/Makefile
  head/www/firefox/distinfo
  head/www/firefox/files/patch-bug1021761
  head/www/firefox/files/patch-bug1239550
  head/www/firefox/files/patch-bug1242132
  head/www/firefox/files/patch-bug1243312
  head/www/firefox/files/patch-bug1252246
  head/www/firefox/files/patch-bug1269165
  head/www/firefox/files/patch-bug826985
  head/www/firefox/files/patch-bug847568
  head/www/firefox/files/patch-ijg-libjpeg
  head/www/firefox/files/patch-sample-type
  head/www/firefox/files/patch-z-bug517422
  head/www/firefox-esr/Makefile
  head/www/firefox-esr/distinfo
  head/www/firefox-esr/files/patch-bug1269165
  head/www/firefox-esr-i18n/Makefile
  head/www/firefox-esr-i18n/distinfo
  head/www/firefox-i18n/Makefile
  head/www/firefox-i18n/Makefile.lang
  head/www/firefox-i18n/Makefile.option
  head/www/firefox-i18n/distinfo
  head/www/libxul/Makefile
  head/www/libxul/distinfo
  head/www/linux-firefox/Makefile
  head/www/linux-firefox/distinfo
Comment 3 Jan Beich freebsd_committer 2016-06-03 11:15:32 UTC
*** Bug 209952 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2016-06-05 20:26:43 UTC
A commit references this bug:

Author: jbeich
Date: Sun Jun  5 20:25:45 UTC 2016
New revision: 416430
URL: https://svnweb.freebsd.org/changeset/ports/416430

Log:
  MFH: r416309 r416312 r416394

  www/firefox: update to 47.0 (rc3) / 45.2esr

  - Adjust firefox-esr-i18n for linux-firefox after r414580
  - Unbreak DTRACE=on + DEBUG=on [1]
  - Unbreak FFMPEG=off [2]

  Changes:	https://www.mozilla.org/firefox/47.0/releasenotes/
  Changes:	https://www.mozilla.org/firefox/45.2.0/releasenotes/
  Security:	8065d37b-8e7c-4707-a608-1b0a2b8509c3
  PR:		200845, 209952 [1], 209308 [2]
  Approved by:	ports-secteam (feld, junovitch)

Changes:
_U  branches/2016Q2/
  branches/2016Q2/Mk/Uses/gecko.mk
  branches/2016Q2/Mk/bsd.gecko.mk
  branches/2016Q2/www/firefox/Makefile
  branches/2016Q2/www/firefox/distinfo
  branches/2016Q2/www/firefox/files/patch-bug1021761
  branches/2016Q2/www/firefox/files/patch-bug1239550
  branches/2016Q2/www/firefox/files/patch-bug1242132
  branches/2016Q2/www/firefox/files/patch-bug1243312
  branches/2016Q2/www/firefox/files/patch-bug1252246
  branches/2016Q2/www/firefox/files/patch-bug1269165
  branches/2016Q2/www/firefox/files/patch-bug826985
  branches/2016Q2/www/firefox/files/patch-bug847568
  branches/2016Q2/www/firefox/files/patch-ijg-libjpeg
  branches/2016Q2/www/firefox/files/patch-sample-type
  branches/2016Q2/www/firefox/files/patch-z-bug517422
  branches/2016Q2/www/firefox-esr/Makefile
  branches/2016Q2/www/firefox-esr/distinfo
  branches/2016Q2/www/firefox-esr/files/patch-bug1269165
  branches/2016Q2/www/firefox-esr-i18n/Makefile
  branches/2016Q2/www/firefox-esr-i18n/distinfo
  branches/2016Q2/www/firefox-i18n/Makefile
  branches/2016Q2/www/firefox-i18n/Makefile.lang
  branches/2016Q2/www/firefox-i18n/Makefile.option
  branches/2016Q2/www/firefox-i18n/distinfo
  branches/2016Q2/www/libxul/Makefile
  branches/2016Q2/www/libxul/distinfo
  branches/2016Q2/www/libxul/files/patch-bug1269165
  branches/2016Q2/www/linux-firefox/Makefile
  branches/2016Q2/www/linux-firefox/distinfo