Bug 200869 - net-p2p/libtorrent-rasterbar-python - libtorrent-rasterbar.so.8: No such file
Summary: net-p2p/libtorrent-rasterbar-python - libtorrent-rasterbar.so.8: No such file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guido Falsi
URL:
Keywords:
: 200873 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-15 09:29 UTC by donnex
Modified: 2015-06-15 14:20 UTC (History)
3 users (show)

See Also:


Attachments
Log (73.31 KB, text/plain)
2015-06-15 09:29 UTC, donnex
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description donnex 2015-06-15 09:29:23 UTC
Created attachment 157755 [details]
Log

I'm running FreeBSD 10.1-RELEASE-p12 and using Poudriere to build net-p2p/deluge.

For the last few days this build has failed when building net-p2p/libtorrent-rasterbar-python.

/usr/bin/strip: '/wrkdirs/usr/ports/net-p2p/libtorrent-rasterbar-python/work/stage/usr/local/lib/libtorrent-rasterbar.so.8': No such file

When checking portsmon it's also failing to build:
http://portsmon.freebsd.org/portoverview.py?category=net-p2p&portname=libtorrent-rasterbar-python
Comment 1 Guido Falsi freebsd_committer 2015-06-15 09:38:09 UTC
Hi,

This is my fault. I'm sorry.

I'm going to fix this ASAP.
Comment 2 Guido Falsi freebsd_committer 2015-06-15 13:34:58 UTC
Fixed in r389706.

Thanks for reporting!
Comment 3 commit-hook freebsd_committer 2015-06-15 13:35:00 UTC
A commit references this bug:

Author: madpilot
Date: Mon Jun 15 13:34:31 UTC 2015
New revision: 389706
URL: https://svnweb.freebsd.org/changeset/ports/389706

Log:
  Fix breakage introduced in r389250.

  PR:		200869
  Submitted by:	donnex at donnex.net
  Pointy hat to:	me

Changes:
  head/net-p2p/libtorrent-rasterbar/Makefile
Comment 4 Guido Falsi freebsd_committer 2015-06-15 14:20:28 UTC
*** Bug 200873 has been marked as a duplicate of this bug. ***