Bug 200883 - Installing FreeBSD 10.1-RELEASE-amd64-{disk1|dvd1}.iso fails to install on Dell C6220, bootonly.iso works
Summary: Installing FreeBSD 10.1-RELEASE-amd64-{disk1|dvd1}.iso fails to install on De...
Status: In Progress
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-15 19:56 UTC by Benedict Reuschling
Modified: 2018-05-22 14:13 UTC (History)
2 users (show)

See Also:


Attachments
LOR on shutdown after install is complete (77.23 KB, image/jpeg)
2018-05-22 14:10 UTC, Benedict Reuschling
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benedict Reuschling freebsd_committer 2015-06-15 19:56:25 UTC
I'm trying to install FreeBSD 10.1-RELEASE-amd64-{disk1|dvd1}.iso on a Dell C6220 using their Java Webstart (Version 6) web-based management console. I mount the ISO, boot the system from it and configure disk-space, select distributions to install, etc. The installation starts and proceeds up to 50% installed (according to the progess bar), then the Java-based viewer errors out and disconnects the mounted ISO and monitor. 
When I reconnect, the installer can't continue due to missing media and the installation is broken and needs to be restarted. I can reproduce the error, each time it reaches only 50%. Right before reaching it, I see a drop of transferred packets until it reaches zero, then it stays there and then the error occurs.
Installing Ubuntu and other penguin OSes work fine being installed from ISOs as described above.

I showed this behavior to sbruno@ in the BSDCan 2015 Hacker Lounge and we tried the bootonly.iso together. This worked flawlessly and I can install a complete FreeBSD system this way.  Sean experienced similar issues and suspects a timeout in the CAM layer (CD-ROM/DVD emulation). He suggested to open this PR so we can fix the issue, as he experienced similar issues with his C6220 systems.

Things I can do to narrow the problem down:
- Update the BIOS of the C6220 to the latest version from Dell
- Test a CURRENT-Snapshot
- Open a problem report with Dell
- test patches you sent me and provide feedback

I have 28 of those Dell C6220 under my control and would very much like to use FreeBSD on them.

If you need more information, let me know.

Best regards

Benedict Reuschling
Comment 1 Benedict Reuschling freebsd_committer 2015-06-16 16:30:34 UTC
Assign to sbruno for now so we can work on it.
Comment 2 Benedict Reuschling freebsd_committer 2015-06-18 09:07:10 UTC
I just tried installing the following CURRENT snapshot: FreeBSD-11.0-CURRENT-amd64-r283577-20150526.disc1.iso. IT WORKED! No hangs or error messages, distributions were extracted completely and I have a complete FreeBSD system now.

Sean, can you confirm this on your own machines?
Comment 3 Sean Bruno freebsd_committer 2015-07-03 02:19:34 UTC
hrm ... my hardware was shipped away.  I can't test this any longer.

Can you try the 10.2r ISO images and see if they're any happier.  If not, maybe there's a missing MFC that makes current much happier.
Comment 4 Benedict Reuschling freebsd_committer 2015-07-08 13:55:34 UTC
I just tested it with FreeBSD-10.2-PRERELEASE-amd64-20150625-r284813-disc1.iso . The same issue as before: the viewer connection gets terminated during the installation process, ejecting the media in the process. I can reliably reproduce the issue each time.

Note: I did install the same machine a couple of times with the FreeBSD-11.0-CURRENT-amd64-r283577-20150526.disc1.iso . In one of these instances, the viewer crashed as well. But this was only one instance and next time, the installer completed just fine and I couldn't reproduce the error like in 10.X. 

We should try to identify which MFC is missing that makes a difference between 10.X and 11-CURRENT and the behaviour I'm experiencing.
Comment 5 Glen Barber freebsd_committer 2015-07-20 21:11:47 UTC
Can you please check if the problem persists with 10.2-BETA2?  There was a change to loader.conf by default in stable/10 recently, which was in head for a long time, and I am curious if this was the underlying cause of this problem.
Comment 6 Eitan Adler freebsd_committer freebsd_triage 2018-05-20 23:52:14 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"
Comment 7 Glen Barber freebsd_committer 2018-05-21 15:12:07 UTC
Is this still an issue with a supported release?  Can you test this with 11.2-BETA2, for example?
Comment 8 Benedict Reuschling freebsd_committer 2018-05-21 15:23:27 UTC
I can do that tomorrow. My experiences so far is that the updated version of the C6220 firmware made the FreeBSD ISO installation worse, whereas Linux (only tested it with Ubuntu) seems to work fine. There are random disconnects of the viewer and when that happens, the following tries also don't work for a number of tries. Then, it works again. My guess is that the problem lies with the firmware and not FreeBSD itself. Problem with that is that it does happen less often (or maybe not at all) with Linux.
But there have also been a number of changes to the FreeBSD boot process recently, so we might be lucky. I'll test it with 11.2-BETA2 and a recent CURRENT snapshot and see what we get. I'll let you know.
Comment 9 Glen Barber freebsd_committer 2018-05-21 15:26:26 UTC
For my own curiosity, could you also test the i386 ISO for 11.2 and 12.0?
Comment 10 Benedict Reuschling freebsd_committer 2018-05-22 14:10:22 UTC
Created attachment 193609 [details]
LOR on shutdown after install is complete
Comment 11 Benedict Reuschling freebsd_committer 2018-05-22 14:13:10 UTC
I've tested the following ISOs:

- FreeBSD-11.2-BETA2-amd64-disc1
- FreeBSD-11.2-BETA2-i386-disc1
- FreeBSD-12.0-CURRENT-amd64-20180426-r333017-disc1
- FreeBSD-12.0-CURRENT-i386-20180426-r333017-disc1

All of these work by installing a new system. With the last two, I've encountered a LOR that I attached. It appears when the system shuts down after the install is complete. Not sure if that has been encountered before. I can search the PR database and add it when necessary.

My original issue is solved though.