Bug 200900 - [patch] mail/opendkim - update to latest version (2.10.3)
Summary: [patch] mail/opendkim - update to latest version (2.10.3)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Guido Falsi
URL:
Keywords: patch
: 200899 (view as bug list)
Depends on: 202056 202057
Blocks:
  Show dependency treegraph
 
Reported: 2015-06-16 08:16 UTC by Daniel Austin
Modified: 2015-08-06 22:36 UTC (History)
3 users (show)

See Also:


Attachments
update opendkim to 2.10.3 (1.60 KB, patch)
2015-06-16 08:17 UTC, Daniel Austin
no flags Details | Diff
Mail/OpenDKIM failure log (24.90 KB, text/plain)
2015-07-30 20:07 UTC, Guido Falsi
no flags Details
DIFFHEADERS option failure (101.77 KB, text/plain)
2015-07-30 20:08 UTC, Guido Falsi
no flags Details
Linker failure (126.23 KB, text/plain)
2015-07-30 20:08 UTC, Guido Falsi
no flags Details
update opendkim to 2.10.3 and fix errors (2.94 KB, patch)
2015-07-31 17:33 UTC, Daniel Austin
no flags Details | Diff
update opendkim to 2.10.3 and fix various errors (2.89 KB, patch)
2015-08-01 16:38 UTC, Daniel Austin
no flags Details | Diff
update opendkim to 2.10.3 and fix various errors (2.89 KB, patch)
2015-08-06 16:40 UTC, Daniel Austin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Austin 2015-06-16 08:16:41 UTC
Update mail/opendkim to latest version (resolving several bugs)

Poudriere testport logs at:

http://poudriere.dan.tm/poudriere/data/latest-per-pkg/opendkim/2.10.3/
Comment 1 Daniel Austin 2015-06-16 08:17:19 UTC
Created attachment 157798 [details]
update opendkim to 2.10.3
Comment 2 Dmitry Marakasov freebsd_committer 2015-06-16 19:41:47 UTC
*** Bug 200899 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Austin 2015-07-25 08:04:45 UTC
any news on this?
it's been over a month with no feedback from the maintainer.

I'm happy to take over maintainer if the current maintainer is missing.
Comment 4 Guido Falsi freebsd_committer 2015-07-27 21:30:04 UTC
Maintainer timeout.
Comment 5 Guido Falsi freebsd_committer 2015-07-30 20:06:22 UTC
Hi,

While testing the update I discovered a pair of issues:

- This update causes the dependent port mail/p5-Mail-OpenDKIM to fail. Looks like something is changed in opendkim includes causing this failure.

- The DIFFHEADERS option(off by default) causes the port to fail due to invalid C++ code. This should be fixed by patching/updating the dependent port.

- Some other option causes the port to fail with clang, I'm guessing due to a missing -pthread option to the linker. I'm sorry but I couldn't identify the option causing this.

Can you check this issues and see if you can send a new patch solving these?

I'm uploading logs showing the failure described above.

Thanks.
Comment 6 Guido Falsi freebsd_committer 2015-07-30 20:07:49 UTC
Created attachment 159396 [details]
Mail/OpenDKIM failure log
Comment 7 Guido Falsi freebsd_committer 2015-07-30 20:08:24 UTC
Created attachment 159397 [details]
DIFFHEADERS option failure
Comment 8 Guido Falsi freebsd_committer 2015-07-30 20:08:54 UTC
Created attachment 159398 [details]
Linker failure
Comment 9 Daniel Austin 2015-07-30 23:48:36 UTC
mail/p5-Mail-OpenDKIM fails to build as opendkim removed support for ADSP 18 months ago, which the perl module requires to compile.

See: https://sourceforge.net/p/opendkim/bugs/183/

OpenDKIM 2.10.0 onwards has all ADSP support removed.
The perl module has had no releases in around the same amount of time.


So we can either never upgrade to OpenDKIM 2.10.x, or seek an alternative to p5-Mail-OpenDKIM :/
Comment 10 Daniel Austin 2015-07-31 17:33:25 UTC
Created attachment 159418 [details]
update opendkim to 2.10.3 and fix errors
Comment 11 Daniel Austin 2015-07-31 17:36:19 UTC
Hi Guido,

I've replaced the patch with a new one that fixes the problems with the DIFFHEADERS option (it can't have ever worked as it required a dependancy!)

Poudriere testport logs for 8/9/10 i386/amd64 defaults and with DIFFHEADERS enabled are at:

https://poudriere.dan.tm/poudriere/data/latest-per-pkg/opendkim/2.10.3/


The only outstanding issue is that it breaks p5-Mail-OpenDKIM which can only be resolved by the maintainer of that port (who is also the author of that software)

I can't see anything in the ports tree that depends on p5-Mail-OpenDKIM directly.
I suspect the author may just remove the references to the removed functions.
Comment 12 Guido Falsi freebsd_committer 2015-08-01 12:44:49 UTC
I'm adding mail/p5-Mail-OpenDKIM maintainer to the CC list of this port.

to vivek, can you please check this bug report and post your feedback about what to do with the port you maintain? Thanks.

To submitter: I'll test the new patch shortly. If a solution for p5-Mail-OpenDKIM can be found I'll include it, otherwise, at a minimum, we should mark that port as broken, but I'd rather have feedback from the maintainer before taking such a drastic measure.

Thanks!
Comment 13 Daniel Austin 2015-08-01 12:49:40 UTC
Hi Guido,

I'm still working on the linker error - that's going to take some more time, but the current patch should fix the diffheaders issues.
Comment 14 Daniel Austin 2015-08-01 16:38:18 UTC
Created attachment 159440 [details]
update opendkim to 2.10.3 and fix various errors
Comment 15 Daniel Austin 2015-08-01 16:41:38 UTC
Ok, final (i hope) patch uploaded which should fix all errors.
I've done testport's on each individual option and all options together.
The linker error was due to the debugging options when in conjunction with other options. Now the debugging option which caused it adds in the pthread library.

I've also updated maintainer to me as the port maintainer has been silent for so long - i'll leave it up to you whether it's been long enough for that.

testport logs are building at the same URL as before for 8/9/10 i386/amd64 and will hopefully be done by the time you look at this :-)

there's logs called ALLOPTS and DIFFHEADERS for the 2 specific tests I did within 10.1/amd64 - the other tests will be with default options identical to how the bsd package builder will use.
Comment 16 Guido Falsi freebsd_committer 2015-08-03 07:45:20 UTC
(In reply to Daniel Austin from comment #15)

Regarding the maintainership, I asked portmgr about this, and was pointed here:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-maintainer.html

second paragraph states that three consecutive 15 days timeouts or one three month timeout is required, I see three timeouts in the history so I'll grant that, but we need to give a little time to mail/p5-Mail-OpenDKIM author to answer. If he does not answer I'll update this port and mark p5-Mail-OpenDKIM broken for the time being.
Comment 17 Vick Khera 2015-08-04 02:00:19 UTC
I don't recall getting the original email about this ticket, but that's neither here nor there.  We have stopped using Mail::OpenDKIM in favor of Mail::DKIM because of some bugs with signing headers other than what the OpenDKIM library want signed (namely, the Google Feedback-ID header). Also, Mail::DKIM seems to be faster or as fast, even though it is in pure perl.

So long and short, if anyone else wishes to keep this port alive, they are free to do so. I will not be able to put any effort into it.
Comment 18 Guido Falsi freebsd_committer 2015-08-04 10:23:18 UTC
(In reply to Vick Khera from comment #17)

I added you to the CC after the fact, since the original ticket is against another port and the autoassign system has no way to know the two are connected (apart from one being dependency of another but that's not sufficient to send automated emails).

You could also have gotten an email about bug 202056, but, since you say that Mail::OpenDKIM will not be maintained an Mail::DKIM can be used as a replacement I'll be marking Mail::OpenDKIM as BROKEN with an expiration timeout of a month or so, informing users to move on to Mail::DKIM.

The port will still be in the ports tree for one month and anyone willing to update and maintain it will have a chance to step up.

Are you ok with this plan?
Comment 19 Daniel Austin 2015-08-06 16:40:40 UTC
Created attachment 159620 [details]
update opendkim to 2.10.3 and fix various errors

updated patch so it applies cleanly after a port revision bump recently.
Comment 20 commit-hook freebsd_committer 2015-08-06 22:36:27 UTC
A commit references this bug:

Author: madpilot
Date: Thu Aug  6 22:36:12 UTC 2015
New revision: 393675
URL: https://svnweb.freebsd.org/changeset/ports/393675

Log:
  - Update mail/opendkim to 2.10.3
  - Assign maintainership to submitter
  - Mark mail/p5-Mail-OpenDKIM as broken, and deprecate it, please
    use mail/p5-Mail-DKIM instead

  While here:

  - Sort USES
  - Make IGNORE text start with lower case
  - Regenerate some patches

  PR:		200900
  Submitted by:	Daniel Austin <freebsd-ports at dan.me.uk>
  Approved by:	Maintainer timeout

Changes:
  head/mail/opendkim/Makefile
  head/mail/opendkim/Makefile.options
  head/mail/opendkim/distinfo
  head/mail/opendkim/files/patch-libopendkim__tests__Makefile.in
  head/mail/opendkim/files/patch-opendkim__tests__Makefile.in
  head/mail/opendkim/pkg-plist
  head/mail/p5-Mail-OpenDKIM/Makefile
Comment 21 Guido Falsi freebsd_committer 2015-08-06 22:36:40 UTC
Committed, with minor changes. Thanks!