Bug 200965 - www/chromium: downloads a binary blob related to hotword without user request
Summary: www/chromium: downloads a binary blob related to hotword without user request
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-chromium mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-19 08:33 UTC by Hukadan
Modified: 2015-09-17 19:34 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hukadan 2015-06-19 08:33:21 UTC
Chromium downloads a blob related to the hotword module without user request. This bug was already reported here (https://code.google.com/p/chromium/issues/detail?id=491435). 

The symptoms are obtained with the following version of chromium (default options) :
chromium-43.0.2357.125
Name           : chromium
Version        : 43.0.2357.125

At first launch, files are automatically downloaded as shown by the following output (just after a rm -Rf .config/chromium):

$ ls -l $HOME/.config/chromium/Default/Extensions/lccekmodgklaepjeofjdjpbminllajkg/0.3.0.5_0/_platform_specific/x86-64_
total 4386
-rw-------  1 hukadan  hukadan  1181296 Jun  5 23:54 hotword-x86-64.nexe
-rw-------  1 hukadan  hukadan  896976 Jun  5 23:54 hotword.data

Going to the following address chrome://voicesearch/, the following information are displayed:

About Voice Search

Chromium	43.0.2357.125 ()
OS	FreeBSD
NaCl Enabled	No
Microphone	No
Audio Capture Allowed	Yes
Current Language	en-US
Hotword Previous Language	en-US
Hotword Search Enabled	No
Always-on Hotword Search Enabled	No
Hotword Audio Logging Enabled	No
Field trial	
Start Page State	No Start Page Service
Extension Id	nbpagnldghgfoolbancepceaanlmhfmd
Extension Version	0.0.1.4
Extension Path	/usr/local/share/chromium/resources/hotword
Extension State	ENABLED
Shared Module Id	lccekmodgklaepjeofjdjpbminllajkg
Shared Module Version	0.3.0.5
Shared Module Path	/home/hukadan/.config/chromium/Default/Extensions/lccekmodgklaepjeofjdjpbminllajkg/0.3.0.5_0
Shared Module State	ENABLED
Shared Module Platforms	x86-64_

A commit was done (https://chromium.googlesource.com/chromium/src.git/+/f269d3b548203e217e8c0080c2e22e7ae3efb51e) to make a flag available in order to disable this downloading. The flag seems not to be available yet with the port version of chromium. 

Would it be possible to make it available ? 

Thank you.
Comment 1 Tony Narlock 2015-07-20 18:51:10 UTC
As an update (43.0.2357.132) doesn't have the flag yet.

https://chromium.googlesource.com/chromium/src.git/+/43.0.2357.132/build/common.gypi
Comment 2 Tony Narlock 2015-07-24 18:13:28 UTC
May or may not be related to this: Is anyone else experiencing an Alert-like dialog if they attempt to close chromium with nothing downloading?
Comment 3 Hukadan 2015-09-17 19:34:13 UTC
I think we can safely close this bug report. The problem is not reproducible anymore on my system. Furthermore, the hotword module has been disabled by default upstream : https://chromium.googlesource.com/chromium/src.git/+/0366a5184a70b3eefb5fcef2c2e13721669f00d8.