Bug 201175 - [PATCH] devel/synfig: Update to version 1.0
Summary: [PATCH] devel/synfig: Update to version 1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-06-28 18:32 UTC by tkato432
Modified: 2015-10-04 10:46 UTC (History)
4 users (show)

See Also:


Attachments
devel_synfig.shar (32.83 KB, text/plain)
2015-06-28 18:32 UTC, tkato432
no flags Details
devel_synfig.shar (30.64 KB, text/plain)
2015-08-03 18:32 UTC, tkato432
no flags Details
devel_synfig.shar (3.02 KB, text/plain)
2015-08-26 22:00 UTC, tkato432
no flags Details
Patch to improve related ports devel/etl, devel/synfig & graphics/synfigstudio (13.40 KB, patch)
2015-09-12 08:54 UTC, Ben Woods
woodsb02: maintainer-approval+
Details | Diff
devel/etl QA: Successful poudriere testport logs on FreeBSD 10.2 amd64 (18.43 KB, text/plain)
2015-09-12 09:04 UTC, Ben Woods
no flags Details
devel/synfig QA: Successful poudriere testport logs on FreeBSD 10.2 amd64 (gzipped) (56.99 KB, application/x-gzip)
2015-09-12 09:05 UTC, Ben Woods
no flags Details
graphics/synfigstudio QA: Successful poudriere testport logs on FreeBSD 10.2 amd64 (gzipped) (57.54 KB, application/x-gzip)
2015-09-12 09:06 UTC, Ben Woods
no flags Details
Patch to update and improve related ports devel/etl, devel/synfig & graphics/synfigstudio (25.93 KB, patch)
2015-10-01 14:22 UTC, Ben Woods
woodsb02: maintainer-approval+
Details | Diff
QA: Successful poudriere testport logs of devel/etl-0.04.19 on FreeBSD 10.2 amd64 (18.43 KB, text/plain)
2015-10-01 14:57 UTC, Ben Woods
no flags Details
QA: Successful poudriere testport logs of devel/synfig-1.0.1 on FreeBSD 10.2 amd64 (gzipped) (52.45 KB, application/x-gzip)
2015-10-01 14:58 UTC, Ben Woods
no flags Details
QA: Successful poudriere testport logs of graphics/synfigstudio-1.0.1 on FreeBSD 10.2 amd64 (gzipped) (56.77 KB, application/x-gzip)
2015-10-01 15:10 UTC, Ben Woods
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tkato432 2015-06-28 18:32:13 UTC
Created attachment 158134 [details]
devel_synfig.shar

- devel/etl: Update to version 0.4.18
- devel/synfig: Update to version 1.0
- graphics/synfigstudio: Update to version 1.0
Comment 1 tkato432 2015-08-03 18:32:12 UTC
Created attachment 159502 [details]
devel_synfig.shar

Chase r388831
Comment 2 Ben Woods freebsd_committer 2015-08-11 13:17:16 UTC
FYI, this is a duplicate of my PR199802:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=199802
Comment 3 Ben Woods freebsd_committer 2015-08-26 15:55:48 UTC
Hi tkato,

Unfortunately, we overlapped our efforts and both submitted patches for the same ports.

The patches that I submitted in PR199802 have been committed. I believe that means this bug report is no longer required. If so, can you please close this bug report? Or, if there are any additional improvements which are not in the current ports tree, can you please highlight them?

Thanks for your efforts!
Comment 4 tkato432 2015-08-26 22:00:07 UTC
Created attachment 160388 [details]
devel_synfig.shar

- devel/etl: Add NO_ARCH
- devel/synfig: Add OPTIONS_DEFINE
- graphics/synfigstudio: Add optional JACK support
Comment 5 Ben Woods freebsd_committer 2015-09-12 08:54:42 UTC
Created attachment 160948 [details]
Patch to improve related ports devel/etl, devel/synfig & graphics/synfigstudio
Comment 6 Ben Woods freebsd_committer 2015-09-12 09:00:45 UTC
Comment on attachment 160388 [details]
devel_synfig.shar

Hi tkato,
Thanks for your suggested improvements. I have included them all in my attached patch and added some others, so I will mark this attachment as maintainer-approval declined (as they are all included in the other attachment).

Other improvements I made:
- remove unnecessary setting of WRKSRC to ${WRKDIR}/${DISTNAME}
- pet portlint (generate patches via makepatch, make NLS an option)
- correct synfig license to GPLv2 or later

Regards,
Ben
Comment 7 Ben Woods freebsd_committer 2015-09-12 09:04:10 UTC
Created attachment 160950 [details]
devel/etl QA: Successful poudriere testport logs on FreeBSD 10.2 amd64
Comment 8 Ben Woods freebsd_committer 2015-09-12 09:05:16 UTC
Created attachment 160951 [details]
devel/synfig QA: Successful poudriere testport logs on FreeBSD 10.2 amd64 (gzipped)
Comment 9 Ben Woods freebsd_committer 2015-09-12 09:06:10 UTC
Created attachment 160952 [details]
graphics/synfigstudio QA: Successful poudriere testport logs on FreeBSD 10.2 amd64 (gzipped)
Comment 10 Ben Woods freebsd_committer 2015-09-22 23:07:15 UTC
Wen,
If you have time, could you please have a look at committing this patch (the second attachment which is my patch incorporating tkato's recommendations)?
Thanks,
Ben
Comment 11 Ben Woods freebsd_committer 2015-10-01 14:22:15 UTC
Created attachment 161598 [details]
Patch to update and improve related ports devel/etl, devel/synfig & graphics/synfigstudio

This updated version of the patch also updates the ports as follows:
devel/etl: Update from 0.04.18 to 0.04.19
devel/synfig: Update from 1.0 to 1.0.1
graphics/synfigstudio: Update from 1.0 to 1.0.1
Comment 12 Ben Woods freebsd_committer 2015-10-01 14:57:30 UTC
Created attachment 161599 [details]
QA: Successful poudriere testport logs of devel/etl-0.04.19 on FreeBSD 10.2 amd64
Comment 13 Ben Woods freebsd_committer 2015-10-01 14:58:13 UTC
Created attachment 161600 [details]
QA: Successful poudriere testport logs of devel/synfig-1.0.1 on FreeBSD 10.2 amd64 (gzipped)
Comment 14 Ben Woods freebsd_committer 2015-10-01 15:10:18 UTC
Created attachment 161602 [details]
QA: Successful poudriere testport logs of graphics/synfigstudio-1.0.1 on FreeBSD 10.2 amd64 (gzipped)
Comment 15 Kurt Jaeger freebsd_committer 2015-10-01 16:11:21 UTC
build-testing@work
Comment 16 Ben Woods freebsd_committer 2015-10-01 22:47:17 UTC
(In reply to Kurt Jaeger from comment #15)
> build-testing@work

Thanks Kurt. Please be aware that the current graphics/synfigstudio port does not build on FreeBSD 9.3 amd64 (as you first reported in PR199802), and I am afraid this minor patch update does not fix that. It does build on all other releases, and I am still investigating the reason for this. I would like to commit this patch anyway, as it does not make things any worse than they already are. More details on my troubleshooting to date can be seen at the end of PR199802.

Lastly, graphics/synfigstudio will fail to build if it the new option setting for NLS is different from the NLS option setting when devel/synfig was built (e.g. Synfigstudio will fail if the NLS option is disabled and the NLS option was enabled when synfig was built).
Comment 17 Kurt Jaeger freebsd_committer 2015-10-04 10:41:43 UTC
build-tests on cur-amd64, 10.2a+i OK, 9.3a failed.

With maintainer approval: Mark 9.3 as broken for now, apply the update.
Comment 18 commit-hook freebsd_committer 2015-10-04 10:44:15 UTC
A commit references this bug:

Author: pi
Date: Sun Oct  4 10:43:33 UTC 2015
New revision: 398569
URL: https://svnweb.freebsd.org/changeset/ports/398569

Log:
  devel/etl: 0.4.18 -> 0.04.19
  devel/synfig: 1.0 -> 1.0.1
  graphics/synfigstudio: 1.0 -> 1.0.1

  PR:		201175
  Submitted by:	Ben Woods <woodsb02@gmail.com> (maintainer)

Changes:
  head/devel/etl/Makefile
  head/devel/etl/distinfo
  head/devel/etl/files/patch-ETL___stringf.h
  head/devel/etl/files/patch-ETL___surface.h
  head/devel/synfig/Makefile
  head/devel/synfig/distinfo
  head/devel/synfig/files/patch-src__synfig__main.cpp
  head/devel/synfig/files/patch-src__synfig__transform.cpp
  head/devel/synfig/pkg-plist
  head/graphics/synfigstudio/Makefile
  head/graphics/synfigstudio/distinfo
  head/graphics/synfigstudio/files/patch-src_synfigapp_cvs.cpp
  head/graphics/synfigstudio/pkg-plist
Comment 19 Kurt Jaeger freebsd_committer 2015-10-04 10:46:20 UTC
Committed, thanks. Please try to find a solution for 9.3.