Bug 201254 - x11/xscreensaver Old version warnings when starting / using xscreensaver settings
Summary: x11/xscreensaver Old version warnings when starting / using xscreensaver sett...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Niclas Zeising
URL:
Keywords: patch
: 194799 202158 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-01 16:17 UTC by Will B
Modified: 2015-10-02 14:26 UTC (History)
6 users (show)

See Also:
bugzilla: maintainer-feedback? (zeising)


Attachments
Screenshot of xscreensaver old version warning (7.82 KB, image/png)
2015-07-01 16:17 UTC, Will B
no flags Details
update patch (11.57 KB, patch)
2015-07-01 23:13 UTC, Guido Falsi
no flags Details | Diff
poudriere buid log on 10.1 AMD64 (768.59 KB, text/plain)
2015-07-03 15:43 UTC, Guido Falsi
no flags Details
Update to 5.33 (13.93 KB, patch)
2015-07-04 06:20 UTC, Ashish SHUKLA
no flags Details | Diff
New patch (16.39 KB, patch)
2015-07-04 14:00 UTC, Guido Falsi
madpilot: maintainer-approval? (zeising)
Details | Diff
poudriere log for new patch (774.69 KB, text/plain)
2015-07-04 14:03 UTC, Guido Falsi
no flags Details
new distinfo fo rerolled distfile (144 bytes, text/plain)
2015-07-05 20:21 UTC, Guido Falsi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will B 2015-07-01 16:17:30 UTC
Created attachment 158225 [details]
Screenshot of xscreensaver old version warning

When starting xscreensaver and running the xscreensaver-demo program to make changes, there are warnings that the version of xscreensaver is too old.

When xscreensaver-demo is started, it shows the following message:

> Warning:
> This version of xscreensaver is VERY OLD!
> Please upgrade!
> http://www.jwz.org/xscreensaver/
> 
> (If this is the latest version that your distro ships, then
> your distro is doing you a disservice. Build from source.)

I have also included a screenshot when xscreensaver -no-splash is run.

I am running 10.1-RELEASE-p14 - 64-bit.

My packages are completely updated and I check often.

Thank you :)
Comment 1 Guido Falsi freebsd_committer 2015-07-01 16:26:14 UTC
I just noticed this report, I'm preparing an update to the port I was planning to submit once ready.

I'll post it as a further followup to this bug as soon I have it ready, unless someone beats me to it.
Comment 2 Guido Falsi freebsd_committer 2015-07-01 23:13:06 UTC
Created attachment 158242 [details]
update patch

Here is my patch to update the port to the latest version, 5.32.

The Makefiles for this port are a little messy.

Even if PAM is disabled it anyway installs an xscreensaver.pam file, which I remove, to avoid leftovers.

I also had to pass the port both DESTDIR and install_prefix, since the Makefile.in.in used in the po directory expects DESTDIR, while the rest of the Makefiles use the non standard install_prefix variable.

I added an XFT option to control linking to libxft, to avoid hidden dependencies.

I also modernized the playlist and regenerated patches to silence portlint warnings.
Comment 3 Guido Falsi freebsd_committer 2015-07-03 15:43:51 UTC
Created attachment 158291 [details]
poudriere buid log on 10.1 AMD64

For completeness I'm adding a poudriere build log.
Comment 4 Ashish SHUKLA freebsd_committer 2015-07-04 06:20:13 UTC
Created attachment 158320 [details]
Update to 5.33

I noticed that 5.33 is out, and came to look for an update PR, and came across this. I updated the diff for update to 5.32, to update to 5.33 now.

Thanks for working on the update.

HTH
Comment 5 Ashish SHUKLA freebsd_committer 2015-07-04 06:26:26 UTC
One more thing which might needs to be fixed in port, that PAM support does not work if xscreensaver binary is not setuid root, i.e. if xscreensaver port is built/staged as unprivileged user, so might need to explicitly setuid-root it, if a working PAM support is desired, at least cases where PAM authentication is Unix authentication.

HTH
Comment 6 Guido Falsi freebsd_committer 2015-07-04 09:29:04 UTC
*** Bug 194799 has been marked as a duplicate of this bug. ***
Comment 7 Guido Falsi freebsd_committer 2015-07-04 14:00:41 UTC
Created attachment 158334 [details]
New patch

This is a further patch which solves some problems:

- Allows packaging as a user
- Installs the executable setuid as intended
- Adds NLS knob (inspired by bug 193627)
Comment 8 Guido Falsi freebsd_committer 2015-07-04 14:03:07 UTC
Created attachment 158335 [details]
poudriere log for new patch
Comment 9 Niclas Zeising freebsd_committer 2015-07-05 18:42:17 UTC
Hi!
While looking into this, I noticed that the distinfo doesn't match what I get when fetching the file.  Can you please double check your file and the source from where you downloaded it.
Comment 10 Guido Falsi freebsd_committer 2015-07-05 20:21:19 UTC
(In reply to Niclas Zeising from comment #9)

I used the distinfo in the patch from Ashish. It did download and checksum correctly the other day. Now it does not, looks like the distfile has been rerolled in the while.

Attaching the new distinfo.

Diffing the two archives after extraction it looks like the old one contains a bunch of android related files, from an android build. This could explain why the distfile was rerolled.
Comment 11 Guido Falsi freebsd_committer 2015-07-05 20:21:47 UTC
Created attachment 158395 [details]
new distinfo fo rerolled distfile
Comment 12 Niclas Zeising freebsd_committer 2015-07-05 20:32:58 UTC
That's the same distinfo I get.  Thanks for helping me clearing that up.  Distinfo magically changing isn't a good thing normally.
It's getting late here, so unfortunately I won't complete this review tonight.  I'll continue tomorrow after work.
Thank you for all help, and apologies for the delays.
Comment 13 Guido Falsi freebsd_committer 2015-08-07 20:03:50 UTC
*** Bug 202158 has been marked as a duplicate of this bug. ***
Comment 14 commit-hook freebsd_committer 2015-10-02 08:41:46 UTC
A commit references this bug:

Author: madpilot
Date: Fri Oct  2 08:41:00 UTC 2015
New revision: 398425
URL: https://svnweb.freebsd.org/changeset/ports/398425

Log:
  - Update to 5.33
  - Resolves the obnoxious startup message issue [1]
  - Add options NLS and XFT
  - Convert to USES=autoreconf
  - Don't install pam file when PAM option is disabled
  - Regenerate patches

  PR:		201254
  Submitted by:	Will B. <will_brokenbourgh at yahoo.com>
  Approved by:	Maintainer timeout
  MFH:		2015Q4 [1]

Changes:
  head/x11/xscreensaver/Makefile
  head/x11/xscreensaver/distinfo
  head/x11/xscreensaver/files/patch-config.h.in
  head/x11/xscreensaver/files/patch-configure.in
  head/x11/xscreensaver/files/patch-driver_Makefile.in
  head/x11/xscreensaver/files/patch-driver_XScreenSaver.ad.in
  head/x11/xscreensaver/files/patch-hacks__config__sonar.xml
  head/x11/xscreensaver/files/patch-hacks_memscroller.c
  head/x11/xscreensaver/files/patch-utils_textclient.c
  head/x11/xscreensaver/pkg-plist
Comment 15 Guido Falsi freebsd_committer 2015-10-02 08:41:54 UTC
Committed due to maintainer timeout.

Waiting for MFH request to be completed before closing.
Comment 16 commit-hook freebsd_committer 2015-10-02 14:26:10 UTC
A commit references this bug:

Author: madpilot
Date: Fri Oct  2 14:25:31 UTC 2015
New revision: 398434
URL: https://svnweb.freebsd.org/changeset/ports/398434

Log:
  MFH: r398425

  - Update to 5.33
  - Resolves the obnoxious startup message issue [1]
  - Add options NLS and XFT
  - Convert to USES=autoreconf
  - Don't install pam file when PAM option is disabled
  - Regenerate patches

  PR:		201254
  Submitted by:	Will B. <will_brokenbourgh at yahoo.com>
  Approved by:	Maintainer timeout

  Approved by:	ports-secteam (feld)

Changes:
_U  branches/2015Q4/
  branches/2015Q4/x11/xscreensaver/Makefile
  branches/2015Q4/x11/xscreensaver/distinfo
  branches/2015Q4/x11/xscreensaver/files/patch-config.h.in
  branches/2015Q4/x11/xscreensaver/files/patch-configure.in
  branches/2015Q4/x11/xscreensaver/files/patch-driver_Makefile.in
  branches/2015Q4/x11/xscreensaver/files/patch-driver_XScreenSaver.ad.in
  branches/2015Q4/x11/xscreensaver/files/patch-hacks__config__sonar.xml
  branches/2015Q4/x11/xscreensaver/files/patch-hacks_memscroller.c
  branches/2015Q4/x11/xscreensaver/files/patch-utils_textclient.c
  branches/2015Q4/x11/xscreensaver/pkg-plist
Comment 17 Guido Falsi freebsd_committer 2015-10-02 14:26:52 UTC
Merged to 2015Q4.