Bug 201317 - [patch] databases/mysql-connector-java: Update to 5.1.36 and restrict to Java 6&7
Summary: [patch] databases/mysql-connector-java: Update to 5.1.36 and restrict to Java...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Matthew Seaman
URL:
Keywords: patch
: 201315 201316 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-03 20:20 UTC by Greg Lewis
Modified: 2015-07-04 10:17 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (matthew)


Attachments
Patch (1011 bytes, patch)
2015-07-03 20:21 UTC, Greg Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Lewis freebsd_committer 2015-07-03 20:20:28 UTC
. Update databases/mysql-connector-java to 5.1.36
. Limit the supported Java versions to 6 & 7 since compilation fails with Java 8.
Comment 1 Greg Lewis freebsd_committer 2015-07-03 20:21:16 UTC
Created attachment 158309 [details]
Patch
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-07-03 22:11:13 UTC
*** Bug 201316 has been marked as a duplicate of this bug. ***
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2015-07-03 22:11:22 UTC
*** Bug 201315 has been marked as a duplicate of this bug. ***
Comment 4 Greg Lewis freebsd_committer 2015-07-03 23:07:57 UTC
Ugh.  Any ideas why Bugzilla created three separate bugs?
Comment 5 commit-hook freebsd_committer 2015-07-04 10:16:58 UTC
A commit references this bug:

Author: matthew
Date: Sat Jul  4 10:16:45 UTC 2015
New revision: 391301
URL: https://svnweb.freebsd.org/changeset/ports/391301

Log:
  Update to 5.1.36

    - limit acceptable OpenJDK versions to 1.6 and 1.7

  Change Log:	https://dev.mysql.com/doc/relnotes/connector-j/en/news-5-1-36.html
  PR:		201317
  Submitted by:	glewis

Changes:
  head/databases/mysql-connector-java/Makefile
  head/databases/mysql-connector-java/distinfo
Comment 6 Matthew Seaman freebsd_committer 2015-07-04 10:17:51 UTC
Committed, thanks!