Bug 201328 - multimedia/quodlibet remove deprecated EXTENSIONS option and misc improvements
Summary: multimedia/quodlibet remove deprecated EXTENSIONS option and misc improvements
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Pawel Pekala
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-04 12:03 UTC by Pawel Pekala
Modified: 2015-08-01 07:47 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (johnson.peter)


Attachments
proposed changes (3.18 KB, patch)
2015-07-04 12:03 UTC, Pawel Pekala
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Pekala freebsd_committer 2015-07-04 12:03:00 UTC
Created attachment 158324 [details]
proposed changes

Proposed patch removes EXTENSIONS option which uses now
deprecated x11-toolkits/py-gnome-extras port, which was removed in r372768

While here few improvements to make port follow modern standards:

- make (RUN|BUILD)_DEPENDS path independent
- use option helpers to make things more readable
Comment 1 commit-hook freebsd_committer 2015-08-01 07:47:16 UTC
A commit references this bug:

Author: pawel
Date: Sat Aug  1 07:46:23 UTC 2015
New revision: 393388
URL: https://svnweb.freebsd.org/changeset/ports/393388

Log:
  - Remove EXTENSIONS option it depended on USE_GNOME=pygnomeestras
    funcionality removed in r372768
  - Make depends path independent
  - Use option helpers for better clarity

  PR:		201328
  Submitted by:	myslef
  Approved by:	maintainer timeout

Changes:
  head/multimedia/quodlibet/Makefile