Bug 201345 - science/py-scikit-sparse: Cannot build with python 3
Summary: science/py-scikit-sparse: Cannot build with python 3
Status: Closed DUPLICATE of bug 201346
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-04 21:56 UTC by John W. O'Brien
Modified: 2015-07-04 22:51 UTC (History)
1 user (show)

See Also:


Attachments
science/py-scikit-sparse: Use print function in test_cholmod (2.65 KB, patch)
2015-07-04 21:56 UTC, John W. O'Brien
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John W. O'Brien 2015-07-04 21:56:45 UTC
Created attachment 158350 [details]
science/py-scikit-sparse: Use print function in test_cholmod

The stage target fails with:

====
byte-compiling /wrkdirs/usr/ports/science/py-scikit-sparse/work/stage/usr/local/lib/python3.4/site-packages/scikits/sparse/test_cholmod.py to test_cholmod.cpython-34.pyc
writing byte-compilation script '/tmp/tmpu41n5nsp.py'
/usr/local/bin/python3.4 -O /tmp/tmpu41n5nsp.py
  File "/usr/local/lib/python3.4/site-packages/scikits/sparse/test_cholmod.py", line 56
    print "dense"
                ^
SyntaxError: Missing parentheses in call to 'print'
====

The cause is self-explanatory. The attached patch corrects this and allows this port to be built under python 3.

While here, update WWW in pkg-descr to match the README and the redirect from Google Code.
Comment 1 John W. O'Brien 2015-07-04 22:51:13 UTC
Sorry for the accidental duplication.

*** This bug has been marked as a duplicate of bug 201346 ***