Bug 201346 - science/py-scikit-sparse: Cannot build with py3k
Summary: science/py-scikit-sparse: Cannot build with py3k
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: patch, patch-ready
: 201343 201344 201345 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-04 22:00 UTC by John W. O'Brien
Modified: 2015-07-26 15:18 UTC (History)
4 users (show)

See Also:
yuri: maintainer-feedback+


Attachments
science/py-scikit-sparse: Use print function in test_cholmod (2.65 KB, patch)
2015-07-04 22:00 UTC, John W. O'Brien
no flags Details | Diff
poudriere testport log for py27-scikit-sparse-0.2_1 (26.96 KB, text/plain)
2015-07-05 00:54 UTC, John W. O'Brien
no flags Details
poudriere testport log for py34-scikit-sparse-0.2_1 (26.95 KB, text/plain)
2015-07-05 00:55 UTC, John W. O'Brien
no flags Details
science/py-scikit-sparse: Use print function in test_cholmod (2.77 KB, patch)
2015-07-05 01:02 UTC, John W. O'Brien
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John W. O'Brien 2015-07-04 22:00:23 UTC
Created attachment 158351 [details]
science/py-scikit-sparse: Use print function in test_cholmod

The stage target fails with:

====
byte-compiling /wrkdirs/usr/ports/science/py-scikit-sparse/work/stage/usr/local/lib/python3.4/site-packages/scikits/sparse/test_cholmod.py to test_cholmod.cpython-34.pyc
writing byte-compilation script '/tmp/tmpu41n5nsp.py'
/usr/local/bin/python3.4 -O /tmp/tmpu41n5nsp.py
  File "/usr/local/lib/python3.4/site-packages/scikits/sparse/test_cholmod.py", line 56
    print "dense"
                ^
SyntaxError: Missing parentheses in call to 'print'
====

The cause is self-explanatory. The attached patch corrects this and allows this port to be built under python 3.

While here, update WWW in pkg-descr to match the README and the redirect from Google Code.

Note: I tried to interact properly with the maintainer feedback flags on this bug, but got a variety of nonsensical, inconsistent errors, so I gave up and submitted it without setting the maintainer feedback flag at all, even though I know it should be set.
Comment 1 Yuri Victorovich freebsd_committer 2015-07-04 22:18:58 UTC
Approved,

thanks!
Comment 2 John W. O'Brien 2015-07-04 22:50:28 UTC
*** Bug 201343 has been marked as a duplicate of this bug. ***
Comment 3 John W. O'Brien 2015-07-04 22:50:50 UTC
*** Bug 201344 has been marked as a duplicate of this bug. ***
Comment 4 John W. O'Brien 2015-07-04 22:51:13 UTC
*** Bug 201345 has been marked as a duplicate of this bug. ***
Comment 5 John W. O'Brien 2015-07-04 23:34:09 UTC
Upstreamed already. Nice!

https://github.com/njsmith/scikits-sparse/pull/12
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-05 00:43:37 UTC
Thanks John, do you have QA results to attach? (portlint, poudriere)
Comment 7 John W. O'Brien 2015-07-05 00:48:32 UTC
Hey Koobs,

% portlint -AC
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
WARN: Makefile: new ports should not set PORTREVISION.
WARN: Makefile: using hyphen in PORTNAME. consider using PKGNAMEPREFIX and/or PKGNAMESUFFIX.
WARN: Makefile: wrong dependency value for BUILD_DEPENDS. BUILD_DEPENDS requires 2 or 3 colon-separated tuples.
0 fatal errors and 4 warnings found.


poudriere testport output on its way shortly.
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-05 00:53:30 UTC
Thanks John, QA results as attachments please :)

If you'd like bonus points, add upstream issue/pr references to the patch header as a comment
Comment 9 John W. O'Brien 2015-07-05 00:54:21 UTC
Created attachment 158356 [details]
poudriere testport log for py27-scikit-sparse-0.2_1
Comment 10 John W. O'Brien 2015-07-05 00:55:12 UTC
Created attachment 158357 [details]
poudriere testport log for py34-scikit-sparse-0.2_1
Comment 11 John W. O'Brien 2015-07-05 01:02:36 UTC
Created attachment 158358 [details]
science/py-scikit-sparse: Use print function in test_cholmod

It's as if you were grooming me for a commit bit or something. :-P

How many bonus points do I get?
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-05 01:18:43 UTC
s/points/gold star! :)
Comment 13 Yuri Victorovich freebsd_committer 2015-07-22 09:48:39 UTC
I suggest we should close this bug because the next release will bring in the fix. USES=python:2 can be set in the meantime.

If this really matters for the submitter, he can put this patch into his local ports tree.
Comment 14 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-22 09:56:21 UTC
If the current quarterly branch is affected, than the changes needed to fix it should be committed, and merged there too (if USES:python:2.7 does indeed resolve the issue)
Comment 15 commit-hook freebsd_committer 2015-07-26 15:12:11 UTC
A commit references this bug:

Author: riggs
Date: Sun Jul 26 15:11:41 UTC 2015
New revision: 392924
URL: https://svnweb.freebsd.org/changeset/ports/392924

Log:
  - Fix build when using python 3.x
  - Update WWW in pkg-descr, points to new project location now

  PR:		201346
  Submitted by:	john@saltant.com
  Approved by:	yuri@rawbw.com (maintainer)
  MFH:		2015Q3

Changes:
  head/science/py-scikit-sparse/Makefile
  head/science/py-scikit-sparse/files/
  head/science/py-scikit-sparse/files/patch-scikits_sparse_test__cholmod.py
  head/science/py-scikit-sparse/pkg-descr
Comment 16 commit-hook freebsd_committer 2015-07-26 15:16:14 UTC
A commit references this bug:

Author: riggs
Date: Sun Jul 26 15:15:58 UTC 2015
New revision: 392925
URL: https://svnweb.freebsd.org/changeset/ports/392925

Log:
  MFH: r392924

  - Fix build when using python 3.x
  - Update WWW in pkg-descr, points to new project location now

  PR:		201346
  Submitted by:	john@saltant.com
  Approved by:	ports-secteam (build fix blanket), yuri@rawbw.com (maintainer)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/science/py-scikit-sparse/Makefile
  branches/2015Q3/science/py-scikit-sparse/files/
  branches/2015Q3/science/py-scikit-sparse/pkg-descr
Comment 17 Thomas Zander freebsd_committer 2015-07-26 15:18:51 UTC
Committed this fix for now, until a new version is released upstream.