Bug 201377 - [exp-run] Update clang in base to 3.7.0-r241361 (snapshot)
Summary: [exp-run] Update clang in base to 3.7.0-r241361 (snapshot)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Dimitry Andric
URL:
Keywords:
Depends on: 202493 202495 202498 202499 202530 202534 202535 202581 202594 202596 202660 202662 202762 202763 202958 202959 203154 203160
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-06 17:49 UTC by Dimitry Andric
Modified: 2016-03-20 14:16 UTC (History)
3 users (show)

See Also:
dim: exp-run?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2015-07-06 17:49:50 UTC
Quite soon, llvm, clang and lldb 3.7.0 will be branched off for release.  At the moment, we have imported 3.7.0-r241361 into the projects/clang-trunk branch.

I would like to ask for an exp-run using this branch, to find regressions before the actual snapshot gets merged into head.  For testing, please use the projects/clang-trunk branch here:

svn://svn.freebsd.org/base/projects/clang-trunk

This branch has been updated to head r285152.
Comment 1 Antoine Brodin freebsd_committer 2015-07-24 15:29:01 UTC
Take for exp run
Comment 2 Antoine Brodin freebsd_committer 2015-07-27 20:34:11 UTC
Could you merge ^/head to at least https://svnweb.freebsd.org/base?view=revision&revision=285857 ?
Comment 3 Dimitry Andric freebsd_committer 2015-07-27 22:22:17 UTC
Thanks for the reminder; I merged ^/head r285793 through r285923 into the projects/clang-trunk branch.
Comment 4 Antoine Brodin freebsd_committer 2015-08-01 09:52:36 UTC
Exp-run results on i386:

http://package18.nyi.freebsd.org/build.html?mastername=headi386PR201377-default&build=2015-07-31_12h04m22s

There seems to be a problem (5684 ports skipped)

New failures:

+ {"origin"=>"audio/lame", "pkgname"=>"lame-3.99.5_2", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"audio/speexdsp", "pkgname"=>"speexdsp-1.2.r3_1", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"devel/k8048", "pkgname"=>"k8048-3.05", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/libpru", "pkgname"=>"libpru-0.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/spark", "pkgname"=>"apache-spark-1.2.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"games/doomlegacy", "pkgname"=>"doomlegacy-1.45.2,1", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"graphics/argyllcms", "pkgname"=>"argyllcms-1.6.3", "phase"=>"build", "errortype"=>"bad_C++_code"}
+ {"origin"=>"graphics/png", "pkgname"=>"png-1.6.17_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/go", "pkgname"=>"go-1.4.2,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"math/py-numpy", "pkgname"=>"py27-numpy-1.9.2,1", "phase"=>"build", "errortype"=>"missing_header"}
+ {"origin"=>"net-mgmt/tcptrack", "pkgname"=>"tcptrack-1.4.2_2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"science/InsightToolkit", "pkgname"=>"InsightToolkit-4.7.2", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"security/obfsclient", "pkgname"=>"obfsclient-0.0.2_1", "phase"=>"build", "errortype"=>"clang_werror"}

Failure logs:

http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/lame-3.99.5_2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/speexdsp-1.2.r3_1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/k8048-3.05.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/libpru-0.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/apache-spark-1.2.1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/doomlegacy-1.45.2,1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/nlarn-0.7.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/argyllcms-1.6.3.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/png-1.6.17_1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/go-1.4.2,1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/phc-0.1.7.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/v8-3.18.5_1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/v8-devel-3.27.7_3.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/py27-numpy-1.9.2,1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/tcptrack-1.4.2_2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/InsightToolkit-4.7.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-07-31_12h04m22s/logs/errors/obfsclient-0.0.2_1.log
Comment 5 Antoine Brodin freebsd_committer 2015-08-01 09:57:08 UTC
Exp-run results on amd64:

http://package18.nyi.freebsd.org/build.html?mastername=headamd64PR201377-default&build=2015-07-31_13h29m42s

New failures:

+ {"origin"=>"databases/rocksdb", "pkgname"=>"rocksdb-3.11.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/k8048", "pkgname"=>"k8048-3.05", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/libpru", "pkgname"=>"libpru-0.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"games/doomlegacy", "pkgname"=>"doomlegacy-1.45.2,1", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"graphics/argyllcms", "pkgname"=>"argyllcms-1.6.3", "phase"=>"build", "errortype"=>"bad_C++_code"}
+ {"origin"=>"graphics/darktable", "pkgname"=>"darktable-1.6.7", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/rust", "pkgname"=>"rust-1.1.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/rust-nightly", "pkgname"=>"rust-nightly-1.3.0.20150703", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net-mgmt/tcptrack", "pkgname"=>"tcptrack-1.4.2_2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"security/obfsclient", "pkgname"=>"obfsclient-0.0.2_1", "phase"=>"build", "errortype"=>"clang_werror"}

Failure logs:

http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/rocksdb-3.11.2.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/k8048-3.05.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/libpru-0.2.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/doomlegacy-1.45.2,1.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/nlarn-0.7.2.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/argyllcms-1.6.3.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/darktable-1.6.7.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/phc-0.1.7.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/rust-1.1.0.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/rust-nightly-1.3.0.20150703.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/v8-3.18.5_1.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/v8-devel-3.27.7_3.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/tcptrack-1.4.2_2.log 
http://package18.nyi.freebsd.org/data/headamd64PR201377-default/2015-07-31_13h29m42s/logs/errors/obfsclient-0.0.2_1.log
Comment 6 Dimitry Andric freebsd_committer 2015-08-01 20:53:55 UTC
Most of the fallout is caused by graphics/png, and that in turn is caused by some floating point exception that I do not understand yet.

It seems that calling pow(0.0, 2.2) causes such an FPE, but only if libm is compiled with clang trunk, specifically the file lib/msun/src/e_pow.c.

Since that code is rather hard to fully grasp, I'm soliciting for some help, and meanwhile, I will try to figure out where clang changed this behavior.
Comment 7 Antoine Brodin freebsd_committer 2015-08-15 19:25:04 UTC
Exp-run done.
Comment 8 Dimitry Andric freebsd_committer 2015-08-19 07:00:39 UTC
Antoine, can you please do another run, after r286896?  I've fixed both the png failure, and the problems with the intrinsics headers, so lame, speexdsp etc should compile again.

I will start having a look at the various other reports now, too.
Comment 9 Antoine Brodin freebsd_committer 2015-08-19 15:01:18 UTC
I have this error:

--- lib/libz__L ---
/poudriere/jails/headamd64PR201377/usr/src/lib/libz/inflate.c:1507:61: error: shifting a negative signed value is undefined [-W
error,-Wshift-negative-value]
    if (strm == Z_NULL || strm->state == Z_NULL) return -1L << 16;
                                                        ~~~ ^
Comment 10 Dimitry Andric freebsd_committer 2015-08-19 17:13:50 UTC
(In reply to Antoine Brodin from comment #9)
> /poudriere/jails/headamd64PR201377/usr/src/lib/libz/inflate.c:1507:61:
> error: shifting a negative signed value is undefined

Sorry about that, this was a local change which I had submitted to Xin Li for head, but I didn't commit it into the projects/clang-trunk branch yet.

I have now committed it in r286927, please try it again. :)
Comment 11 Dimitry Andric freebsd_committer 2015-08-19 19:38:46 UTC
Submitted bug 202493 for devel/k8048.
Comment 12 Dimitry Andric freebsd_committer 2015-08-19 20:04:30 UTC
Submitted bug 202495 for devel/libpru.
Comment 13 Dimitry Andric freebsd_committer 2015-08-19 20:11:47 UTC
The devel/spark error does not seem to have anything to do with clang, since it is a Maven-built Java program.  The Maven log ends with this error:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-dependency-plugin:2.9:copy-dependencies (copy-dependencies) on project spark-core_2.10: Error copying artifact from /wrkdirs/usr/ports/devel/spark/work/m2/com/google/guava/guava/14.0.1/guava-14.0.1.jar to /wrkdirs/usr/ports/devel/spark/work/spark-1.2.1/core/target/jars/guava-14.0.1.jar: Map failed -> [Help 1]

Maybe "Map failed" is an obscure way of telling that Maven was out of memory?
Comment 14 Dimitry Andric freebsd_committer 2015-08-19 21:31:16 UTC
The math/numpy port was fixed by r286896.  I expected science/InsightToolkit to be fixed too, but that dies with a strange error, which I'm not sure of if it has anything to do with clang; it looks more like a bad CMakeLists.txt:

Scanning dependencies of target ITKData
[  0%] Building C object Modules/ThirdParty/KWSys/src/KWSys/CMakeFiles/itksys.dir/ProcessUNIX.c.o
[  0%] Building CXX object Modules/ThirdParty/VNL/src/vxl/vcl/CMakeFiles/itkvcl.dir/vcl_deprecated.cxx.o
[  0%] Building CXX object Modules/ThirdParty/DoubleConversion/src/double-conversion/CMakeFiles/itkdouble-conversion.dir/bignum-dtoa.cc.o
[  0%] Building C object Modules/ThirdParty/KWSys/src/KWSys/CMakeFiles/itksys.dir/Base64.c.o
[  0%] Building CXX object Modules/ThirdParty/DoubleConversion/src/double-conversion/CMakeFiles/itkdouble-conversion.dir/cached-powers.cc.o
[  0%] Building C object Modules/ThirdParty/KWSys/src/KWSys/CMakeFiles/itksys.dir/EncodingC.c.o
make[4]: make[4]: don't know how to make ExternalData/Testing/Data/Input/MetaIO/Small\. Stop

make[4]: stopped in /usr/work/share/dim/ports/science/InsightToolkit/work/.build
Comment 15 Dimitry Andric freebsd_committer 2015-08-19 21:47:31 UTC
Submitted bug 202498 for games/doomlegacy.
Comment 16 Dimitry Andric freebsd_committer 2015-08-19 22:01:03 UTC
Submitted bug 202499 for games/nlarn.
Comment 17 Dimitry Andric freebsd_committer 2015-08-20 18:33:42 UTC
I cannot reproduce the build failure for graphics/argyllcms.  It builds just fine for me...
Comment 18 Dimitry Andric freebsd_committer 2015-08-20 20:12:20 UTC
The lang/ghc port needs a fix to have -gnu89-inline removed from CXXFLAGS, but it is tricky to do without nasty hacks.

The root cause is really that sys.mk sets CXXFLAGS directly from CFLAGS, so the ports framework does not have a way to set a "C-only-but-not-C++" flag.

Baptiste thinks that should be fixed in sys.mk instead, and I agree, but this is not a trivial task.  (The difficulty comes from dozens of Makefiles in the base system, which are now assuming CFLAGS are automatically added to CXXFLAGS.)
Comment 19 Dimitry Andric freebsd_committer 2015-08-20 21:05:19 UTC
Submitted bug 202530 for lang/v8.
Comment 20 Dimitry Andric freebsd_committer 2015-08-20 21:31:52 UTC
Submitted bug 202534 for lang/v8-devel.
Comment 21 Dimitry Andric freebsd_committer 2015-08-20 21:40:33 UTC
Submitted bug 202535 for net-mgmt/tcptrack.
Comment 22 Antoine Brodin freebsd_committer 2015-08-21 08:19:54 UTC
Exp-run results on i386 on ports/head@394538 :

http://package18.nyi.freebsd.org/build.html?mastername=headi386PR201377-default&build=2015-08-20_15h42m20s

New failures:

+ {"origin"=>"chinese/gimp-help-zh_CN", "pkgname"=>"zh_CN-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"devel/k8048", "pkgname"=>"k8048-3.05", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/libpru", "pkgname"=>"libpru-0.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/rubygem-thrift", "pkgname"=>"rubygem-thrift-0.9.1,1", "phase"=>"stage", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/spark", "pkgname"=>"apache-spark-1.2.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"editors/openoffice-4", "pkgname"=>"apache-openoffice-4.1.1_11", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"editors/openoffice-devel", "pkgname"=>"apache-openoffice-devel-4.2.1694132,3", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"games/doomlegacy", "pkgname"=>"doomlegacy-1.45.2,1", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"games/stepmania-devel", "pkgname"=>"stepmania-devel-5.0.a3_4,1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"graphics/darktable", "pkgname"=>"darktable-1.6.7", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"lang/go", "pkgname"=>"go-1.4.2,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/rubinius", "pkgname"=>"rubinius-2.5.2", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"misc/gimp-help-ca", "pkgname"=>"ca-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"misc/gimp-help-da", "pkgname"=>"da-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"misc/gimp-help-nn", "pkgname"=>"nn-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"misc/gimp-help-sl", "pkgname"=>"sl-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"misc/gimp-help-sv", "pkgname"=>"sv-gimp-help-html-2.8.1_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"net-mgmt/tcptrack", "pkgname"=>"tcptrack-1.4.2_2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net/pimd", "pkgname"=>"pimd-2.2.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"print/fontforge", "pkgname"=>"fontforge-20150612_2", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"security/obfsclient", "pkgname"=>"obfsclient-0.0.2_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"www/varnish4", "pkgname"=>"varnish4-4.0.3_7", "phase"=>"build", "errortype"=>"clang_werror"}

Failure logs:

http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/zh_CN-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/k8048-3.05.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/libpru-0.2.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/rubygem-thrift-0.9.1,1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/apache-spark-1.2.1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/apache-openoffice-4.1.1_11.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/apache-openoffice-devel-4.2.1694132,3.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/doomlegacy-1.45.2,1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/nlarn-0.7.2.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/stepmania-devel-5.0.a3_4,1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/darktable-1.6.7.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/go-1.4.2,1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/phc-0.1.7.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/rubinius-2.5.2.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/v8-3.18.5_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/v8-devel-3.27.7_3.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/ca-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/da-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/nn-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/sl-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/sv-gimp-help-html-2.8.1_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/tcptrack-1.4.2_2.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/pimd-2.2.0.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/fontforge-20150612_2.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/obfsclient-0.0.2_1.log
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-08-20_15h42m20s/logs/errors/varnish4-4.0.3_7.log
Comment 23 Antoine Brodin freebsd_committer 2015-08-22 04:01:32 UTC
Exp-run results on amd64 on ports/head@394820:

http://package22.nyi.freebsd.org/build.html?mastername=headamd64PR201377-default&build=2015-08-20_16h45m13s

New failures:

+ {"origin"=>"databases/rocksdb", "pkgname"=>"rocksdb-3.11.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/k8048", "pkgname"=>"k8048-3.05", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/rubygem-thrift", "pkgname"=>"rubygem-thrift-0.9.1,1", "phase"=>"stage", "errortype"=>"clang_werror"}
+ {"origin"=>"games/doomlegacy", "pkgname"=>"doomlegacy-1.45.2,1", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"graphics/darktable", "pkgname"=>"darktable-1.6.7", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"graphics/jpeg-turbo", "pkgname"=>"jpeg-turbo-1.4.0", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/libjpeg-turbo", "pkgname"=>"libjpeg-turbo-1.4.0", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/go", "pkgname"=>"go-1.4.2,1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/rubinius", "pkgname"=>"rubinius-2.5.2", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"lang/rust", "pkgname"=>"rust-1.1.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/rust-nightly", "pkgname"=>"rust-nightly-1.3.0.20150703", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net-mgmt/tcptrack", "pkgname"=>"tcptrack-1.4.2_2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net/pimd", "pkgname"=>"pimd-2.2.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"security/obfsclient", "pkgname"=>"obfsclient-0.0.2_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"www/varnish4", "pkgname"=>"varnish4-4.0.3_7", "phase"=>"build", "errortype"=>"clang_werror"}

Error logs:

http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/rocksdb-3.11.2.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/k8048-3.05.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/rubygem-thrift-0.9.1,1.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/doomlegacy-1.45.2,1.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/nlarn-0.7.2.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/darktable-1.6.7.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/jpeg-turbo-1.4.0.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/libjpeg-turbo-1.4.0.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/go-1.4.2,1.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/phc-0.1.7.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/rubinius-2.5.2.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/rust-1.1.0.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/rust-nightly-1.3.0.20150703.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/v8-3.18.5_1.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/v8-devel-3.27.7_3.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/tcptrack-1.4.2_2.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/pimd-2.2.0.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/obfsclient-0.0.2_1.log 
http://package22.nyi.freebsd.org/data/headamd64PR201377-default/2015-08-20_16h45m13s/logs/errors/varnish4-4.0.3_7.log 

There is a regression compared to previous run with jpeg-turbo/libjeg-turbo,  tests were succeeding on august 1st
Comment 24 Dimitry Andric freebsd_committer 2015-08-22 22:53:48 UTC
Submitted bug 202581 for security/obfsclient.
Comment 25 Dimitry Andric freebsd_committer 2015-08-23 11:10:51 UTC
The graphics/jpeg-turbo problem seems a lot like this:

http://sourceforge.net/p/libjpeg-turbo/bugs/85/
Comment 26 Dimitry Andric freebsd_committer 2015-08-23 14:00:17 UTC
Submitted bug 202594 for graphics/darktable.
Comment 27 Dimitry Andric freebsd_committer 2015-08-23 16:41:31 UTC
Submitted bug 202596 for lang/rust and lang/rust-nightly.  (The -Werror warnings are actually caused by headers from devel/llvm36.)
Comment 28 Dimitry Andric freebsd_committer 2015-08-25 18:48:06 UTC
Submitted bug 202660 for lang/ruby21 (which fixes the build error for devel/rubygem-thrift, and possibly other ruby ports).
Comment 29 Dimitry Andric freebsd_committer 2015-08-25 20:14:51 UTC
Submitted bug 202662 for lang/go.
Comment 30 Antoine Brodin freebsd_committer 2015-08-28 19:56:48 UTC
For graphics/jpeg-turbo on amd64, replacing jcdctmgr.o and .libs/jcdctmgr.o with ones compiled with clang 3.6.1 makes the tests succeed.

Disassembly of jcdctmgr.c:quantize() doesn't look the same with clang 3.6.1 and 3.7-snapshot,  with 3.7-snapshot it looks more complex and uses xmm registers.
Comment 31 Dimitry Andric freebsd_committer 2015-08-28 20:14:52 UTC
(In reply to Antoine Brodin from comment #30)
> For graphics/jpeg-turbo on amd64, replacing jcdctmgr.o and .libs/jcdctmgr.o
> with ones compiled with clang 3.6.1 makes the tests succeed.
> 
> Disassembly of jcdctmgr.c:quantize() doesn't look the same with clang 3.6.1
> and 3.7-snapshot,  with 3.7-snapshot it looks more complex and uses xmm
> registers.

Yes, with help from some people on the llvm channel, I have found out that the jpeg-turbo version of jcdctmgr.c does some undefined behavior in its quantize() function.  (It tries to right-shift something by 65551, which is obviously wrong.)

I am working on a bug report for upstream, and I hope they can provide a fix for this, as I do not fully understand all that quantization code. :)
Comment 32 Dimitry Andric freebsd_committer 2015-08-28 20:18:15 UTC
(In reply to Antoine Brodin from comment #30)
> Disassembly of jcdctmgr.c:quantize() doesn't look the same with clang 3.6.1
> and 3.7-snapshot,  with 3.7-snapshot it looks more complex and uses xmm
> registers.

Btw, the reason this function now gets translated into a lot of SIMD instructions is that an upstream commit[1] has enabled vectorization of certain right-shift operations.

A quick workaround could be to disable vectorization for this particular file, or even just the quantize() function, but on the other hand, jpeg-turbo is designed to take advantage of SIMD. :)

[1] http://llvm.org/viewvc/llvm-project?view=revision&revision=241989
Comment 33 Dimitry Andric freebsd_committer 2015-08-29 23:50:32 UTC
Submitted bug 202762 for graphics/jpeg-turbo.
Comment 34 Dimitry Andric freebsd_committer 2015-08-30 00:28:33 UTC
Submitted bug 202763 for graphics/mozjpeg.  (This has the same bug as graphics/jpeg-turbo, but it was not failing, because the port does not run any tests.)
Comment 35 Dimitry Andric freebsd_committer 2015-09-07 21:06:40 UTC
I have now updated clang to 3.7.0 release in the projects/clang370-import branch.  This seems to have fixed a number of things, as I cannot reproduce e.g. the various gimp-help-html segmentation faults any more.

Could you please do the exp-run again, but now from:

svn://svn.freebsd.org/base/projects/clang370-import?

Or if you rather want a new PR, please let me know.  Meanwhile, I will continue to submit fixes in this PR, those could be linked to a new PR later, if they still apply.
Comment 36 Dimitry Andric freebsd_committer 2015-09-07 21:30:42 UTC
Submitted bug 202958 for www/varnish4.
Comment 37 Dimitry Andric freebsd_committer 2015-09-07 21:32:55 UTC
The print/fontforge failure was reported upstream quite some time ago, but no fix yet: https://llvm.org/bugs/show_bug.cgi?id=21903
Comment 38 Dimitry Andric freebsd_committer 2015-09-07 21:40:38 UTC
Submitted bug 202959 for net/pimd.
Comment 39 Antoine Brodin freebsd_committer 2015-09-16 08:49:49 UTC
Exp-run results on amd64:

http://package18.nyi.freebsd.org/build.html?mastername=headamd64PR201377-default&build=2015-09-16_07h08m17s

11 new failures:

+ {"origin"=>"databases/rocksdb", "pkgname"=>"rocksdb-3.13.1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/codeblocks", "pkgname"=>"codeblocks-13.12_4", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"devel/rubygem-thrift", "pkgname"=>"rubygem-thrift-0.9.1,1", "phase"=>"stage", "errortype"=>"clang_werror"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/go14", "pkgname"=>"go14-1.4.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/rubinius", "pkgname"=>"rubinius-2.5.2", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net/pimd", "pkgname"=>"pimd-2.2.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"www/varnish4", "pkgname"=>"varnish4-4.0.3_7", "phase"=>"build", "errortype"=>"clang_werror"}
Comment 40 Dimitry Andric freebsd_committer 2015-09-16 12:48:34 UTC
Submitted bug 203154 for databases/rocksdb.
Comment 41 Dimitry Andric freebsd_committer 2015-09-16 17:39:37 UTC
Submitted bug 203156 for lang/rubinius.
Comment 42 Dimitry Andric freebsd_committer 2015-09-16 20:02:00 UTC
Submitted bug 203160 for devel/codeblocks.
Comment 43 Dimitry Andric freebsd_committer 2015-09-16 22:30:59 UTC
(In reply to Antoine Brodin from comment #39)
> Exp-run results on amd64:
> 
> http://package18.nyi.freebsd.org/build.html?mastername=headamd64PR201377-
> default&build=2015-09-16_07h08m17s
> 
> 11 new failures:

I think the other bugs I submitted now cover all these failures.  I expect those to get committed soon-ish (with maybe a maintainer timeout or two :).

Does it look safe enough now to merge the clang370-import branch back to head?
Comment 44 Antoine Brodin freebsd_committer 2015-09-17 17:05:58 UTC
Exp-run results on i386:
http://package18.nyi.freebsd.org/build.html?mastername=headi386PR201377-default&build=2015-09-17_14h43m50s

New failures:
+ {"origin"=>"devel/codeblocks", "pkgname"=>"codeblocks-13.12_4", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"devel/rubygem-thrift", "pkgname"=>"rubygem-thrift-0.9.1,1", "phase"=>"stage", "errortype"=>"clang_werror"}
+ {"origin"=>"devel/spark", "pkgname"=>"apache-spark-1.2.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"games/nlarn", "pkgname"=>"nlarn-0.7.2", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"games/stepmania-devel", "pkgname"=>"stepmania-devel-5.0.a3_4,1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"lang/go14", "pkgname"=>"go14-1.4.2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"lang/phc", "pkgname"=>"phc-0.1.7", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"lang/rubinius", "pkgname"=>"rubinius-2.5.2", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"lang/v8", "pkgname"=>"v8-3.18.5_1", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"lang/v8-devel", "pkgname"=>"v8-devel-3.27.7_3", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"net/pimd", "pkgname"=>"pimd-2.2.0", "phase"=>"build", "errortype"=>"clang_werror"}
+ {"origin"=>"print/fontforge", "pkgname"=>"fontforge-20150824", "phase"=>"build", "errortype"=>"clang-bug"}
+ {"origin"=>"www/varnish4", "pkgname"=>"varnish4-4.0.3_7", "phase"=>"build", "errortype"=>"clang_werror"}

Failure logs:
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/codeblocks-13.12_4.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/rubygem-thrift-0.9.1,1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/apache-spark-1.2.1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/nlarn-0.7.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/stepmania-devel-5.0.a3_4,1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/go14-1.4.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/phc-0.1.7.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/rubinius-2.5.2.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/v8-3.18.5_1.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/v8-devel-3.27.7_3.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/pimd-2.2.0.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/fontforge-20150824.log 
http://package18.nyi.freebsd.org/data/headi386PR201377-default/2015-09-17_14h43m50s/logs/errors/varnish4-4.0.3_7.log
Comment 45 Antoine Brodin freebsd_committer 2015-10-04 15:00:22 UTC
(In reply to Dimitry Andric from comment #43)
Yes it should be safe  (I assume you did a make universe?)
Comment 46 Dimitry Andric freebsd_committer 2016-03-20 14:16:36 UTC
Closing since 3.7.0 was merged to head a long time ago.