Bug 201379 - audio/aqualung: Missing liblame dependency
Summary: audio/aqualung: Missing liblame dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Alexey Dokuchaev
URL:
Keywords: easy, needs-qa
Depends on:
Blocks:
 
Reported: 2015-07-06 19:35 UTC by leventelist
Modified: 2016-03-03 05:16 UTC (History)
3 users (show)

See Also:


Attachments
svn diff for audio/aqualung (521 bytes, patch)
2015-09-10 17:12 UTC, Chris Hutchinson
no flags Details | Diff
svn diff to update audio/aqualung (patch) (1.11 KB, patch)
2016-01-27 19:49 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description leventelist 2015-07-06 19:35:42 UTC
Aqualung requires liblame to be installed. However, it is not installed when installing aqualung with pkg method. Installing lame solves the problem.
Comment 1 Bartek Rutkowski freebsd_committer 2015-08-05 15:14:04 UTC
This port has a 'libmp3lame.so:${PORTSDIR}/audio/lame' in LIB_DEPENDS, are you sure this issue is not something with your particular host? Can you reproduce it on fresh installation of 10.1 or 9.3?
Comment 2 leventelist 2015-08-05 21:04:06 UTC
Well... back than was a fresh install. I might not indicated, and I don't know if it counts, but I installed it from binary package, with pkg.

Lev
Comment 3 vvim 2015-09-10 00:07:29 UTC
I can confirm this bug on a fresh 10.2 install. 

$ aqualung
Shared object "libmp3lame.so.0" not found, required by "aqualung"

Building the port (usr/ports/audio/lame) allows aqualung to run.

Port should get fixed, but building lame seems to require gmake-4.1_2 
:-P
Comment 4 Chris Hutchinson 2015-09-10 17:12:50 UTC
Created attachment 160900 [details]
svn diff for audio/aqualung

Examining the source trail; it appears that the pkg
cluster didn't regenerate the [aqualung] pkg after the many
changes introduced in r374303. This patch accomplishes the following:

adds PORTREVISION
takes MAINTAINER

That's it!

Thanks.

P.S. I'm currently testing version 1.0 for up(date/grade) | inclusion.

--Chris
Comment 5 vvim 2015-09-11 21:55:46 UTC
(In reply to Chris Hutchinson from comment #4)
Thank you :-)
Comment 6 Chris Hutchinson 2015-09-12 01:05:41 UTC
(In reply to vvim from comment #5)
> (In reply to Chris Hutchinson from comment #4)
> Thank you :-)

You're welcome. :)
But someone will need to commit this. So that the pkg
cluster will recognize that it will need to re-generate
the packages.Picking up all the changes made both now,
and especially earlier.

Then I can open a new pr(1) for version 1.0. :)

--Chris
Comment 7 Alexey Dokuchaev freebsd_committer 2015-10-26 10:21:07 UTC
Kubilay, "in progress" does not necessarily mean that I'm working on it.  It means that some progress is made on the PR, so it can be filtered from purely new ones.

If I really take it, I'd make sure that I change its status, provide a comment, and reassign.

That said, no action on this PR is needed, I'll try to handle it since you've assign it to me.
Comment 8 Chris Hutchinson 2016-01-27 19:49:20 UTC
Created attachment 166201 [details]
svn diff to update audio/aqualung (patch)

GRR...
I tested, and modified the source to update aqualung to 1.0,
only to discover that it'd had already been done by a couple
of the committers. sigh...

OK. So the svn diff attached to this archive corrects the
pkg-descr, keeping it in sync with the authors *new* web
site. It also updates WWW, to reflect that.

In short...

CHANGES

pkg-descr
WWW
MAINTAINER

That's it!

Can we *please* push this now? It's been ~6 months.

Thanks!

--Chris
Comment 9 Chris Hutchinson 2016-01-27 19:51:02 UTC
Comment on attachment 166201 [details]
svn diff to update audio/aqualung (patch)

It's maintained by ports@ -- implicit approval :)
Comment 10 commit-hook freebsd_committer 2016-03-03 02:44:49 UTC
A commit references this bug:

Author: danfe
Date: Thu Mar  3 02:44:31 UTC 2016
New revision: 409999
URL: https://svnweb.freebsd.org/changeset/ports/409999

Log:
  - Provide better port description text
  - Point WWW line to a working homepage
  - Transfer maintainership to submitter
  - Convert to USES=localbase while here

  PR:	201379

Changes:
  head/audio/aqualung/Makefile
  head/audio/aqualung/pkg-descr
Comment 11 Alexey Dokuchaev freebsd_committer 2016-03-03 02:46:04 UTC
Committed alongside with other minor changes as ports r409999, thank you.
Comment 12 Chris Hutchinson 2016-03-03 05:16:49 UTC
(In reply to Alexey Dokuchaev from comment #11)
> Committed alongside with other minor changes as ports r409999, thank you.

Thank *you*, Alexey! :-)

--Chris