Bug 201431 - sysutils/py-tmuxp: update to 0.9.0, fix tmux 2.0 compatibility
Summary: sysutils/py-tmuxp: update to 0.9.0, fix tmux 2.0 compatibility
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ruslan Makhmatkhanov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-09 01:43 UTC by Tony Narlock
Modified: 2015-07-14 18:38 UTC (History)
1 user (show)

See Also:


Attachments
patch to upgrade from 0.1.12 -> 0.9.0 (1.13 KB, patch)
2015-07-09 01:43 UTC, Tony Narlock
tony: maintainer-approval+
Details | Diff
poudriere output (27.68 KB, text/x-log)
2015-07-09 01:45 UTC, Tony Narlock
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Narlock 2015-07-09 01:43:54 UTC
Created attachment 158550 [details]
patch to upgrade from 0.1.12 -> 0.9.0

0.9.0 has:

- support for tmux 2.0 (which is the current version of misc/tmux in ports)
- add dependency of devel/py-colorama
- miscellaneous bugfixes, see changelog at http://tmuxp.readthedocs.org/en/latest/history.html
Comment 1 Tony Narlock 2015-07-09 01:45:06 UTC
Created attachment 158551 [details]
poudriere output
Comment 2 Tony Narlock 2015-07-09 01:48:34 UTC
(In reply to Tony Narlock from comment #0)
> support for tmux 2.0 (which is the current version of misc/tmux in ports)

Correction to above, that is "sysutils/tmux", not "misc/tmux".
Comment 3 Tony Narlock 2015-07-09 01:50:25 UTC
This is my first time submitting an update for of my ports (yay!). Please let me know if I've overlooked anything.

Included above: patch and poudriere output.
Comment 4 Tony Narlock 2015-07-10 19:03:49 UTC
$ portlint -AC
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 1 warning found.
Comment 5 Ruslan Makhmatkhanov freebsd_committer 2015-07-14 18:17:24 UTC
Take
Comment 6 commit-hook freebsd_committer 2015-07-14 18:20:51 UTC
A commit references this bug:

Author: rm
Date: Tue Jul 14 18:20:36 UTC 2015
New revision: 392042
URL: https://svnweb.freebsd.org/changeset/ports/392042

Log:
  sysutils/py-tmuxp: update to 0.9.0

  This release fixing compatibility with tmux 2.0.

  While here, limit python version to 2.x:

  """
  ===>  Configuring for py34-tmuxp-0.9.0
  Traceback (most recent call last):
    File "<string>", line 1, in <module>
    File "setup.py", line 25, in <module>
      readme = open('README.rst').read()
    File "/usr/local/lib/python3.4/encodings/ascii.py", line 26, in decode
      return codecs.ascii_decode(input, self.errors)[0]
  UnicodeDecodeError: 'ascii' codec can't decode byte 0xe4 in position 635: ordinal not in range(128)
  """

  PR:		201431
  Submitted by:	Tony Narlock <tony@git-pull.com> (maintainer)

Changes:
  head/sysutils/py-tmuxp/Makefile
  head/sysutils/py-tmuxp/distinfo
Comment 7 Ruslan Makhmatkhanov freebsd_committer 2015-07-14 18:21:07 UTC
Committed, thank you!
Comment 8 Ruslan Makhmatkhanov freebsd_committer 2015-07-14 18:28:25 UTC
I also added NO_ARCH, because package doesn't contain any architecture-dependent files and limited python version to 2.x, because it was unable to build it with 3.x (see traceback in commit message). By the way, LICENSE looks like 3-clause BSD, while in port we have BSD3CLAUSE. Should I change it to BSD3CLAUSE in Makefile, or you can update the license in distribution (you are tmuxp author, AFAIK)?
Comment 9 Tony Narlock 2015-07-14 18:31:43 UTC
(In reply to Ruslan Makhmatkhanov from comment #8)

Thank you Ruslan!

Correct I am author.

Thank you for that. Can you update it to 3 clause, or should I make a bugzilla ticket + patch?
Comment 10 commit-hook freebsd_committer 2015-07-14 18:37:57 UTC
A commit references this bug:

Author: rm
Date: Tue Jul 14 18:37:06 UTC 2015
New revision: 392044
URL: https://svnweb.freebsd.org/changeset/ports/392044

Log:
  sysutils/py-tmuxp: correct license

  It's actually BSD3CLAUSE, not BSD2CLAUSE. It was confirmed with maintainer, who
  is the upstream developer in PR 201431

  PR:		201431

Changes:
  head/sysutils/py-tmuxp/Makefile
Comment 11 Ruslan Makhmatkhanov freebsd_committer 2015-07-14 18:38:24 UTC
Just done. Thank you for quick response!