Bug 201464 - [MAINTAINER] deskutils/py-khal: fix dependencies, add zsh completion
Summary: [MAINTAINER] deskutils/py-khal: fix dependencies, add zsh completion
Status: Closed DUPLICATE of bug 202598
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-07-10 22:52 UTC by Maxim Filimonov
Modified: 2015-08-24 00:40 UTC (History)
4 users (show)

See Also:


Attachments
svn diff (1.80 KB, patch)
2015-07-10 22:53 UTC, Maxim Filimonov
no flags Details | Diff
poudriere log (1.80 KB, patch)
2015-07-10 23:27 UTC, Maxim Filimonov
no flags Details | Diff
svn diff (972 bytes, patch)
2015-07-12 20:18 UTC, Maxim Filimonov
no flags Details | Diff
svn diff (896 bytes, patch)
2015-07-12 20:26 UTC, Maxim Filimonov
che: maintainer-approval+
Details | Diff
Updated poudreire (for new patch) (896 bytes, text/plain)
2015-07-13 10:04 UTC, Tony Narlock
no flags Details
Corrected poudriere (29.22 KB, text/x-log)
2015-07-13 10:19 UTC, Tony Narlock
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Filimonov 2015-07-10 22:52:37 UTC
The mentioned port reportedly depends on databases/py-sqlite3. However, that wasn't stated in setup.py. This patch fixes that. Moreover, this patch adds the zsh completion provided with the package. `portlint -AC` says everything is fine; patch and poudriere log are soon to come.
Comment 1 Maxim Filimonov 2015-07-10 22:53:19 UTC
Created attachment 158592 [details]
svn diff

Added the patch
Comment 2 Maxim Filimonov 2015-07-10 23:27:23 UTC
Created attachment 158593 [details]
poudriere log

And here comes the poudriere log.
Comment 3 Tony Narlock 2015-07-11 12:14:03 UTC
Hey there! Going to give this a shot :)

When I tried to apply the patch (via diff -p1 < svndiffile) it doesn't apply cleanly.

From within the project directory (desktuils/py-khal) @ head:391734:

$ patch -p1 < ~/work/patches/py-khal-201464.txt
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: Makefile
|===================================================================
|--- Makefile	(revision 391725)
|+++ Makefile	(working copy)
--------------------------
Patching file Makefile using Plan A...
Reversed (or previously applied) patch detected!  Assume -R? [y] n
Apply anyway? [n] y
Hunk #1 succeeded at 2 with fuzz 2 (offset 1 line).
Hunk #2 succeeded at 12 (offset -1 lines).
done


Am I applying the patch incorrectly?  Maybe it's just a formatting thing?
Comment 4 Maxim Filimonov 2015-07-11 12:28:24 UTC
You might be using a newer revision of the ports tree than me. Also, the patch has actually applied as far as I can see from the provided output. Moreover, did you try `patch -p0`?
Comment 5 Tony Narlock 2015-07-12 18:38:42 UTC
(In reply to Maxim Filimonov from comment #4)

Here is what I got when I tried it again.

tony at z600 in ~/work/ports/deskutils/py-khal (head:391832) 
$ patch -p0 < ~/work/patches/py-khal-201464.txt
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|Index: Makefile
|===================================================================
|--- Makefile	(revision 391725)
|+++ Makefile	(working copy)
--------------------------
Patching file Makefile using Plan A...
Reversed (or previously applied) patch detected!  Assume -R? [y] 
Hunk #1 succeeded at 2 with fuzz 1 (offset 1 line).
Hunk #2 failed at 15.
1 out of 2 hunks failed--saving rejects to Makefile.rej
done
Comment 6 Maxim Filimonov 2015-07-12 20:18:53 UTC
Created attachment 158662 [details]
svn diff

Fixed the patch
Comment 7 Maxim Filimonov 2015-07-12 20:26:10 UTC
Created attachment 158663 [details]
svn diff

Now fixed the patch: the header was wrong
Comment 8 Tony Narlock 2015-07-13 10:04:15 UTC
Created attachment 158682 [details]
Updated poudreire (for new patch)

Hey! The new patch applies cleanly.  I added the poudriere. :)
Comment 9 Tony Narlock 2015-07-13 10:19:15 UTC
Created attachment 158683 [details]
Corrected poudriere

Correction to the above. Submitted the wrong file.
Comment 10 Maxim Filimonov 2015-07-30 09:54:37 UTC
Comment on attachment 158663 [details]
svn diff

Set maintainer-approval to "+"
Comment 11 Maxim Filimonov 2015-08-24 00:39:47 UTC
This PR is no longer actual, please close it. Duplicated by #202598
Comment 12 Maxim Filimonov 2015-08-24 00:40:42 UTC

*** This bug has been marked as a duplicate of bug 202598 ***