Bug 201597 - graphics/intel-backlight should be marked amd64/i386 only
Summary: graphics/intel-backlight should be marked amd64/i386 only
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
: 201596 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-15 17:31 UTC by Sean Bruno
Modified: 2015-07-16 08:32 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Bruno freebsd_committer 2015-07-15 17:31:50 UTC
There's no need to allow this package on any other arch.  Mind if I mark it that way?
Comment 1 Sean Bruno freebsd_committer 2015-07-15 17:40:36 UTC
Something like this perhaps?


Index: /usr/local/poudriere/ports/default/graphics/intel-backlight/Makefile
===================================================================
--- /usr/local/poudriere/ports/default/graphics/intel-backlight/Makefile        (revision 392172)
+++ /usr/local/poudriere/ports/default/graphics/intel-backlight/Makefile        (working copy)
@@ -19,6 +19,9 @@
 PLIST_FILES=           bin/intel_backlight
 PORTEXAMPLES=          isl_backlight.sh
 
+ONLY_FOR_ARCHS=                amd64 i386
+ONLY_FOR_ARCHS_REASON= This hardware is only found on Intel x86 systems
+
 do-build:
        cd ${WRKSRC} && \
        ${CC} ${CFLAGS} -o intel_backlight -I${PREFIX}/include \
Comment 2 Sean Bruno freebsd_committer 2015-07-15 19:06:06 UTC
*** Bug 201596 has been marked as a duplicate of this bug. ***
Comment 3 commit-hook freebsd_committer 2015-07-16 08:31:46 UTC
A commit references this bug:

Author: grembo
Date: Thu Jul 16 08:31:00 UTC 2015
New revision: 392279
URL: https://svnweb.freebsd.org/changeset/ports/392279

Log:
  Limit archictectures to i386 and amd64, as the hardware is only found there.

  PR:		201597
  Approved by:	mentors (implicit)

Changes:
  head/graphics/intel-backlight/Makefile
Comment 4 Michael Gmelin freebsd_committer 2015-07-16 08:32:59 UTC
Looks good to me, committed, thank for bringing this up and providing a solution.