Bug 201624 - BTX halted using 10.x with root on ZFS supermicro AMD
Summary: BTX halted using 10.x with root on ZFS supermicro AMD
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.0-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-16 16:18 UTC by Mike Selner
Modified: 2015-07-28 20:43 UTC (History)
2 users (show)

See Also:


Attachments
dmesg (7.06 KB, text/plain)
2015-07-22 13:19 UTC, Mariano Aliaga
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Selner 2015-07-16 16:18:21 UTC
Hello, I have a supermicro server with motherboard H8DMR-i2 v2.0 (http://www.supermicro.com/aplus/motherboard/opteron2000/mcp55/h8dmr-i2.cfm)
The bios is at the latest level and I have 2 - 6core AMD CPUs.

I've been running FreeBSD 9.3 with ZFS on root. When upgrading to 10.0 using freebsd-update -r 10.1-RELEASE. The upgrade completes but the system halts on reboot:

Code:
BTX loader 1.00  BTX version is 1.02                      
Consoles: internal video/keyboard                        
BIOS drive A: is disk8                             
BIOS drive C: is disk9                                
int=00000000  err=00000000  efl=00010246  eip=00037df4              
eax=00000001  ebx=00000000  ecx=00000000  edx=00000000            
esi=00000000  edi=00000000  ebp=00092600  esp=00092598             
cs=002b    ds=0033  es=0033    fs=0033  gs=0033  ss=0033                
cs:eip=f7 35 90 f5 03 00 85 f6-74 05 89 3e 89 5e 04 89              
       c2 e9 cc 00 00 00 66 c7-45 ea 00 00 89 d8 c1 e8            
ss:esp=00 00 00 00 00 00 00 00-00 00 00 00 00 00 00 00             
       00 00 00 00 00 00 00 00-00 00 00 00 c8 25 09 00                
BTX halted


After the POST, the "spinning cursor" appears for just a second or two before it halts.


I did a fresh 10.1 install on a new disk (same server) and the same thing happened. I also tried 10.2 beta (FreeBSD-10.2-PRERELEASE-amd64-20150704-r285132-memstick.img) with the same result.  

The system works fine on 9.3/zfs as well as 10.x/ufs. The problem only seems to occur on 10.x. 

I booted using a 10.1 installer memstick and went to a shell. I can import the ZFS "zroot" pool. I verified that the /boot/ directory contents of this pool matched the install memstick /boot/ (except kernel symbols files are not on the installer).

Can someone please advise on next steps to resolve? I have a number of these systems and I would very much like to run 10.x.

It does boot and run OK using FreeBSD-11.0-CURRENT-amd64-20150625-r284814.

Thanks
Mike
Comment 1 Mike Selner 2015-07-19 13:34:36 UTC
Updated: Same problem occurs using 10.2-BETA2
Comment 2 Mike Selner 2015-07-21 00:16:19 UTC
UPDATE
I was able to identify the cause of the problem.
There is a BIOS setting WHEA (Windows Hardware Error Architecture) under the ACPI mode section. If set to ENABLED, the system will BTX HALT as above. If WHEA is set to DISABLED, the system boots and runs fine.

If you set the BIOS settings to "Optimal" it will enable WHEA among other things. I used the the Optimal settings and then set WHEA to DISABLED.  The setting is under BIOS / Advanced / BIOS features / ACPI Mode / General WHEA configuration / (choose Enabled or Disabled).

Since it worked fine on 9.x and 11.x, can it be fixed in the BTX loader for 10.x?
Comment 3 Mariano Aliaga 2015-07-22 13:19:34 UTC
Created attachment 159061 [details]
dmesg

Hi, same problem here (10.x fails, 11 ok), adding information in case it's useful for debugging.

I'm running it on Asus M2N-MX bios 1004. On ACPI options I can choose between v1, v2 and v3. On v3 I get the BTX halted error, but boots ok otherwise. I'm attaching dmesg for 10.1 and ACPI v3.
Comment 4 Mike Selner 2015-07-28 20:43:26 UTC
Just tested on 10.2-RC1. Same failure.
It would be a nasty surprise to anyone with this machine type when upgrading from 9.x to 10.2 and not being able to boot after freebsd-update if they don't know about the bios setting.