Bug 201645 - [MAINTAINER] Fix shuffle playback with audio/ncmpcpp
Summary: [MAINTAINER] Fix shuffle playback with audio/ncmpcpp
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2015-07-17 07:25 UTC by yamagi
Modified: 2015-08-05 06:20 UTC (History)
1 user (show)

See Also:


Attachments
svn patch to fix random playback with audio/ncmpcpp (2.49 KB, patch)
2015-07-17 07:25 UTC, yamagi
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description yamagi 2015-07-17 07:25:45 UTC
Created attachment 158905 [details]
svn patch to fix random playback with audio/ncmpcpp

An user told me that shuffle playback with audio/ncmpcpp has been broken for month. The problem is caused by a missing initialization of the PRNG, the upstream bug report with patch can be found here: http://bugs.musicpd.org/view.php?id=4342

The attached minor update to the port adds the patch to it. It'll be removed as soon as the issue has been fixed upstream. Changes to the port are:
 - Add the patch
 - Bump PORTREVISION
The update has been tested von FreeBSD/amd64 9.4, 9.3 and 10.1.
Comment 1 commit-hook freebsd_committer 2015-08-02 14:04:11 UTC
A commit references this bug:

Author: riggs
Date: Sun Aug  2 14:03:59 UTC 2015
New revision: 393424
URL: https://svnweb.freebsd.org/changeset/ports/393424

Log:
  Fix shuffle playback
  (random number generator is not initialised properly)

  While on it:
  Pet portlint

  PR:		201645
  Submitted by:	yamagi@yamagi.org (maintainer)
  MFH:		2015Q3

Changes:
  head/audio/ncmpcpp/Makefile
  head/audio/ncmpcpp/files/patch-src__status.cpp
  head/audio/ncmpcpp/files/patch-src_mpdpp.cpp
  head/audio/ncmpcpp/files/patch-src_mpdpp.h
Comment 2 commit-hook freebsd_committer 2015-08-05 06:20:45 UTC
A commit references this bug:

Author: riggs
Date: Wed Aug  5 06:20:25 UTC 2015
New revision: 393566
URL: https://svnweb.freebsd.org/changeset/ports/393566

Log:
  MFH: r393424

  Fix shuffle playback
  (random number generator is not initialised properly)

  While on it:
  Pet portlint

  PR:		201645
  Submitted by:	yamagi@yamagi.org (maintainer)
  Approved by:	ports-secteam (delphij)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/audio/ncmpcpp/Makefile
  branches/2015Q3/audio/ncmpcpp/distinfo
  branches/2015Q3/audio/ncmpcpp/files/patch-src__status.cpp
  branches/2015Q3/audio/ncmpcpp/files/patch-src_mpdpp.cpp
  branches/2015Q3/audio/ncmpcpp/files/patch-src_mpdpp.h