Bug 201654 - [PATCH] devel/magit: update to 2.1.0 and etc.
Summary: [PATCH] devel/magit: update to 2.1.0 and etc.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jun Kuriyama
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2015-07-17 16:35 UTC by Yasuhiro KIMURA
Modified: 2015-07-22 02:01 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (kuriyama)


Attachments
Update to 2.1.0 and etc. (3.48 KB, patch)
2015-07-17 16:35 UTC, Yasuhiro KIMURA
no flags Details | Diff
Updated patch. (4.45 KB, patch)
2015-07-18 04:23 UTC, Yasuhiro KIMURA
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2015-07-17 16:35:04 UTC
Created attachment 158914 [details]
Update to 2.1.0 and etc.

* Update to 2.1.0.
* Update LICENSE. Now texinfo is also covered by GPLv3.
* Re-add GIT_SUBVERSION option.
Comment 1 Yasuhiro KIMURA 2015-07-18 04:23:34 UTC
Created attachment 158931 [details]
Updated patch.

Patch is updated in order to 
* make 'magit-version' variable in magit-version.el set properly.
* pet portlint
So please commit updated patch instead of original one.

Regards.
Comment 2 commit-hook freebsd_committer 2015-07-22 02:00:28 UTC
A commit references this bug:

Author: kuriyama
Date: Wed Jul 22 02:00:26 UTC 2015
New revision: 392655
URL: https://svnweb.freebsd.org/changeset/ports/392655

Log:
  - Upgrade to 2.1.0.

  PR:		ports/201654
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>

Changes:
  head/devel/magit/Makefile
  head/devel/magit/distinfo
  head/devel/magit/files/
  head/devel/magit/files/patch-default.mk
  head/devel/magit/pkg-plist
Comment 3 Jun Kuriyama freebsd_committer 2015-07-22 02:01:09 UTC
Committed, thanks!