Bug 201655 - graphics/inkscape: fails to compile
Summary: graphics/inkscape: fails to compile
Status: Closed DUPLICATE of bug 194760
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2015-07-17 18:13 UTC by voh.ron
Modified: 2015-10-29 09:08 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description voh.ron 2015-07-17 18:13:25 UTC
inkscape-0.91 fails to compile

# uname -a
FreeBSD aaaa.bbbb.cc 10.1-RELEASE-p10 FreeBSD 10.1-RELEASE-p10 #0: Wed May 13 06:54:13 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64



extension/internal/bitmap/imagemagick.o: In function `Inkscape::Extension::Internal::Bitmap::ImageMagickDocCache::readImage(char const*, Magick::Image*)':
extension/internal/bitmap/imagemagick.cpp:(.text+0x36f): undefined reference to `Magick::Blob::base64(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)'
extension/internal/bitmap/imagemagick.cpp:(.text+0x408): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
extension/internal/bitmap/imagemagick.o: In function `Inkscape::Extension::Internal::Bitmap::ImageMagickDocCache::readImage(char const*, Magick::Image*)':
extension/internal/bitmap/imagemagick.cpp:(.text+0x36f): undefined reference to `Magick::Blob::base64(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> >)'
extension/internal/bitmap/imagemagick.cpp:(.text+0x408): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
extension/internal/image-resolution.o: In function `Inkscape::Extension::Internal::ImageResolution::readmagick(char const*)':
extension/internal/image-resolution.cpp:(.text+0x48b): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
extension/internal/image-resolution.o: In function `Inkscape::Extension::Internal::ImageResolution::readmagick(char const*)':
extension/internal/image-resolution.cpp:(.text+0x48b): undefined reference to `Magick::Image::read(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&)'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
Makefile:6891: recipe for target 'inkscape' failed
gmake[5]: *** [inkscape] Error 1
gmake[5]: *** Waiting for unfinished jobs....
c++: error: linker command failed with exit code 1 (use -v to see invocation)
Makefile:6895: recipe for target 'inkview' failed
gmake[5]: *** [inkview] Error 1
gmake[5]: Leaving directory '/usr/ports/graphics/inkscape/work/inkscape-0.91/src'
Makefile:5048: recipe for target 'all' failed
gmake[4]: *** [all] Error 2
gmake[4]: Leaving directory '/usr/ports/graphics/inkscape/work/inkscape-0.91/src'
Makefile:1401: recipe for target 'all-recursive' failed
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory '/usr/ports/graphics/inkscape/work/inkscape-0.91'
Makefile:1096: recipe for target 'all' failed
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory '/usr/ports/graphics/inkscape/work/inkscape-0.91'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/graphics/inkscape
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/inkscape
Comment 1 Koop Mast freebsd_committer 2015-07-29 12:49:02 UTC
Please post 'make showconfig' of both graphics/ImageMagick and graphics/inkscape
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-10-29 09:04:23 UTC
@Koop, this appears to be a duplicate of bug 194760, please close in favour of that.
Comment 3 Kurt Jaeger freebsd_committer 2015-10-29 09:08:10 UTC

*** This bug has been marked as a duplicate of bug 194760 ***