Bug 201717 - sysutils/screen example screenrc contains incorrect command
Summary: sysutils/screen example screenrc contains incorrect command
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Cy Schubert
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-20 14:54 UTC by David Maxwell
Modified: 2015-09-08 16:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Maxwell 2015-07-20 14:54:35 UTC
sysutils/screen/files/screenrc.sample, which gets installed in /usr/local/etc
includes the following (last) line:

logfile flush

The logfile directive in screen has two forms, one which takes a filename argument (the file name to log to when ^aH logging is turned on), and one which takes a secondary keyword flush and a time in seconds of how often to flush.

By including flush without the secondary argument, the sample rc file sets the logfile name for all screens to $HOME/flush (lacking a '%n' in the argument, it won't create separate files for each screen either).

This is probably not what was intended.
Comment 1 commit-hook freebsd_committer 2015-07-22 03:14:43 UTC
A commit references this bug:

Author: cy
Date: Wed Jul 22 03:14:32 UTC 2015
New revision: 392658
URL: https://svnweb.freebsd.org/changeset/ports/392658

Log:
  Remove incorrect screenrc command.

  PR:		201717

Changes:
  head/sysutils/screen/Makefile
  head/sysutils/screen/files/screenrc.sample
Comment 2 Cy Schubert freebsd_committer 2015-07-22 03:16:19 UTC
Removed the offending command. Fixed.
Comment 3 commit-hook freebsd_committer 2015-09-08 16:45:32 UTC
A commit references this bug:

Author: feld
Date: Tue Sep  8 16:45:01 UTC 2015
New revision: 396410
URL: https://svnweb.freebsd.org/changeset/ports/396410

Log:
  MFH: r392658

  Remove incorrect screenrc command.

  PR:		201717
  Approved by:	ports-secteam (with hat)

Changes:
_U  branches/2015Q3/
  branches/2015Q3/sysutils/screen/Makefile
  branches/2015Q3/sysutils/screen/files/screenrc.sample