Bug 201814 - [MAINTAINER] graphics/qgis: update to 2.10.1
Summary: [MAINTAINER] graphics/qgis: update to 2.10.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-24 13:27 UTC by Rainer Hurling
Modified: 2015-07-26 12:54 UTC (History)
2 users (show)

See Also:
rhurlin: maintainer-feedback+


Attachments
patch to update QGIS to 2.10.1 (2.88 KB, patch)
2015-07-24 13:27 UTC, Rainer Hurling
no flags Details | Diff
Poudriere log for QGIS 2.10.1 on 9.3 am64 with default options enabled (230.18 KB, application/zip)
2015-07-24 13:29 UTC, Rainer Hurling
no flags Details
Poudriere log for QGIS 2.10.1 on 9.3 am64 with default options enabledPoudriere log for QGIS 2.10.1 on 10.1 am64 with default options enabled (229.91 KB, application/zip)
2015-07-24 13:29 UTC, Rainer Hurling
no flags Details
Poudriere log for QGIS 2.10.1 on HEAD am64 with all options disabled (150.64 KB, application/zip)
2015-07-24 13:30 UTC, Rainer Hurling
no flags Details
Poudriere log for QGIS 2.10.1 on HEAD am64 with all options enabled (249.29 KB, application/zip)
2015-07-24 13:31 UTC, Rainer Hurling
no flags Details
Poudriere log for QGIS 2.10.1 on HEAD am64 with default options enabled (229.84 KB, application/zip)
2015-07-24 13:31 UTC, Rainer Hurling
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling 2015-07-24 13:27:41 UTC
Created attachment 159143 [details]
patch to update QGIS to 2.10.1

- Update to version 2.10.1
- reintegrate USES=iconv:wchar_t
- remove dependency on graphics/gdal-grass, see bug #201483


===========================
bug #201483 for QGIS 2.10.0 is obsolete now and can be remove without a commit.
===========================


Poudriere logs are attached for HEAD (default, all options enabled; all options disabled), 10.1 (default options enabled) and 9.3 (default options enabled).

portlint -AC
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 1 warning found.
Comment 1 Rainer Hurling 2015-07-24 13:29:07 UTC
Created attachment 159144 [details]
Poudriere log for QGIS 2.10.1 on 9.3 am64 with default options enabled
Comment 2 Rainer Hurling 2015-07-24 13:29:48 UTC
Created attachment 159145 [details]
Poudriere log for QGIS 2.10.1 on 9.3 am64 with default options enabledPoudriere log for QGIS 2.10.1 on 10.1 am64 with default options enabled
Comment 3 Rainer Hurling 2015-07-24 13:30:55 UTC
Created attachment 159146 [details]
Poudriere log for QGIS 2.10.1 on HEAD am64 with all options disabled
Comment 4 Rainer Hurling 2015-07-24 13:31:38 UTC
Created attachment 159147 [details]
Poudriere log for QGIS 2.10.1 on HEAD am64 with all options enabled
Comment 5 Rainer Hurling 2015-07-24 13:31:59 UTC
Created attachment 159148 [details]
Poudriere log for QGIS 2.10.1 on HEAD am64 with default options enabled
Comment 6 commit-hook freebsd_committer 2015-07-25 20:21:32 UTC
A commit references this bug:

Author: riggs
Date: Sat Jul 25 20:21:26 UTC 2015
New revision: 392906
URL: https://svnweb.freebsd.org/changeset/ports/392906

Log:
  Update to upstream version 2.10.1

  PR:		201814
  Submitted by:	rhurlin@gwdg.de (maintainer)

Changes:
  head/graphics/qgis/Makefile
  head/graphics/qgis/distinfo
  head/graphics/qgis/pkg-plist
Comment 7 Rainer Hurling 2015-07-26 12:54:26 UTC
Thanks for the commit.

Could you please also close bug #201483 ? It is obsolete, because it was for 2.10.0 and the patch is integrated in 2.10.1. Thanks in advance.