Bug 201913 - Kernel panic during stopping syncthing daemon
Summary: Kernel panic during stopping syncthing daemon
Status: Closed DUPLICATE of bug 200846
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-27 08:10 UTC by martin
Modified: 2016-08-15 12:57 UTC (History)
3 users (show)

See Also:


Attachments
Photo of the kernel trace after kernel panic (96.15 KB, image/jpeg)
2015-07-27 08:10 UTC, martin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description martin 2015-07-27 08:10:30 UTC
Created attachment 159299 [details]
Photo of the kernel trace after kernel panic

FreeBSD versions: multiple 10.1-RELEASE versions up to p14 have been tested.

How to reproduce:
/usr/local/etc/rc.d/syncthing stop

(You need latest net/syncthing installed.)

The panic appeared after some syncthing update.

The system does not write coredump, but I can reproduce it every time and it is very annoying, because I cannot shut down the server properly (I need syncthing). I attached a photo of the trace, I hope it's enough.
Comment 1 martin 2015-08-27 20:00:39 UTC
Panic also occurs with 10.2-RELEASE and syncthing-0.11.18.

I forgot to tell that the kernel is not GENERIC.

Lines added:

> options         DDB
> options         GDB
> 
> options         ALTQ
> options         ALTQ_CBQ        # Class Bases Queueing
> options         ALTQ_RED        # Random Early Detection
> options         ALTQ_RIO        # RED In/Out
> options         ALTQ_HFSC       # Hierarchical Packet Scheduler
> options         ALTQ_CDNR       # Traffic conditioner
> options         ALTQ_PRIQ       # Priority Queueing
> options         MROUTING
Comment 2 Peter Wemm freebsd_committer freebsd_triage 2015-09-08 20:24:52 UTC
FWIW; duplicate of bug #202978

There is a workaround there; the problem is 'local announce' is triggering an ipv6 multicast kernel bug.
Comment 3 martin 2015-11-16 15:21:16 UTC
I want to confirm that the workaround works. Thank you Peter.
Comment 4 Brad Davis freebsd_committer 2016-08-15 12:32:53 UTC
Fixed as noted in PR 202978.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-15 12:37:04 UTC
Re-open. Will add more context/information shortly.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-15 12:57:58 UTC
Underlying userland causing kernel panic is being tracked in the duplicated (original) bug 200846

*** This bug has been marked as a duplicate of bug 200846 ***