Bug 202005 - [PATCH] Update security/tor-devel to 0.2.7.2-alpha
Summary: [PATCH] Update security/tor-devel to 0.2.7.2-alpha
Status: Closed DUPLICATE of bug 203421
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Brendan Fabeny
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-07-31 12:29 UTC by Neel Chauhan
Modified: 2015-09-28 17:28 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (bf)


Attachments
Patch to update security/tor-devel to 0.2.7.2-alpha (1.12 KB, patch)
2015-07-31 12:29 UTC, Neel Chauhan
no flags Details | Diff
Poudriere build log for security/tor-devel 0.2.7.2-alpha (44.38 KB, text/x-log)
2015-07-31 12:30 UTC, Neel Chauhan
no flags Details
Updated patch for security/tor-devel 0.2.7.2-alpha (1.07 KB, patch)
2015-09-15 15:13 UTC, Neel Chauhan
no flags Details | Diff
Poudriere build log for security/tor-devel 0.2.7.2-alpha on FreeBSD 9.3 (44.96 KB, text/plain)
2015-09-15 15:13 UTC, Neel Chauhan
no flags Details
Poudriere build log for security/tor-devel 0.2.7.2-alpha on FreeBSD 10.2 (44.52 KB, text/plain)
2015-09-15 15:14 UTC, Neel Chauhan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan 2015-07-31 12:29:34 UTC
Created attachment 159410 [details]
Patch to update security/tor-devel to 0.2.7.2-alpha

Hi,
I have a patch to update the port security/tor-devel to 0.2.7.2-alpha. The poudriere build log will be uploaded shortly.

Keep in mind that tor-devel 0.2.7.2-alpha now requires OpenSSL 1.0 or higher. I have added the lines to the Makefile which checks for the version of FreeBSD, and if it's FreeBSD 8 or 9, if the OpenSSL port is installed.
Thanks,
Neel Chauhan
Comment 1 Neel Chauhan 2015-07-31 12:30:27 UTC
Created attachment 159411 [details]
Poudriere build log for security/tor-devel 0.2.7.2-alpha

Also, here is the poudriere build log.
-Neel
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-07-31 13:52:29 UTC
Perhaps adding 'Please define WITH_OPENSSL_PORT=foo' to the IGNORE message would help users recover from the failure.

Longer term, this feels like something bsd.openssl.mk should handle, perhaps allowing ports to ask for, or to look for a particular minimum version.
Comment 3 Neel Chauhan 2015-09-15 15:13:27 UTC
Created attachment 161067 [details]
Updated patch for security/tor-devel 0.2.7.2-alpha

Hi,
I have a updated patch for security/tor-devel 0.2.7.2-alpha, which is attached. I have decided to change these lines:

.if ${OSVERSION} < 1000000 && !defined(WITH_OPENSSL_PORT)
IGNORE=		tor-devel requires OpenSSL 1.0.0+
.endif

to this:

.if ${OSVERSION} < 1000000
WITH_OPENSSL_PORT=	yes
.endif

Tell me what you think.
I will upload the poudriere build logs for FreeBSD 9.3 and 10.2 shortly.

Thanks,
Neel Chauhan
Comment 4 Neel Chauhan 2015-09-15 15:13:52 UTC
Created attachment 161068 [details]
Poudriere build log for security/tor-devel 0.2.7.2-alpha on FreeBSD 9.3
Comment 5 Neel Chauhan 2015-09-15 15:14:15 UTC
Created attachment 161069 [details]
Poudriere build log for security/tor-devel 0.2.7.2-alpha on FreeBSD 10.2
Comment 6 Neel Chauhan 2015-09-28 17:28:21 UTC

*** This bug has been marked as a duplicate of bug 203421 ***