Bug 202029 - math/gmp: math/mpfr: libtool:keepla causes build failure for gnome-calculator in jhbuild
Summary: math/gmp: math/mpfr: libtool:keepla causes build failure for gnome-calculator...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alex Dupre
URL:
Keywords:
: 202031 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-01 17:26 UTC by Ting-Wei Lan
Modified: 2016-02-10 17:16 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ale)
ale: exp-run?


Attachments
Remove .la files for gmp and mpfr (1.86 KB, patch)
2015-08-05 09:56 UTC, Ting-Wei Lan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2015-08-01 17:26:20 UTC
Both gmp and mpfr ports install .la files. Can we remove them to prevent odd build problems?

libgmp.la and libmpfr.la cause gnome-calculator to fail to build in jhbuild because wrong version of libpangoft2-1.0.so.0 is found during linking:
/home/lantw44/gnome/devinstall/lib/libgtk-3.so: undefined reference to `pango_fc_font_map_config_changed'
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Removing libgmp.la and libmpfr.la fixes the problem.
Comment 1 Ting-Wei Lan 2015-08-05 09:49:16 UTC
A simple build test done by running 'poudriere bulk' on all ports having math/gmp or math/mpfr dependencies shows no build failure, so removing libgmp.la and libmpfr.la seems to be safe.
Comment 2 Ting-Wei Lan 2015-08-05 09:56:50 UTC
Created attachment 159569 [details]
Remove .la files for gmp and mpfr
Comment 3 Ting-Wei Lan 2015-11-13 16:15:33 UTC
This problem still doesn't get fixed and we still see build failure caused by .la files. Does anyone have time to review the patch?
Comment 4 Antoine Brodin freebsd_committer 2015-12-02 06:33:47 UTC
*** Bug 202031 has been marked as a duplicate of this bug. ***
Comment 6 Ting-Wei Lan 2016-02-10 14:38:52 UTC
The patch has stayed in bugzilla for more than 6 months. Can it be committed?
Comment 7 commit-hook freebsd_committer 2016-02-10 16:13:30 UTC
A commit references this bug:

Author: kwm
Date: Wed Feb 10 16:13:25 UTC 2016
New revision: 408635
URL: https://svnweb.freebsd.org/changeset/ports/408635

Log:
  Drop :keepla from USES:libtool.

  PR:		202029
  Submitted by:	Ting-Wei Lan <lantw44@gmail.com>
  Exp-run by:	antoine@
  Approved by:	maintainer timeout (6 months)

Changes:
  head/math/gmp/Makefile
  head/math/gmp/pkg-plist
  head/math/mpfr/Makefile
  head/math/mpfr/pkg-plist
Comment 8 Koop Mast freebsd_committer 2016-02-10 17:16:21 UTC
Committed thanks!