Bug 202068 - www/chromium: can't login to google account - white screen
Summary: www/chromium: can't login to google account - white screen
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-chromium mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-03 23:42 UTC by Tony Narlock
Modified: 2017-11-26 20:46 UTC (History)
5 users (show)

See Also:
cpm: maintainer-feedback+


Attachments
After clicking "Sign in to Chromium". (56.64 KB, image/png)
2015-08-03 23:42 UTC, Tony Narlock
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Narlock 2015-08-03 23:42:30 UTC
Created attachment 159509 [details]
After clicking "Sign in to Chromium".

$ freebsd-version -ku; uname -apKU                                                           
10.1-RELEASE-p16
10.1-RELEASE-p16
FreeBSD z600 10.1-RELEASE-p16 FreeBSD 10.1-RELEASE-p16 #0: Tue Jul 28 12:04:19 UTC 2015     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64 amd64 1001000 1001000


$ pkg info chromium-44.0.2403.125 
chromium-44.0.2403.125
Name           : chromium
Version        : 44.0.2403.125
Installed on   : Mon Aug  3 14:27:40 CDT 2015
Origin         : www/chromium
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : www
Licenses       : MPL and LGPL21 and BSD3CLAUSE
Maintainer     : chromium@FreeBSD.org
WWW            : http://www.chromium.org/Home
Comment        : Google web browser based on WebKit
Options        :

To create:

1. Open chrome
2. Go to Chrome Settings  / chrome://settings
3. Click "Sign in to Chromium" button
Comment 1 Yonas Yanfa 2016-10-26 19:22:05 UTC
I'm seeing this now with Chromium 52.0.2743.116 (64-bit). Must be a regression.

I can sign into Chromium for my main account, but if I create a second account and try to sign in, a blank white popup box shows.
Comment 2 Tony Narlock 2016-11-25 02:00:42 UTC
(In reply to Yonas Yanfa from comment #1)

Confirmed white screen on login for 54.0.2840.100 also.
Comment 3 Patrick McMunn 2017-08-06 05:40:43 UTC
I can confirm this is still an issue with at least the 64-bit version of Chromium chromium-59.0.3071.115_2. I was unable to test 32-bit because it segfaults immediately.
Comment 4 Carlos J. Puga Medina freebsd_committer 2017-08-08 11:56:22 UTC
(In reply to Patrick from comment #3)

It works fine for me. 

Did you try to create a new profile?
Comment 5 Patrick McMunn 2017-08-10 03:28:41 UTC
(In reply to Carlos J. Puga Medina from comment #4)
I did a fresh install of FreeBSD on the netbook in question only a week or two ago, so everything is fresh and new. Just so there is no confusion, I have no problem signing into my Google account. But this is separate from signing into Chromium.
Comment 6 Grégory Reinbold 2017-08-11 09:29:41 UTC
Hi,

Same issue here. Can't Sign in to Chromium. I see just a white screen. And it bug when I maximize the window. I can't see anything until a restore the window's size. Chromium does not show any error.

# uname -a
FreeBSD lrd 11.1-RELEASE FreeBSD 11.1-RELEASE #0 r321309: Fri Jul 21 02:08:28 UTC 2017     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

I compiled all packages using Poudriere. Here is the build options of Chromium:

# cat /usr/local/etc/poudriere.d/11-1amd64-workstation-options/www_chromium/options

# This file is auto-generated by 'make config'.
# Options for chromium-59.0.3071.115_2
_OPTIONS_READ=chromium-59.0.3071.115_2
_FILE_COMPLETE_OPTIONS_LIST=CODECS DRIVER GCONF KERBEROS ALSA PULSEAUDIO SNDIO DEBUG TEST
OPTIONS_FILE_SET+=CODECS
OPTIONS_FILE_SET+=DRIVER
OPTIONS_FILE_SET+=GCONF
OPTIONS_FILE_SET+=KERBEROS
OPTIONS_FILE_UNSET+=ALSA
OPTIONS_FILE_UNSET+=PULSEAUDIO
OPTIONS_FILE_SET+=SNDIO
OPTIONS_FILE_UNSET+=DEBUG
OPTIONS_FILE_UNSET+=TEST

Resume:
- I can't use Chromium in a maximized window
- I can't Sign in to Chromium with my Google account

Regards
Comment 7 Carlos J. Puga Medina freebsd_committer 2017-08-11 12:19:15 UTC
(In reply to Grégory from comment #6)

Try to disable hardware acceleration through the command line and see if it helps to restore the main windows size and the white screen sign in

% chrome --disable-gpu
Comment 8 Grégory Reinbold 2017-08-11 14:46:52 UTC
(In reply to Carlos J. Puga Medina from comment #7)

It works. Thank you very much!
Comment 9 vali gholami 2017-11-26 20:46:38 UTC
MARKED AS SPAM