Bug 202071 - ixgbe continuously complains about unsupported SFP
Summary: ixgbe continuously complains about unsupported SFP
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.2-STABLE
Hardware: Any Any
: --- Affects Many People
Assignee: Eric Joyner
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2015-08-04 07:27 UTC by babak
Modified: 2018-05-28 20:11 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description babak 2015-08-04 07:27:14 UTC
After r283620, ixgbe driver continuously spams console about unsupported SFP, every 3 seconds. Sample log follows:

Aug  4 11:54:36 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:36 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:36 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:36 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:39 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:39 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:39 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:39 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:42 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:42 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:42 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Aug  4 11:54:42 joker kernel: WARNING: Intel (R) Network Connections are quality tested using Intel (R) Ethernet Optics. Using untested modules is not supported and may cause unstable operation or damage to the module or the adapter. Intel Corporation is not responsible for any harm caused by using untested modules.
Comment 1 Sean Bruno freebsd_committer 2015-08-04 15:48:46 UTC
Are you using unsupported SFP modules?
Comment 2 babak 2015-08-04 16:45:03 UTC
Yes. I use Cisco SFPs.
Comment 3 Sean Bruno freebsd_committer 2015-08-04 16:48:24 UTC
(In reply to Sean Bruno from comment #1)
This looks like the "sfp_probe" function firing every 3 seconds and noticing that you have "unsupported" SFP modules.  Wow, that's spammy.

You can use the tuneable "hw.ix.unsupported_sfp" to turn this off, hopefully.
Comment 4 babak 2015-08-05 04:35:30 UTC
Doesn't setting hw.ix.unsupported_sfp=0 disable my SFP then? I actually need that setting to be enabled, and as I mentioned in original PR, this behavior just happened after commit r283620. In older builds I just see the message once during the interface activation.
Comment 5 Hiren Panchasara freebsd_committer 2015-08-09 18:23:11 UTC
Eric,

Can you please take a look at this regression? It is super annoying to have the console getting spammed like this. :-)

Thanks in advance.
Comment 6 olivier 2015-09-13 10:44:05 UTC
This behavior is very annoying: Can you fix this regression ?
Comment 7 Bjoern A. Zeeb freebsd_committer 2015-09-13 11:13:34 UTC
I think the proper (and acceptable) behaviour would be to log it once on driver attach (SPF insert) but not continuously.  I did see it on every ifconfig up for a while in the past, which was already super-annoying with a 3rd party SPF.
Comment 8 Eric Joyner freebsd_committer 2015-09-13 13:14:36 UTC
Lazy fix if it's really bothering you would be to redefine EWARN in ixgbe_osdep.h to print out nothing. You won't get any messages though, but I'm sure you'll know at this point if you're using an unsupported SFP or not. :p

I'll work on getting EWARN to only fire once on attach(), since EWARN is only ever used to print out the message complaining about an unsupported SFP module.
Comment 9 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:48:10 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.