Bug 202287 - databases/postgresql94-server: pgxml.so fails to load while creating xml2 extension in postgresql
Summary: databases/postgresql94-server: pgxml.so fails to load while creating xml2 ext...
Status: Closed DUPLICATE of bug 202649
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: pgsql
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-13 10:44 UTC by pavlov
Modified: 2015-12-02 20:51 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pavlov 2015-08-13 10:44:13 UTC
FreeBSD 10.1-RELEASE-p17

while executing the following postgresql command:

create extension xml2;

the following error raises:

ERROR:  could not load library "/usr/local/lib/postgresql/pgxml.so": dlopen (/usr/local/lib/postgresql/pgxml.so) failed: /usr/local/lib/postgresql/pgxml.so: Undefined symbol "xml_ereport"



package list and postgresql configure are below:

pkg version
apr-1.5.2.1.5.4                    =
db5-5.3.28_2                       =
dialog4ports-0.1.5_2               =
expat-2.1.0_3                      =
gdbm-1.11_2                        =
gettext-runtime-0.19.5.1           =
indexinfo-0.2.3                    =
libgcrypt-1.6.3                    =
libgpg-error-1.19_1                =
libxml2-2.9.2_3                    =
libxslt-1.1.28_7                   =
pkg-1.5.6                          =
portmaster-3.17.7                  =
postgresql94-client-9.4.4          =
postgresql94-contrib-9.4.4_1       =
postgresql94-server-9.4.4_1        =
serf-1.3.8                         =
sqlite3-3.8.10.2                   =
subversion-1.8.14                  =

pg_config 
BINDIR = /usr/local/bin
DOCDIR = /usr/local/share/doc/postgresql
HTMLDIR = /usr/local/share/doc/postgresql
INCLUDEDIR = /usr/local/include
PKGINCLUDEDIR = /usr/local/include/postgresql
INCLUDEDIR-SERVER = /usr/local/include/postgresql/server
LIBDIR = /usr/local/lib
PKGLIBDIR = /usr/local/lib/postgresql
LOCALEDIR = /usr/local/share/locale
MANDIR = /usr/local/man
SHAREDIR = /usr/local/share/postgresql
SYSCONFDIR = /usr/local/etc/postgresql
PGXS = /usr/local/lib/postgresql/pgxs/src/makefiles/pgxs.mk
CONFIGURE = '--with-libraries=/usr/local/lib' '--with-includes=/usr/local/include' '--enable-thread-safety' '--disable-debug' '--enable-nls' '--without-pam' '--with-openssl' '--without-gssapi' '--prefix=/usr/local' '--localstatedir=/var' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=amd64-portbld-freebsd10.1' 'build_alias=amd64-portbld-freebsd10.1' 'CC=cc' 'CFLAGS=-O2 -pipe  -fstack-protector -fno-strict-aliasing' 'LDFLAGS= -L/usr/local/lib -lpthread  -fstack-protector' 'LIBS=' 'CPPFLAGS=' 'CPP=cpp' 'LDFLAGS_SL='
CC = cc
CPPFLAGS = -I/usr/local/include -I/usr/local/include
CFLAGS = -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -Wmissing-format-attribute -Wformat-security -fno-strict-aliasing -fwrapv -Wno-unused-command-line-argument -O2 -pipe  -fstack-protector -fno-strict-aliasing
CFLAGS_SL = -fPIC -DPIC
LDFLAGS = -L../../../src/common -L/usr/local/lib -lpthread -fstack-protector -L/usr/local/lib -Wl,--as-needed -Wl,-R'/usr/local/lib'
LDFLAGS_EX = 
LDFLAGS_SL = 
LIBS = -lpgcommon -lpgport -lintl -lssl -lcrypto -lz -lreadline -lcrypt -lm 
VERSION = PostgreSQL 9.4.4


select version();
                                                                   version                                                                   
---------------------------------------------------------------------------------------------------------------------------------------------
 PostgreSQL 9.4.4 on amd64-portbld-freebsd10.1, compiled by FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512, 64-bit
Comment 1 Palle Girgensohn freebsd_committer 2015-12-02 20:51:18 UTC

*** This bug has been marked as a duplicate of bug 202649 ***