Bug 202317 - devel/gps: Errors/warnings do not appear in the 'Locations' window.
Summary: devel/gps: Errors/warnings do not appear in the 'Locations' window.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: John Marino
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-14 09:07 UTC by Rod Kay
Modified: 2016-07-08 22:29 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (marino)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rod Kay 2015-08-14 09:07:36 UTC
Hi,

   When GPS compiles a file and an error occurs, the error (with file/line number) is usually displayed in the 'Locations' window, which allows easy navigation to the error source line. Atm, this does not happen.


   With a simple test file which contains an error, GPS shows ...

    gprbuild -ws -c -f -u -P/usr/home/rod/Desktop/default.gpr hello_world.adb
    ada -c -g -O2 hello_world.adb
    [2015-08-14 18:59:31] process exited with status 4, elapsed time: 00.31s

   ... in the 'Messages' window, and nothing in the 'Locations' window.


   The test code was ...

procedure hello_World
is
begin
--   null;
end hello_World;
   


Regards.
Comment 1 John Marino freebsd_committer 2015-11-20 09:12:31 UTC
I can't reproduce this.

Using the provided example,
On windows GPL 2015, Locations tab:

V  Builder results (1 item)
   V  hello_world.adb (1 item)
      5:1   statement expected

On DragonFly using GPS 6.1.1 (20150118):
V  Builder results (1 item)
   V  hello_world.adb (1 item)
      5:1   statement expected 


Exactly the same!
Comment 2 Rod Kay 2015-12-01 10:15:33 UTC
   The problem does *not* occur on dragonflyBSD. It does occur with freeBSD 10.2 and 11.

   Also, the gps log file (in ~/.gps) intermittently shows an exception (with callback trace) related to tasking, though this made no difference to the presence/absence of the problem. It occurs during startup, prior to the user doing the build command which produces the prob.
Comment 3 John Marino freebsd_committer 2015-12-07 15:26:08 UTC
how new is your FreeBSD 11?
Comment 4 Rod Kay 2015-12-08 04:50:14 UTC
I installed from "FreeBSD-11.0-CURRENT-amd64-20151119-r291085-disc1.iso".
Comment 5 Rod Kay 2015-12-08 07:37:56 UTC
No change after 'pkg update' on fBSD11.
Comment 6 commit-hook freebsd_committer 2016-06-11 18:42:18 UTC
A commit references this bug:

Author: marino
Date: Sat Jun 11 18:41:55 UTC 2016
New revision: 416739
URL: https://svnweb.freebsd.org/changeset/ports/416739

Log:
  devel/gps: Upgrade to 2016 release (plus 2 dependencies)

  x11-toolkits/gtkada3: Upgrade version 3.8.3.2 => 3.14.2
  devel/gnatcoll:       Upgrade version    2015 => 2016
  devel/gps:            Upgrade version 6.1.1.0 => 2016

  This upgrade appears to work flawlessly on DragonFly, but
  on FreeBSD the PR list below regarding navigation to code
  error is unfortunately still valid.

  PR:	202317

Changes:
  head/devel/gnatcoll/Makefile
  head/devel/gnatcoll/distinfo
  head/devel/gnatcoll/files/patch-Makefile
  head/devel/gnatcoll/files/patch-configure
  head/devel/gnatcoll/pkg-plist
  head/devel/gps/Makefile
  head/devel/gps/distinfo
  head/devel/gps/files/patch-Makefile.in
  head/devel/gps/files/patch-gps_Makefile
  head/devel/gps/files/patch-shared.gpr
  head/devel/gps/pkg-plist
  head/x11-toolkits/gtkada3/Makefile
  head/x11-toolkits/gtkada3/distinfo
  head/x11-toolkits/gtkada3/files/patch-Makefile.in
  head/x11-toolkits/gtkada3/files/patch-configure
  head/x11-toolkits/gtkada3/files/patch-docs_Makefile
  head/x11-toolkits/gtkada3/files/patch-docs_Makefile.in
  head/x11-toolkits/gtkada3/files/patch-namespace
  head/x11-toolkits/gtkada3/files/patch-src_opengl_gtkglarea.h
  head/x11-toolkits/gtkada3/pkg-plist
Comment 7 commit-hook freebsd_committer 2016-07-08 22:28:37 UTC
A commit references this bug:

Author: marino
Date: Fri Jul  8 22:28:05 UTC 2016
New revision: 418247
URL: https://svnweb.freebsd.org/changeset/ports/418247

Log:
  devel/gps: Fix compiler error highlight on FreeBSD

  On DragonFly, GPS has been properly highlighting code errors during
  compilation, but on FreeBSD nothing happens.  Luckily Rod Kay has been
  persistent in diagnosing the cause and he finally isolated it to a
  too-short timeout interval for Expect calls.  The timeout period was
  set to 1 millisecond, the absolute shortest interval possible.  While
  Linux and DF could complete the function call during this time, FreeBSD
  requires at least 10 milliseconds to do the same.

  I'm setting the timeout to 100 milliseconds to ensure this functionality
  works on FreeBSD.  Rod and I can't immediately see any negative impact
  to extending the timeout and we're casually pinging Adacore to understand
  the orignal 1-ms value.

  PR:	202317

Changes:
  head/devel/gps/Makefile
  head/devel/gps/files/patch-kernel_src_gps-kernel-timeout.adb
Comment 8 John Marino freebsd_committer 2016-07-08 22:29:38 UTC
Good job, Charlie5!